[ubuntu 14.04LTS] - an error that has stumped me

so I’ve been running piaware for over a month on my server, and it’s been doing great. However, during this reinstallation, i’m running into a problem and out of options.

I’ve decided to FINALLY note that i’ve been running piaware nefariously behind a Zentyal 4.1.5 Active Directory server (this server is built on & runs on ubuntu Server 14.04LTS). It did fine for a month, then a typo during an update, and well, i’ve been running around with my head on fire for 4 days now.

since I had to reinstall zentyal from scratch, I decided to take advantage of switching from 32 to 64 bit architecture. If this is a problem, go figure…

SO, since the switch, i’ve been running into this error whilst installing Dump1090 muta

	dpkg-shlibdeps -Tdebian/dump1090-mutability.substvars debian/dump1090-mutability/usr/bin/dump1090-mutability debian/dump1090-mutability/usr/bin/view1090-mutability
dpkg-shlibdeps: error: no dependency information found for /usr/local/lib/librtlsdr.so.0 (used by debian/dump1090-mutability/usr/bin/dump1090-mutability)
dh_shlibdeps: dpkg-shlibdeps -Tdebian/dump1090-mutability.substvars debian/dump1090-mutability/usr/bin/dump1090-mutability debian/dump1090-mutability/usr/bin/view1090-mutability returned exit code 2
make: *** [binary] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
[exit] Error building dump1090-mutability, script will now exit.

I’ve looked into librtlsdr, and it is where it’s supposed to be. gedit gives me an error where I can’t read the data, so I didn’t know what that meant.

There was a similar thread to this, and I tried as many options and fixes as listed in there, including apt-get remove, purge, reinstall, as well as physically deleting librtlsdr from the server. I also added i386 architecture to my dpkg list (i had a similar issue with Teamviewer), and deleted the lot and tried again. I also tried an automated script I’d found on FA, but with the same result. Assistance in the matter would be greatly appreciated. Thanks!


You need to remove the unmanaged copies of librtlsdr in /usr/local/lib on the build machine, the debian packaging system is trying to work out the dependencies it should add for a binary that links to the copies in /usr/local/lib and failing because those copies were not installed from a package.

Note that you don’t have to build the dump1090-mutability package on the machine that you’re going to install on - you can build elsewhere (so long as it’s basically the same sort of system) and copy the resulting .deb over.

It’s good to have a second pair of eyes on this, I appreciate the help obj. The system is back up and running. :smiley: