FlightAware Discussions

Tweaks


#42

.
Did you carry out following steps when changing skin from 2-clock to SkyView?


#now go to folder dump1090-mutability 
cd /usr/share/dump1090-mutability 
#first change name of folder html to original-html 
#this preserves the original html folder, and enables revert in case something goes wrong 
sudo mv html original-html

To find out if you have renamed original folder to original-html, give this command


ls /usr/share/dump1090-mutability

If yes, then to revert do this:


#Go to folder dump1090-mutability 
cd /usr/share/dump1090-mutability    

#Change name of folder html to fa-html 
#this preserves the SkyView html folder, and enables revertto SkyView in case something goes wrong 
sudo mv html fa-html    

#Now change name of original-html to html
sudo mv original-html html   


#43

Yes on the top question. And all done. (small typo in changing original-html, missed the “mv” …all good :))

thanks. :slight_smile:


#44

Thanks for pointing out. Fixed now for benefit of anyone else who may use it in future.


#45

That’s why I pointed it out in case of that situation :slight_smile:


#46

Mmm, I am trying to use the first script with the newest version of the image, and get the

“sudo: unable to execute ./optimize-gain.py: No such file or directory”

First I thought this because I thought copying and pasting left out all the \ and " and :, but it still seems not to work…

Python is installed, 2:7.13-2


#47
sudo chmod +x optimize-gain.py

sudo ./optimize-gain.py

#48

If I do not chmod, it says

“sudo: ./optimize-gain.py: command not found”

After the chmod command, it gives the error message quoted above.

“sudo: unable to execute ./optimize-gain.py: No such file or directory”

apt-get install python tells me I already have the newest version…


#49

@biekerc

Do this test

#Delete existing file optimize-gain.py
sudo rm optimize-gain.py 

#Create new blank file optimize-gain.py and make it executeable
sudo touch optimize-gain.py 
sudo chmod +x optimize-gain.py 

#Run the new blank file
sudo ./optimize-gain.py 

Do you still get error message, or get nothing?

If you still get error message, then problem is with your python installation.

If you get nothing, then problem was in code. In this case copy-pate the code in the new blank file, save file then again give following command to run it.

sudo ./optimize-gain.py


#50

Hahaa, success!!! :grinning:

Creating the file on the pi did the trick.

Before, created the file with the windows editor, copied the skript into it and transferred it with filezilla. Not sure if that generally does not work or just some odd occurence. Do not want to check it now, as the pi is happily running through the script testing gains…


#51

This is general occurance. This is due to Windows encoding (CRLF), instead of Unix encoding (LF), in text files generated on Windows.


#52

Ah, ok. Not sure how did last time I used the script, or a different version of it on a different Pi.

Thanks again @abcd567


#53

In such cases dos2unix might help as well.


#54

.

True, but creating file on Win/Mac means following 2 unnecessary steps, and still may give errors.

  1. Convert dos2unix
  2. File transfer from Win/Mac to pi.

Easiest and cleanest is to create the file directly in Pi, as follows:

(1) Create blank file
sudo touch optimize-gain.py

(2) Make file executeable
sudo chmod +x optimize-gain.py

(3) Open newly created file in nano editor
sudo nano optimize-gain.py

(4) Out of 4 versions of code in this post, select the one applicable to your install, and copy-paste it to the newly created blank file which you have opened in nano in step (3) above.

(5) Save (Ctrl+o) and Close (Ctrl+x) the file.

(6) Run the code
sudo ./optimize-gain.py


#55

I was referring to this case.
Of course those steps are unnecessary, but it’s good to know that there’s command line option, to solve the issue without transferring the file back to windows, saving it in the correct format, and then transferring it back to the pi.


#56

Your proposed commandline method dos2unix is good to solve the issue when the issue exists.

What I am trying to tell is that we are creating the issue ourselves by generating the file optimize-gain.py on Win/Mac computer. Generate the file directly in Pi, and the issue will cease to exist.


#57

Hi,
my first post in the community.
I used TWEAK2 to replace the 2-clock map.
(I have to say I first run the installation of dump1090-fa according the instructions of the installation page, but because I have the spinning thingie on port 8080, I decided to go for this solution and to get rid of google maps api)
But now my columns with altitude and speed are empty (even after refresh).
What can I try to have this fixed ?
see also screenshot

PS : I have run since Febr fr24feed and since begin June also flightaware and I use dump1090-mutability v1.14

Thanks for helping me out
Patrick


#58

This means that you are running dump1090-mutability ver 1.14, but replaced its folder /usr/share/dump1090-mutability/html by the html folder of dump1090-fa which you cloned/downloaded from Github.

Your screenshot shows that you have performed all steps correctly.

Try this:

  1. Reboot your Pi

  2. Clear browser cache by pressing (Ctrl+Shift+Delete) keys.

  3. Reload browser by pressing (Ctrl+F5) keys.


#59

Hi abcd567,

Yes I thought I performed the steps correctly.
I did what you asked but the result is the same.
I did it with different browsers on my desktop computer and to be sure and also on the Raspbery Pi itself (connection with VNC).
I’m still open for suggestions, yesterday before I wrote the message , when I copy everything back to the “original” setup, the columns are filled up with altitude and speed.

greetings
Patrick


#60

You are tight. I just now burned Pi24 image which has dump1090-mutability ver 1.14.

I then changed 2-clock map with fa map and faced exactly same problem as you. Seems there are some non compatble features between 1.14 and fa

Tomorrow i will try to uninstall ver 1.14, and install ver 1.15 in its place, and try changing 2-clock map by fa map.


#61

The new versions of dump1090-fa use different names for speed and altitude in the json database that is the transfer between dump1090 and the javascript in your browser.

You need to get an old dump1090-fa version.
3.5.1 should do the trick, not sure how you switch that at github.