FlightAware Discussions

Tar1090 -- improved webinterface for dump1090-fa and readsb

That’s not required for the javascript settings, only for the /etc/defaul/tar1090 configuration.

1 Like

restart not required, but a browser refresh to show the new rings

That worked and did what I wanted: a circle every 50 nm out to 250.

Question: I enabled both range outline and actual range outline but I’m seeing anything from them. Maybe I don’t understand what it’s supposed to look like, or else it needs more data? I’ve only been using tar1090 for around 8 hours.

Only works with readsb and the readsb location must be set.

Have you done all the panorama stuff as in the readme?

Ah, OK. I’m using dump1090-fa not readsb. I imagine that I can use one or the other but not both at the same time, correct? And the “range outline” just shows the theoretical range a la HeyWhatsThat? (Sorry for all the dumb questions, I’m just new. I got my first Pi only 6 days ago.)

readme: GitHub - wiedehopf/tar1090: Provides an improved webinterface for use with ADS-B decoders readsb / dump1090-fa

The last update didn’t go too well on my x86_64 system:

From https://github.com/wiedehopf/tar1090
 * branch            master     -> FETCH_HEAD
HEAD is now at d5b5e24 localstorage stuff
/home/sorin
cat: /etc/lighttpd/conf-enabled/89-skyaware.conf: No such file or directory
cat: /etc/lighttpd/conf-enabled/89-skyaware.conf: No such file or directory
----------------
Lighttpd error, tar1090 will probably not work correctly:
2021-09-19 09:22:18: (configfile.c.1349) opening configfile  /etc/lighttpd/conf-enabled/89-skyaware.conf failed: No such file or directory
2021-09-19 09:22:18: (configfile.c.1316) source: /etc/lighttpd/lighttpd.conf line: 49 pos: 15 parser failed somehow near here: (EOL)
[ERROR] Error in line 417 when executing: lighttpd -tt -f /etc/lighttpd/lighttpd.conf

Tar1090 is still displaying the webpage and planes.
Same happened for graphs1090:

Unpacking objects: 100% (9/9), 1.56 KiB | 228.00 KiB/s, done.
From https://github.com/wiedehopf/graphs1090
 * branch            master     -> FETCH_HEAD
 + c1763b0...ce6dd04 master     -> origin/master  (forced update)
HEAD is now at ce6dd04 airspy misc autoscale
/home/sorin
------------------
Install in progress, this shouldn't take longer than a minute or two ..........
Job for lighttpd.service failed because the control process exited with error code.
See "systemctl status lighttpd.service" and "journalctl -xe" for details.
[ERROR] Error in line 224 when executing: systemctl restart lighttpd
sorin@ubuntu:~$ systemctl status lighttpd.service
● lighttpd.service - Lighttpd Daemon
     Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor pres>
     Active: failed (Result: exit-code) since Sun 2021-09-19 09:28:56 EDT; 3min>
    Process: 614876 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lightt>

Sep 19 09:28:56 ubuntu systemd[1]: lighttpd.service: Scheduled restart job, res>
Sep 19 09:28:56 ubuntu systemd[1]: Stopped Lighttpd Daemon.
Sep 19 09:28:56 ubuntu systemd[1]: lighttpd.service: Start request repeated too>
Sep 19 09:28:56 ubuntu systemd[1]: lighttpd.service: Failed with result 'exit-c>
Sep 19 09:28:56 ubuntu systemd[1]: Failed to start Lighttpd Daemon.

Spoke too soon.
Problem fetching data from the server:

This is actually a dump1090-fa issue.
It leaves stuff in conf-enabled while deleting the files in conf-available.

But … easily enough to automate cleaning up broken symlinks in /etc/lighttpd/conf-enabled …
Rerun the install it should automatically fix that issue now …

1 Like

I did, and it works now. Thanks!

Hi
Setting: Dim Map should now read Black Map :slight_smile:
I have today updated tar1090 to 210927. Previous version was abt 1 month old.
With Safari 15 (release version) (on BigSur) I get completely black map background when Dim Map is selected. Have been using tar1090 in Safari 15 for a few days without seeing this issue, only when updating tar1090 it happened.
Seems to work as intended in latest Chrome on same Mac.
br Lars

1 Like

tar1090 code hasn’t changed, apparently Safari 15 code has.
You can bug report with Apple if you wish, i’ll flat out ignore this issue (no offense).
But good to know.

1 Like

I’ve just updated to the latest tar1090 and then installed Safari 15 on macOS 11.6 (Big Sur) to test this (I never use Dim Map). - Dim Map is working fine for me on all map options.

Is there a saver for outer ring plotting on readsb it disappears and resets
in24 hours so not sure it it does after 24 hours
a pain if i cannot save alike graphs :slight_smile:
Edit: i read ptracks=8 hours
is this the outer range ring on readsb or not

That’s by design, the displayed ring is the maximum over the last 24h.
You can’t save it and it’s reset on restart.

Thankyou for quick reply

Just want to say that ptracks along with readsb is excellent.

24 hours of flat conditions. I love it when everything works as expected.

And the MTG (no readsb on the viewer Pi)

4 Likes

Spot the differences:

(the blue outlines are 30,000ft and 40,000ft)

I’d guess you have a wrong antenna height entered for the panorama somehow.
Or trees … those cause panorama issues i think.

I think your running out of PA1NT mate

1 Like