FlightAware Discussions

Support for Stratux v3 UAT SDR

Just tried your steps and it failed at step 2.

I am getting an error during the apt-get update where it mentions duplicate entries.

It again cannot find any of the soapysdr modules.

Which os you are using?

Also, please give output of following command

cat/etc/os-release

pi@piaware:~$ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 8 (jessie)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“8”
VERSION=“8 (jessie)”
ID=raspbian
ID_LIKE=debian
HOME_URL=“http://www.raspbian.org/
SUPPORT_URL=“http://www.raspbian.org/RaspbianForums
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

:open_mouth: too old a version!
I am not sure if dump978-fa ver 3.7.1/3.7.2 are compatible to jessie.

@obj can answer this.

I’m just starting an OS upgrade so we shall see if that fixes it.

If you are upgrading, then better upgrade to Stretch, and not to Buster. The dump978-fa may have dependency issues on Buster.

EDIT:

Noted that you have Piaware SD card image. The current Piaware image is Stretch based. Cleanest and easiest option is to re-image with latest Piaware SD card image. It has both dump1090-fa and dump978-fa.

Piaware SD card image 3.7.1 Quickstart Guide

Note: do not download and use ver 3.7.1 image as mentioned in the guide (it was written before 3.7.2 was released). Use the latest version 3.7.2. The guide holds good for ver 3.7.2 also.

It is partway through the upgrade to stretch.

If it doesn’t work I’ll climb up in the attic tomorrow and reimage the SD card.

Thanks for the help.

If you have a spare microSD card, write latest piawsre image to it and replace old card by new one. This will save you one climb to attic. Dont forget to create a file named ssh in boot folder of card while it is still in the laptop/desktop after writing the piaware image (please see the “QuickStart Guide” I have linked in my above post)

I have a bunch of SD cards (I sell Stratux’s) but it is not a terrible hardship to go up and down twice.

The performance increase of these radios vs SDR’s in the Stratux world has been pretty substantial so it would be nice to see them used for this application as well. Now we just need TI to make a version of the CC1310 that can deal with 1090.

1 Like

Haven’t tried on jessie and don’t intend to support it, it’s EOL. Use stretch or buster.

1 Like

This is deliberate; the package name has changed because the API/ABI changed. That is, a binary linked against soapysdr 0.5 will not function correctly if used with 0.6; the binary has to match the library. If the package maintainer didn’t do this, the binary package would appear to install OK and then crash or malfunction.

1 Like

Thanks Oliver for clarifying.

It is mind boggling that Linux devs include the version in the actual name of the application. I guess just to be different from Windows?
What’s wrong with having the version info in the files themselves?

Reimage the SD card and after swapping the UATradio got it to work. The UATradio I happened to grab was setup for RXWX rather than vanilla Stratux so it was not appearing as /dev/uatradio.

Is there any way to see if dump978 is picking anything up? There wont be much UAT traffic around here but it would be nice to know.

Is there a guide to setup dump978 to run automatically?

If you compile and install it as a debian package it already starts automatically.

Have you checked the configuration /etc/default/dump978-fa?

That appears to be just a default config and appears to be currently disabled.

It points me to /usr/lib/piaware-support/generate-receiver-config

Got any suggestions on how to tell the dump978 section that I have this radio?

How do you know it’s disabled?
If it says ENABLED=no, then just change that to yes.

Read the comment again.

RECEIVER_OPTIONS="--stratuxv3 /dev/uatradio"

I suppose this should be the correct configuration.

Note that you need the experimental tree as described in the post above.

Here are the contents of /etc/default/dump978-fa that header leaves me to believe that changing this to yes will just result in it being overwritten at the next reboot.

# Generated automatically by /usr/lib/piaware-support/generate-receiver-config
# This file will be overwritten on reboot.
# dump978-fa does not run when uat-receiver-type=none
ENABLED=no

Taking a look at /usr/lib/piaware-support/generate-receiver-config and it does not look like something that is intended to be edited by the end user.

proc generate_dump978_config {config} {
        set receiverOpts [list "--raw-port" "30978" "--json-port" "30979"]
        set enabled 1

        switch -nocase [$config get uat-receiver-type] {
                sdr {
                        set gain [$config get uat-sdr-gain]
                        if {$gain ne "max"} {
                                # default is max gain, only need to override if different
                                lappend receiverOpts "--sdr-gain" $gain
                        }
                        set ppm [$config get uat-sdr-ppm]
                        if {$ppm ne 0} {
                                lappend receiverOpts "--sdr-ppm" $ppm
                        }
                        lappend receiverOpts "--sdr" [$config get uat-sdr-device]
                }

                stratuxv3 {
                        lappend receiverOpts "--stratuxv3" "/dev/uatradio"
                }

                none - other {
                        set enabled 0
                }

                default {
                        ::fa_config_generator::logger "unrecognized uat-receiver-type '[$config get uat-receiver-type]', not configuring dump978"
                        set enabled 0
                }
        }

Oh it even has what you want.

Didn’t know you were using the piaware sd-card image.
Assumed you installed via a package.
Such things are useful to mention.

In that case you need to use piaware-config to change settings.

piaware-config uat-receiver-type stratuxv3

Ok that was easy enough.

There are very few UAT aircraft in my area but I will see if any show up on

http://piaware.local:8978/

WIll have to upgrade the feeder at the airport for this as well.