FlightAware Discussions

[Solved] New install, maps not loading cleanly

Now this is odd. I built a new receiver a few days ago from a fresh PiAware 3.6.3 image in preparation for a new box in my garden. It’s only got a teensy aerial so it’s not receiving much which is absolutely fine, it’s what I’d expect.

However the map isn’t loading cleanly. It was when I first tested it a few days back but now it seems to be stalling and never completely loading.

I’ve done a complete cache clean and browser reset and tried multiple browsers. It’s the same, it starts loading the map tiles but it never completes. The only thing I’ve done differently today is to dump an unintheair.json file in but even removing that, the same thing still happens. This all loaded correctly a couple of days ago.

This isn’t linked to an account so there is no home location set. It’ll get my old feeder ID when I’m ready so will pick the location up from there.

Any suggestions of anything to try please?

Thanks.

1 Like

Habe you tried another computer?

Was it working correctly before you loaded the file?

Since it only takes about ten minutes to start again from a clean image that would be the easiest and safest thing to do.

S.

ctrl-r should fix it.

Seems the openstreetmap tile server (providing those images) is slow at the moment.

ctrl-r (or the Mac equivalent) didn’t fix it - But I think you’re right, it may just be slow being served. It still hasn’t dropped in fully but it is populating slowly.

Reboot everything to include your router

It’s fine now. It all eventually loaded. Thread can be closed (if that’s possible).

1 Like

You can edit the title, make it start with [Solved]. :innocent:

2 Likes

I checked again and openstreetmap tiles are still loading slowly.

If you want to use another tile server, it’s quite easy:

I’m using the wikimedia tiles, you can download my version which uses wikimedia tiles.
sudo wget -O /usr/share/dump1090-fa/html/layers.js https://raw.githubusercontent.com/wiedehopf/dev-webview/master/layers.js

When a new dump1090-fa is installed that html folder gets overwritten though, so i have another directory with a modified copy that is not overwritten.

I’ve put some more tile servers that work in that file, they are commented out:
/usr/share/dump1090-fa/html/layers.js

But you can comment out the wikimedia line and uncomment one of the other lines to try them out.

			"url" : "https://maps.wikimedia.org/osm-intl/{z}/{x}/{y}.png"
//			"url" : "http://{a-c}.tile.openstreetmap.org/{z}/{x}/{y}.png"
//			"url" : "http://{a-c}.basemaps.cartocdn.com/light_all/{z}/{x}/{y}.png"
//			"url" : "http://{a-c}.basemaps.cartocdn.com/dark_all/{z}/{x}/{y}.png"
//			"url" : "https://korona.geog.uni-heidelberg.de/tiles/roads/x={x}&y={y}&z={z}"
//			"url" : "https://korona.geog.uni-heidelberg.de/tiles/asterh/x={x}&y={y}&z={z}"
//			"url" : "http://{a-c}.tile.openstreetmap.de/tiles/osmde/{z}/{x}/{y}.png"
//			"url" : "http://{a-c}.tilessputnik.ru/tiles/kmt2/{z}/{x}/{y}.png"
//			"url" : "https://{a-c}.tile.openstreetmap.se/hydda/full/{z}/{x}/{y}.png"
//			"url" : "https://{a-c}.tile.openstreetmap.se/osm/{z}/{x}/{y}.png"

Make sure only one of those addresses has the // at the start of the line removed otherwise it won’t work.
So to change to one of the other options you put // in front of the active line and remove the // in front of the line you want.

Then use Ctrl-F5 to reload the SkyView page.

1 Like

I am using Wikimedia map since last few weeks (thanks to @wiedehopf).

I did this:

  1. sudo mv /usr/share/dump1090-fa/html/layers.js /usr/share/dump1090-fa/html/layers.js.original

  2. wget -O /usr/share/dump1090-fa/html/layers.js https://raw.githubusercontent.com/wiedehopf/dev-webview/master/layers.js

  3. Ctrl+F5

2 Likes

Line 2 needs sudo

sudo wget -O /usr/share/dump1090-fa/html/layers.js https://raw.githubusercontent.com/wiedehopf/dev-webview/master/layers.js`
3 Likes

Example different tile server