FlightAware Discussions

Solved: Installation instructions for PiAware appear incorrect

I’m a former network engineer and feel comfortable with all things related to PC’s and was idly installing the piAware app. I ran into a problem, however. It says in order to get the wifi running on the device one needs to open up the sdCard on which piAware is installed and alter a config file.

This doesn’t seem to be possible. Any attempt to open the drive creates a pop-up dialog asking to "Insert disk into USB drive. This is Windows 10.

This seems like absurdly basic stuff. What am I missing.

1 Like

If you have used balena etcher or raspberry pi imager to write the image, upon completion of write, it ejects the microSD card, although it is physically still plugged in.

Unplug and replug the USB card reader (with microSD card in it) and try again to open the drive.

2 Likes

I removed the device, re-inserted it several times. I then removed the micro-USB drive from the adapter. Then reinserted the adapter. The drive then came up with a list of files. This is absurd. Very few users will be able to navigate this experience.

Better use Win32DiskImager. It does NOT eject the microSD card after write is completed, and you can open the drive without unplugging and replugging the card reader/microSD card.

1 Like

Haven’t seen that problem reported before. Since you’re comfortable with technology can you experiment and try to work out if it’s something specific to your machine?

You could also try the Raspberry Pi Imager to see if that works any better for you.

I’ll see if I can get the instructions updated to clarify. FWIW it’s not necessary on e.g. Linux with Etcher, and the current Windows instructions do already say to eject/remove the drive after flashing.

To see if it’s specific to my machine I’d need a bunch of Raspberry Pi 4’s, which I don’t have. I may have some network gremlins, however.

Uh, I thought the problem you were having was on your Windows machine.

I just tried on my Windows 10 machine and it worked as expected here:

  • download and install etcher
  • download the piaware image
  • plug in a USB3 sdcard adaptor with sdcard
  • use etcher to flash the image to the sdcard
  • unplug and reinsert the sdcard adaptor
  • now there is a E:\ boot drive with piaware-config.txt et al

I did reproduce the “insert disk” prompt you mentioned, if I tried to access the sdcard before doing the unplug/replug step. If you follow the install instructions you’ve unplugged the drive after flashing, though, and on subsequent replugs the drive was visible as expected. I did not need to replug multiple times.

2 Likes

 

That is exactly what I also suggested:

 

… and that is also what the https://flightaware.com/adsb/piaware/build page says:

image

1 Like

There is an alternative method even if piaware-config.txt is invisible on the computer: Logon to your Pi as default user pi, edit/configure /boot/piaware-config.txt, then reboot.

Several options to do this. The most straight-forward is to connect a USB keyboard, and an HDMI TV/monitor to your Pi. Then, log on as default user pi. Just press F2 to get to login prompt.

Or, if you are super comfortable with typing, you can even do this without monitor. Remember to press F2 first.

pi
flightaware
sudo piaware-config wireless-ssid 'YourWiFiSSID'
sudo piaware-config wireless-password 'YourDarkestSecret'
sudo piaware-config wireless-network yes
sudo reboot

Unrelated to wi-fi but to FA instructions, I encountered confusion with a package install of PiAware 5 on my established RPi 4B with RPi OS. “Already running dump1090 on a Raspberry Pi?” clearly bypasses the RPi build and card steps yet suggested to this reader I should already be running dump1090 before installing PiAware. This notion was reinforced on the PiAware installation page, “… link your RPi with dump1090 to FA …” So I went to step 3 and made an unsuccessful attempt to first install dump1090 via the commands. Then, like a responsible dummy, I followed the instructions exactly from step 1 and was up in a few minutes.