FlightAware Discussions

Skyview: Some ground units displayed?

I have disabled the ground vehicles in Skyview 3.6.3
I have two ADS-B test transmitters in the area that is always displayed despite this. The altitude column for those two are saying ground. They are probably identifying as airplanes.
Would it be possible to completely disable the display of anything located on ground?

Have you tried just using the altitude filter?

Even 1 as minimum should work, just give it a try.

Otherwise you’d have to dive into the javascript of the webinterface.
Not too hard either.

You would need to modify the following file:
/usr/share/dump1090-fa/html/planeObject.js

Find these lines: (starting around line 132)

    // filter out ground vehicles
    if (typeof this.filter.groundVehicles !== 'undefined' && this.filter.groundVehicles === 'filtered') {
        if (typeof this.category === 'string' && this.category.startsWith('C')) {
            return true;
        }
    }

Add these two lines:

        if (this.altitude === "ground")
            return true;

so it looks like this:

    // filter out ground vehicles
    if (typeof this.filter.groundVehicles !== 'undefined' && this.filter.groundVehicles === 'filtered') {
        if (typeof this.category === 'string' && this.category.startsWith('C')) {
            return true;
        }
        if (this.altitude === "ground")
            return true;
    }
1 Like

Thanks :slight_smile:
The alt filter works if i set min to 1, but then i have to do that at every browser start.
I tried the Java change, and it works, but seems only if i place it outside the enclosing IF…

It’s tied to the “filter ground vehicles” checkbox i thought the way i did it.

Anyway when dump1090-fa gets updated you’ll have to redo it as it overwrite the html folder.
Just a heads up.

If you want that filter always on then it’s fine the way you did it.
It’ll also filter aircraft on ground though.