FlightAware Discussions

Skyview shows spinning wheel, was working last night?

I have skyview working ok from PC (version in this docker container) however when i try to view on an ipad i see an infinite spinning wheel like logo with a little progress bar below it.

This is overlayed over the top of the skyview page with no data.

Any ideas?

my bad, seems to be doing this on a PC now - i have no idea what broke it?

You’ll have to take that up with the creator of that docker container i’d say.

Or just get use a Raspberry Pi and install the software, then we are more likely to be able to help.

But my guess would be you aren’t able to connect to the docker anymore?
Have you tried restarting the container?

Ctrl-F5 will maybe show another error?
As i said hard to say what’s wrong with an unknown configuration.

Thanks for the quick reply. I don’t think you understand, i can connect to the docker just fine. The container is happily reporting data to FR24 and Flightaware.

The issue is the local skyview webpage on :8080 loads but displays a spinner. There is no error in any logs i can find (i can ssh into the container and i am looking at a bunch of logs, but not sure what is relevant to the web page?).

The only error shown in an F12 browser debug window is a 404 error for http://ipaddres:8080/status.json - but i have no idea if this is relevant. the container was working perfectly last night, i just blew away the contents of the container (i.e. back to how it was) keeping only my config files and still get the same issue. This would indicate an issue with either the config.js for the app, or how the app connects to data?

The issue is purely the web app. If someone can tell me what the web app is doing when it shows http://192.168.1.38:8080/spinny.gif then i could go troubleshoot. The web app is waiting for data of some sort?

Like this:

Do you get address/data/aircraft.json per http?
aircraft.json should be in /run/dump1090-fa per ssh.

Anyway have a look at the webconsole and try Ctrl-F5 to get rid of cache.

Yes i get aircraft data on http://192.168.1.38:8080/data/aircraft.json
Already did it with flushing cache several times (i disabled cache in console too)

I think the receiver.json is required, otherwise it won’t stop spinning.

Have you looked in the web console log?
I’m not sure why it would hang after status.json, that shouldn’t be required i think.

- i assume this means the recievier.json is good?

Here is the log from a total fresh reboot - this clears the docker HDD of any changes.
https://pastebin.com/Vi4T0S36 this shows two attempts to connect to the website

My configs are all held on the host (i.e. this is where i persist state):

That’s not the browser console log.

Anyway i’ve got no clue why it’s not loading.
Maybe it doesn’t like the empty version string.

thanks for you help, where is the browser console log?
Any hoo I found what was the issue in config.js (darn quotes) - shame it didn’t error in stderr.

Wrong
BingMapsAPIKey = Avy9LtvbZ5M4bkrBScC_KqklExzo84IEQ0MoqxGY_7L3H6eSVzC80kTTxfCdanBA";

Right
BingMapsAPIKey = "Avy9LtvbZ5M4bkrBScC_KqklExzo84IEQ0MoqxGY_7L3H6eSVzC80kTTxfCdanBA";

Note i had commented out the key with // and it was still failing it seems this line is required with either “key” or null (no quotes)

When you showed the network transfers in the browser, there should be a console tab.

Thanks for the tip, i am not a coder and in general i have found the network trace to show errors i need, i now know to look in console all ways! Thanks. This would have got me to the issue much sooner without posting, sorry.