FlightAware Discussions

Signal Strength Heatmap

A few minor changes:

  • Can now collect data from remote pi without timelapse1090 installed.

  • Added variables to allow collecting from other dump1090 versions, eg mutability, mictronics - most people won’t need to change this.

  • James from ADSBx added some error checking for remote data collecting.

2 Likes

It appears that the version numbers (from 3 to 4) got updated.

http://ftp.debian.org/debian/pool/main/g/gnuplot/gnuplot-data_5.2.7+dfsg1-4_all.deb
http://ftp.debian.org/debian/pool/main/g/gnuplot/gnuplot-nox_5.2.7+dfsg1-4_armhf.deb

And I get the following errors after changing the “3” to a “4”:

pi@piaware:~ $ sudo dpkg -i gnuplot-nox.deb gnuplot-data.deb
Selecting previously unselected package gnuplot-nox.
(Reading database … 42984 files and directories currently installed.)
Preparing to unpack gnuplot-nox.deb …
Unpacking gnuplot-nox (5.2.7+dfsg1-4) …
Selecting previously unselected package gnuplot-data.
Preparing to unpack gnuplot-data.deb …
Unpacking gnuplot-data (5.2.7+dfsg1-4) …
dpkg: dependency problems prevent configuration of gnuplot-nox:
gnuplot-nox depends on libc6 (>= 2.29); however:
Version of libc6:armhf on system is 2.24-11+deb9u4.
gnuplot-nox depends on libgd3 (>= 2.1.0~alpha~); however:
Package libgd3 is not installed.

dpkg: error processing package gnuplot-nox (–install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gnuplot-data:
gnuplot-data depends on aglfn; however:
Package aglfn is not installed.

dpkg: error processing package gnuplot-data (–install):
dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.6.1-2) …
Errors were encountered while processing:
gnuplot-nox
gnuplot-data

How do I update libc6 and libgd3 and install Package aglfn? Or am I just lost in the wilderness? :nerd_face:

Thank you!

Start with a fresh system based on Buster.

Or you can try these:

wget -O gnuplot-data.deb http://ftp.debian.org/debian/pool/main/g/gnuplot/gnuplot-data_5.2.6+dfsg1-1+deb10u1_all.deb
wget -O gnuplot-nox.deb http://ftp.debian.org/debian/pool/main/g/gnuplot/gnuplot-nox_5.2.6+dfsg1-1+deb10u1_armhf.deb
sudo dpkg -i gnuplot-nox.deb gnuplot-data.deb

I forgot to say I started with a new SD card and installed PiAware 3.7.2. When I had upgraded from 3.7.1 to 3.7.2 I had issues with graphs1090 (no UAT data), timelapse (blank), and tar1090 (UAT didn’t show). I got tar1090 working again but never did figure out timelapse and the graphs. Figured it would be a good time to start anew. I guessed wrong! :grin:

Still dependency errors…:sob:

Start over?

Follow up, this seemed to fix whatever went wrong…:man_shrugging:

sudo apt --fix-broken install

What system are you on?
Buster Lite?
Or piaware sd-card?

3.7.2 changed the address for skyview from /skyview978 to /skyaware978
The graphs should start working again automatically when you upgrade.

For tar1090 you’ll have to edit the URL_978 and change it appropriately.
timelapse for 1090 MHz shouldn’t be affected.
Oh wait i can think of one way this would fail, just do a reinstall/update of timelapse1090 and check if that helps.

Started with clean sd card, followed the instructions with a fresh install of Piaware 3.7.2.

For tar1090 you’ll have to edit the URL_978 and change it appropriately.

That explains why it I got it to work, changed to xxx.xxx.x.151:8978 and it started working.

Did a reinstall/update for the graphs (no UAT data) and timelapse (just a map), never got either working. So i decided for fun to start over! :grin:

It appears i got it all to work, the sudo apt --fix-broken install command seemed fix what I broke. 6 hours later, seems stable.

Thank you

Which version though? Buster or Stretch?

On Buster you can just install the packages via sudo apt install gnuplot-nox gnuplot-data as they are up to date.
The downloading and dpkg -i is only needed on Stretch.

$ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”

If you used a new Raspbian image, could have just used a current image as in Buster.

Or did you use the piaware sd-card?

Downloaded Piaware onto a blank SD card.

That’s called the piaware sd-card image.

Versus installing piaware once you used the normal Raspbian Lite image.
Your expression “installed piaware” confused me.

piaware is not the sd-card image, it’s the name of the feed client.
Oh well it’s FAs fault for mixing up terms -.-

My fault. Lesson learned. Helps to explain to everyone if I knew in the first place; which I should have.

Thanks for teaching!

1 Like

So currently your polar.sh doesn’t work on the aircraft.json produced by skyaware978, this can be fixed like this:

select((has("tisb") | not) and (.tisb | has("lat") | not)

The above caters for the possibility of the tisb array not existing at all. In this case lazy evaluation avoids the null error :slight_smile:

Are you putting that in place of the existing filter or as well as?

Needs to be in place of your tisb filter which can’t handle the tisb array not existing.

OK - that example you gave breaks the dump1090 filter though.

Are you sure it breaks it?

Oh yeah it does.
Need to and first and then negate i think.

Unless I’ve done something dumb - https://jqplay.org/s/NNFZQd5isz

Here we go, sorry for not testing properly:

select( ( has("tisb") and (.tisb | contains(["lat"])) ) | not)

This might be prettier:

select( (has("tisb") | not) or (.tisb | contains(["lat"]) | not) )

That seems to work. I don’t have a current 978 json to test against, but it’s good for dump1090 output.