FlightAware Discussions

Running PiAware on a QNAP TS-251+ NAS

I’ve got a QNAP TS-251+ NAS which has an Intel 4 core Celeron CPU with 8Gb of RAM, it supports Debian & Ubuntu through Containers and VM’s. I run PiAware on an RPi but the house gets in the way and as I can’t get the antenna above the roofline I’m looking at running a second unit on the other side of the house and thought I might try to get it running on the conveniently located NAS rather than a 2nd RPi. Problem is that I get errors during the build phase and not being a linux guru I was wondering if anyone on here has successfully managed to get an orange FA dongle running on a QNAP NAS.

Any help appreciated MTIA


If you’re into docker, try this: https://github.com/mikenye/docker-readsb/wiki/Guide-to-ADS-B-Data-Receiving,-Decoding-and-Sharing,-Leveraging-RTLSDR-and-Docker#feeding-flightaware

Otherwise, isn’t this thread exactly what you’re looking for?

Hi wiedehopf,
Very many thanks for the response, I’ve tried the instructions on your second thread but seem to fail during the build phase but it does look to be the best set of instructions.

I think I must be missing something in the QNAP build part of the operation, I’ve found in the past that QNAP have a habit of giving you basic generic installation instructions but fail to give you the specific what comes next instructions so you end up with a system with big holes in it.

I had hoped that maybe one of the members may have come up with something like “I’ve done that and you need to watch for …”


so … what’s the error?

And are you running debian or Ubuntu, then it should be really straight forward.
You weren’t quite clear on what it was actually running, only what it supports.

I’ve started from scratch and I have installed Ubuntu 18.04. Following the instructions you pointed me at, I kick off the command “sudo dpkg-buildpackage -b --no-sign” by a copy & paste and this is the result:

admin@ubuntu_1804:~/dump1090-fa$ sudo dpkg-buildpackage -b --no-sign
dpkg-buildpackage: info: source package dump1090-fa
dpkg-buildpackage: info: source version 3.8.1
dpkg-buildpackage: info: source distribution stable
dpkg-buildpackage: info: source changed by Eric Tran eric.tran@flightaware.com
dpkg-buildpackage: info: host architecture amd64
dpkg-source --before-build dump1090-fa
debian/rules clean
dh clean --with=systemd
make -j1 clean
make[1]: Entering directory ‘/home/admin/dump1090-fa’
rm -f .o compat/clock_gettime/.o compat/clock_nanosleep/.o dump1090 view1090 faup1090 cprtests crctests convert_benchmark
make[1]: Leaving directory ‘/home/admin/dump1090-fa’
rm -f debian/debhelper-build-stamp
rm -rf debian/.debhelper/
rm -f – debian/dump1090.substvars debian/dump1090-fa.substvars debian/files
rm -fr – debian/dump1090/ debian/tmp/ debian/dump1090-fa/
find . ( (
( -path .*/.git -o -path .*/.svn -o -path .*/.bzr -o -path .*/.hg -o -path .*/CVS -o -path .*/.pc -o -path .*/_darcs ) -prune -o -type f -a
( -name '#
#’ -o -name ‘.~’ -o -name '~’ -o -name DEADJOE
-o -name ‘.orig’ -o -name '.rej’ -o -name ‘.bak’
-o -name '.
.orig’ -o -name ..rej -o -name ‘.SUMS’
-o -name TAGS -o ( -path '
/.deps/’ -a -name '.P’ )
) -exec rm -f {} + ) -o
( -type d -a -name autom4te.cache -prune -exec rm -rf {} + ) )
debian/rules build
dh build --with=systemd
debian/rules override_dh_auto_build
make[1]: Entering directory ‘/home/admin/dump1090-fa’
dh_auto_build – RTLSDR=yes BLADERF=yes DUMP1090_VERSION=3.8.1
make -j1 RTLSDR=yes BLADERF=yes DUMP1090_VERSION=3.8.1
make[2]: Entering directory ‘/home/admin/dump1090-fa’
cc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=“3.8.1” -DMODES_DUMP1090_VARIANT=“dump1090-fa” -DENABLE_RTLSDR -DENABLE_BLADERF -g -O2 -fdebug-prefix-map=/home/admin/dump1090-fa=. -fstack-protector-strong -Wformat -Werror=format-security -std=c11 -O2 -g -Wall -Werror -W -D_DEFAULT_SOURCE -I/usr/include/ -I/usr/include/ -c dump1090.c -o dump1090.o
In file included from /usr/include/x86_64-linux-gnu/bits/libc-header-start.h:33:0,
from /usr/include/stdio.h:27,
from dump1090.h:65,
from dump1090.c:50:
/usr/include/features.h:424:12: fatal error: sys/cdefs.h: No such file or directory

include <sys/cdefs.h>


compilation terminated.
Makefile:45: recipe for target ‘dump1090.o’ failed
make[2]: *** [dump1090.o] Error 1
make[2]: Leaving directory ‘/home/admin/dump1090-fa’
dh_auto_build: make -j1 RTLSDR=yes BLADERF=yes DUMP1090_VERSION=3.8.1 returned exit code 2
debian/rules:23: recipe for target ‘override_dh_auto_build’ failed
make[1]: *** [override_dh_auto_build] Error 2
make[1]: Leaving directory ‘/home/admin/dump1090-fa’
debian/rules:32: recipe for target ‘build’ failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

As you can see it seems to have lost a directory.

Some google says:

sudo apt-get --reinstall install libc6 libc6-dev

Hi wiedehopf,
Success!! Very many thanks for your help, it’s very much appreciated. I’ve got FA confirming that they are receiving data from me so I have just to configure location, height etc and when some aircraft get up in the air I might see them. I’ve just got to get VRS to work with the NAS as it’s using a virtual switch so I’ve got to try and work out the IP address and port number.

Thanks again,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.