Running other programs with PiAware (SD Card) 3.5.0

Hi all, I would like to run a ham radio APRS iGate on the same Pi that is running an upgraded PiAware (SD Card) 3.5.0. … dr-dongle/

I tried to install the above program but couldn’t get past the ‘make’ command. I gather that PiAware has a cut down OS that doesn’t have all the files of a normal OS?

I also gather that if I add PiAware as an add on to the latest Jessie light, that it will fail as per this post:


Are these 2 programs compatible and how would I go about getting them to install and work on the same Pi please?

Would using an old version of Jessie light but not updating it work?

Also, will PiAware automatically choose the Pro Stick over the Nooelec dongle installed for APRS on each boot up?

Thanks, B

You are fine to install piaware from packages on a Jessie image. The upgrade problems specifically affect the piaware 3.3.0 sdcard image only.

The piaware sdcard images have a fairly minimal set of packages installed, but you can always install whatever extra packages you need via apt-get. If you are building something from source then “sudo apt-get install build-essential” will get you most of what you need.

No; you will need to set the “rtlsdr-device-index” configuration option to identify which dongle to use (by index or by serial number) if you are using a piaware sdcard image.
If you are using a piaware + dump1090 package install, you’ll need to configure dump1090 with a --device-index option.

Thanks obj, sudo apt-get install build-essential gave me the files to allow ‘make’ to run.

rtl_test gives:

Found 2 device(s):
0: Realtek, RTL2832U, SN: 00001000
1: Realtek, RTL2838UHIDIR, SN: 00000001

Device index 0 is a Pro Stick, and device index 1 is a Nooelec dongle for APRS.

I can see in raspi-config where to set rtlsdr-device-index.

However, the iGate program wants to use device index 0 and I don’t see any option to change that.

Is there any way to swap the device numbers around so that I can then tell raspi-config to use the Pro Stick as device 1?

Any help appreciated.

The device index is just whatever order they happen to enumerate in, it’s probably tied to the physical USB port so you could try swapping the ports over?

When you run rtl_fm, use the -d option.
Default is 0, but you can force -d 1