FlightAware Discussions

Running dump1090 and the reporting on different machines?

Yes piaware uses gpsd as a position source, not a clock source.

1 Like

USB is too variable to be used for accurate timing. That is why NTP normally uses a PPS signal on a UART or GPIO port. I have several different GPS units setup to provide NTP. They can get the local clock down to a few microsecond accuracy on an RPI.

Actually I do have a uBlox module on the GPIO UART and the PPS is connected via GPIO too. I use the kernel mode PPS support and ntpd is quite happy with it. I don’t like USB GPS dongles for timing as the USB bus is unpredictable in timing by nature.
It is a TCXO based module, so it is good, but not comparable to the double-oven TCVCXO modules I use for my lab reference.

1 Like

I have some u-blox 8 series hats. They work well. I also have the new ZED-F9P from ardusimple.com. It can handle all four main GNSS constellations at once (the 8 series can only do 3) as well as dual band reception (L2C and L1 CA for GPS. E1 and E5b for Galileo, B1 and B2 for BeiDou and R1/R2 for glonass).

I use the NEO8-MAX series for APRS amateur radio projects like our balloon project.

And this V.KEL Neo Clone is used just for fun on the PI as an “upgrade” to the ADSB project. Sorry, I had an issue, after a planned reboot of the ADSB unit I had an issue that the RTL-SDR was not recognized anymore, and I do not get any PPS signal from the GPS… It’s probably one of “these days”. However, dump1090-fa is working again, I switched to a different antenna for testing it’s range.

GPS still needs to be fixed. It flashes with PPS, so the RPi should see PPS…

What dongle are you running? Personally i would switch to the Pi3B+, it’s a much more stable platform compared to the RPiZero.
The dongle not being recognized sounds like the dongle might just be bad.

You are probably only doing this project for the tinkering with antennas, otherwise i’d recommend going with an LNA either external or builtin to the dongle (options: https://github.com/wiedehopf/adsb-wiki/wiki/Useful-items-for-purchase)

What antennas are you trying?

1 Like

I have a microsat ulari (http://www.ulari.net/doku.php) for an APRS base unit. Not sure what it uses for GPS, however, it does have one. I have their older device but could never get the Xastir RPI to KISS interface to work (Serial or blu-tooth)

I use the uputronics (https://store.uputronics.com/index.php?route=product/product&path=60_64&product_id=81) and the https://drfasching.com/products/gnss/raspignss GNSS devices too.

I tried to get PTP working but haven’t managed to compile the kernel correctly yet.

Wiedehopf, I have some passive PCB antennas for ADSB and I will add some LNB and a filter later. I do have noise over here but it looks like there is no real impact on the 1090. So first I optimize the antenna, then I add LNB and filters if needed. And the Antenna and the RTL-SDR are only a meter away. There is no problem with the RTL-SDR, which is Chinese but with a good TCXO. I had a RPi issue, cause after plugging in a WiFi dongle, seeing the LED flicker a lot, pulling the SD and putting back the RTL-SDR, everything works fine. From what I saw on the USB related kernel messages, it just failed to enable the USB interface completely.

Jon, the ULARI is neat, but does not have enough power to fit my needs as a platform. I do have a lot of RF demo kits around my desk, but for digital amateur radio I prefer STM32F and for plain signal decoding I need performance like a Rockchip RK3399 or such. So I use Nano PC T4.

1 Like

If you mean the Pi’s power LED, then that’s an undervoltage problem - check your power supply.

On the zero w there is only one LED and flickering means, it is accessing the SD card.

I set up a second system on my NanoPC T4. I tried using this install.sh from github, that asks you a lot of questions and tries to install everything alone. But this hardware is new, the RK3399 is an arm64 and FriendlyElec is not Ubuntu, it failed and left quite a mess. So I went the same way, I used for the Pi.

I downloaded dump1090-fa, beastsplitter and fa-feeder from their repositories, compiled them the usual way and now everything runs fine. I also added FR24 and that’s up too.

I couldn’t finish the installation last night, but at least the RPi based unit was running fine. This Morning I didn’t check the RPi but being connected via VPN I cannot reach it and FA tells that it isn’t active anymore. The NanoPC still goes strong.

I am not sure what to think about this… I am using a RPi B3+ as my DMR/D-Star relay and it works for a year now without having failed a single time. And all previous trials to run that relay on Orange-Pis always failed after a few weeks.
But with piaware / dump1090 / fr24 the Pi seems not to run that stable. I will switch to another Pi unit I have but I also think of moving to a IMX6D board I have, that is automotive and really a rugged version. Cause one of my FA units should go up on a 40m exposed mast and I really do not like to climb up there every week…