FlightAware Discussions

RPi4 not displaying Skyview properly

I have an issue with a new Rpi4/2GB. My intent was use it as a desktop PC to view Skyview,
performance graphs and various other things. It is a new Rpi 4 running the latest Buster
full image.

I have three piaware feeders. All run the SD image. Two run 3.7.1 and dump1090. One running 3.7.0.1
and dump978. All of them are feeding only FA.

When I connect to any one of my feeder’s Skyview from the Rpi4, I get pretty much the same
thing as the attached display. Some or all of the map is “tiled” with portions of the map repeated.
Also the range ring distance indicators are distorted. Is the same on both hdmi interfaces.

Thinking this might be a Buster problem I loaded Buster on an old 3B+ with no problems.

I do not see any problems with any other URL. Anyone know why the Rpi4 is acting as it is with only Skyview?

1 Like

I just tried it on my RPI4 and it worked OK.
I don’t have any traffic at the moment (just getting the code ready to swap out a feeder).
Even Bing Maps looked good.

Did you refresh your browser? ctrl F5 etc.
Which browser are you using?

Did you refresh your browser? ctrl F5 etc.
Which browser are you using?

Many times.

Chromium
Version 74.0.3729.157 (Official Build) Built on Raspbian , running on Raspbian 10 (32-bit)

This problem seems to be due to Chromium. While looking around to alternatives to Chromium, I found GNOME Web, also known as epiphany-browser. It is comes with the Raspbian distribution. It is launched from the command line with “epiphany-browser”. It is very slow and runs up cpu usage/temp, but it does display Skyview properly.

Is your connection working fine in general?

Yesterday i had temporarily the same error accessing the device remotely with my Firefox. All loading, but the map loads with a heavy delay. After waiting a while the map appeared

I found out that my VPN connect to my provider was to a very slow server. Switched it and all went good.

The map itself is loaded from the internet directly and has nothing to do with the device you are using for tracking.

There are a lot of posts over in the Troubleshooting portion of the forums on RaspberryPi.org concerning
Chromium and the handling of Google Maps. It seems that more than just a few users are having problems with the Pi4s and asking questions, but no answers yet.

Isn’t PIAware using Openstreetmaps?

@wiedehopf has posted a good method of fixing this, it changes the default map provider.

You need to run two commands:

sudo mv /usr/share/dump1090-fa/html/layers.js /usr/share/dump1090-fa/html/layers.js.original
sudo wget -O /usr/share/dump1090-fa/html/layers.js https://raw.githubusercontent.com/wiedehopf/dev-webview/master/layers.js

Then refresh the browser window.

It’s described further in this thread I posted a while back with the same problem.

It’s a different problem.

His problem can’t be fixed by changing the map or the webinterface.

The problem is the browser (chromium) running on the RPi4.
Or rather the graphics driver on the RPi4 is the real culprit.

The other browsers he tried might have graphics acceleration disabled.
Thus they are much slower and use more CPU.
But the graphics acceleration issue doesn’t show.

Hmm, if the problem is google maps and Chromium on the Pi4 (works fine on mine btw), then won’t changing the maps help? It’s just a thought.

Do you have a monitor connected to the RPi4?
He’s literally using the RPi4 as a desktop computer.

It’s got nothing to do with the RPi serving the map.

And the problem is with the graphics acceleration used by the browser.
Which is likely the same regardless which map.
(the functions are the same, 2D graphics acceleration)

1 Like

No. Good point. I’ll shut up now :wink:

I know, it’s a strange proposition to connect a monitor to the RPi :wink:

Who would do that?!

I’ve done it once. Then it scared me so I disconnected it!

2 Likes

Well, me. :confused:

Moving on…

When I open keithma’s feeder site at http://mtg.getmyip.com:747/tar1090/ I see the same issue as with my sites.

Can someone with a RPi4 loaded with the latest Buster full image with a monitor try that URL and see if they see the same issue and report back?

Yes, the skyview maps are not rendered correctly on a RPi 4 using chromium. On the raspberry.org forums someone mentioned this as well, a map with weather information.

The Pi 4 has a new video core, so it is probably a driver issue with chromium, as suggested before. Happens with bing maps as well.

The

sudo apt-get update
sudo apt-get install firefox-esr

works fine

biekerc, thank you for your work. I wanted to make sure that the issue was not just with me.

1 Like

A lot of upgrades for Buster came down today, They had no effect on this issue.

I went in the Chromium Settings, Advanced section and turned off ‘Use Hardware Acceleration when available’ and it cleared up the map/tile issue. Will run it that way until there is either a video driver or Chromium update to fix it.

rhazzed

Thank you. I see the same result.