RPi3 WiFi interface failure


#1

Has anybody seen/heard of an RPi3 WiFi interface failure before?

The WiFi interface in my second receiver has failed. I tried everything I could think of, nothing worked.

The ethernet interface is fine.


#2

It happened to me when I did put in a new SD card, freshly written. I have re-written the card with the un-zipped ISO (using 7zip) and all was well.


#3

Have you set a country? Wifi is deactivated if it’s not set.

This is a post i previously wrote about it: Raspberry Pi 3 not connecting to wifi

Not necessarily the problem though.


#4

What does “sudo iwconfig” command show?


#5

I tried that many times, and Raspbian only also. Tried different cards as well. Different power supplies.

I can access the Pi directly or over an ethernet connection. The message from the Pi is that there is no WiFi interface available.

The receiver was working fine, and then stopped feeding FA.


#6

eth0 no wireless extensions.

lo no wireless extensions.


#7

Never had to do it when using the Piaware image on a fresh/clean SD install. I do it if installing on top of Raspbian.


#8

If, as mentioned above, the country isn’t set, I would start there. If it is set, then see what " iwlist scanning" shows.


#9

That’s how it was for me too - no WiFI interface was detected. No matter if I tried in raspi-config or not.
Reflashing the SD with the ISO image (not the zip), extracted with 7zip fixed it.


#10

eth0 Interface doesn’t support scanning.

lo Interface doesn’t support scanning.

I have a third RPi, inserted the same SD and all is fine.

The ‘defective’ RPi is running Raspbian now. I set the country, still no WiFi.


#11

I did that many times. I always unzip. I only noticed Etcher will handle zipped images recently. Inserted the same SD in another RPi3 and WiFi worked. No country was set, as usual, when using the Piaware image.

As I mentioned before, it happened while working, and then stopped. I was not doing anything with it. I went to check because it had stopped working. No experiments were being conducted.


#12

New info.

The ‘defective’ RPi is now running Raspbian, and I’m accessing it with VNC over ethernet. When I installed it, I configured the WiFi country. For some reason, the WiFi country is not being saved. Locale, Timezone and Keyboard are saved. WiFi country reverts to -not set-, no matter how many times I reset it.

How does one set WiFi country in Piaware? Again, never had to do it, but I’ll give it a try.


#13

Link from my other post:
https://www.raspberrypi.org/forums/viewtopic.php?t=191252


#14

Thanks. That is for Raspbian. I remember ‘dealing’ with wpa_supplicant in the past, but it was not ADS-B related.

My main interest is Piaware. As I said, the same SD card works on one RPi but not the other. It used to work on both. Raspbian is not a factor, as the card is a Piaware image burn.

WiFi stopped during ‘normal’ operations. No upgrades, no experiments were involved.


#15

Well… than maybe it really died. You can add an USB WiFi: https://raspberrypihq.com/how-to-add-wifi-to-the-raspberry-pi/


#16

I really think this is what happened, as unusual as it may be.

I have now completed the re-org. The Pi that was in the office, is now part of the second Piaware receiver. The defective Pi is now in the office. The only difference is that the office Pi was also connected using WiFi, now it’s using ethernet.

Too much time spent on this stuff this weekend. Going offline for a while, enough of ADS-B.:grin:

Thank you all for the help.


#17

Try an old piaware image maybe? The radio kill with no country set was only introduced for the 3B+ with stretch. Jessie does not have this stupid feature, but it seems to be a regulatory requirement.

obj said there is a piaware option that is not yet documented if you want to try it.


#18

similar happened to me a while ago. wlan0 works eth0 not, due to near by thunderstorm.


#19

FWIW the piaware sdcard images set the country to 00 (the worldwide regulatory domain) if you don’t explicitly set it - it doesn’t set rfkill like base Raspbian does.


#20

So it’s probably a different problem for Dxista :frowning:

Anyway only thing that came to mind sorry. Maybe you forgot to plug in the wifi cable?