Red light comes on ..Green flickers then goes out


#1

Newbie…just put together my raspberry. Downloaded software onto SD a couple of times after reformatting. I get the red light and the green light flickers then goes out… Flightaware is not picking up my receiver… :frowning:


#2

Did you “claim” the receiver under your account?


#3

Is the Pi still responding, does it work with the standard rasparian image? - I’m wondering if the power supply you’re using is up to the job.


#4

Yes, I claimed the receiver and flightaware shows it linked to my account. I am using the power supply that was recommended on the purchase list…


#5

I using my raspberry hooked up to a desktop that is connected via wifi. I am wondering if that could be the issue. Should I connect the etherntet directly to my router…will that make a difference ??


#6

It may depending on your setting. I would run a cable direct to the Pi and see how is responds. I run mine on WiFi, but it is a USB WiFi directly in the back of the Pi.


#7

Try that, I had issues trying to use both wifi and the dongle on the RPI, both drawing too much power. Using the ethernet will address that or use a powered USB hub for the dongle.


#8

Yes, try that, but disconnect the WiFi adapter before trying. I had to use a powered USB hub for WiFi + SDR dongle. Each draw a lot of power and the RPi has known issues with supplying ample power to its USB ports (despite a good power supply).

Specifically, which power supply did you buy? Some are over rated.
Did you get one with at least a 2-2.5 amp rating?


#9

I run my Pi over homeplug (aka powerline) ethernet - this carries ethernet signals over the building wiring

see amazon.com/TP-LINK-TL-PA2010 … B00AWRUIY4

You need at least two adaptors (a starter kit), one for by the internet router - the second for the Pi, (then a third for the smart TV, a fourth for Network storage appliance)


#10

Pity Internet over mains (PLT) causes interference to HF radio and can knock out digital FM.
interference.org.uk/


#11

Thanks for all of the replies and suggestions. Yes, I bought a powered USB port, but it does not seem to help. I am running the power cord that was suggested on the list. So, Now I am running power to the Pi and one to the usb. So far, this has not helped. I also downloaded the new version -3 software and connected directly to my router. Still NO luck ??? Red light in on … Green Light flickers then goes out… I claimed my receiver and it shows that it has been claimed, but on top of screen also states that there is no active Pi. ??
could this be a Flight Aware issue and not a hardware issue on my part?
Tom


#12

Have you plugged the RPi into a monitor over HDMI to see what’s going on?


#13

I AM UP AND RUNNING !! I think it might have been the combination of getting the powered USB port plus connecting directly to the router. I had previously tried to connect to the router with no avail. After getting the powered USB port , I still was not online. Then I plugged back to the router and Voila ! My router is on the opposite side of our house so I was avoiding having to do that…
Thanks for all of the suggestions !!!
Tom