FlightAware Discussions

Raspberry Pi Debian images - Latest Release Bullseye

This is very interesting. It is exactly the same messages I was getting on the feeders that ‘died’ recently. The thing is - they were running Stretch!

Having already imaged Buster onto new SD cards and set them up again from scratch, I decided to have a play with one of the broken ones. After having uninstalled and purged piaware and dump1090 then reinstalled them, it sprung into life.

What is going on?

P.S. before anyone asks why I didn’t just go with Bullseye, when it comes to ‘live systems’ I’m a risk adverse late adopter.

P.P.S. Sorry, I polluted your Bullseye thread!

1 Like

This is a common problem. With Bulls Eye this library has been updated to a new version. Therefore, you cannot install the “buster” build of dump1090-fa under Bulls Eye.

FA would have to provide a Bulls Eye build in its repository and I am sure this will be the case with PiAware 6.0.

The easiest workaround currently is to manually install the required buster version of the reported libraries. You can download them at https://packages.debian.org/buster/. However, caution is advised - this may well cause problems later. Before updating to PiAware 6 it may be necessary to uninstall dump1090-fa including libraries (apt purge …).

The alternative would be to compile the dump1090-fa package yourself, but this requires some modifications in /debian/rules.

1 Like

@JensDutzi

Thanks for the advise.

Tonight or tomorrow morning, I will run my automated install script at Github which builds-and-installs piaware and dump1090-fa packages from source code. It has proven successfull on Debian 11 Bullseye amd64 on PC.

Just to have a clean image to start with, before running the automated build-and-install scripts, I will re-image microSD card of RPi Model 2B, using OS image 20210823_raspi_2_bullseye.img.xz

1 Like

FAILED TO BUILD FROM SOURCE CODE

pi@rpi2-20210823:~$ uname -a
Linux rpi2-20210823 5.10.0-8-armmp #1 SMP Debian 5.10.46-4 (2021-08-03) armv7l GNU/Linux

 

git clone https://github.com/flightaware/dump1090
cd dump1090-fa
sudo sed -i 's/dh-systemd,//' debian/control

sudo dpkg-buildpackage -b --no-sign
... ... ...
... ... ...
In file included from dsp/generated/flavor.armv7a_neon_vfpv4.c:18:
dsp/generated/../impl/magnitude_sc16.c: In function 'starch_magnitude_sc16_neon_vrsqrte_armv7a_neon_vfpv4':
dsp/generated/../impl/magnitude_sc16.c:52:5: error: converting a packed 'sc16_t' pointer (alignment 1) to a 'int16_t' {aka 'const short int'} pointer (alignment 2) may result in an unaligned pointer value [-Werror=address-of-packed-member]
   52 |     const int16_t * restrict in_align = (const int16_t *) STARCH_ALIGNED(in);
      |     ^~~~~
In file included from dsp/generated/flavor.armv7a_neon_vfpv4.c:19:
dsp/generated/../impl/magnitude_sc16q11.c: In function 'starch_magnitude_sc16q11_neon_vrsqrte_armv7a_neon_vfpv4':
dsp/generated/../impl/magnitude_sc16q11.c:89:5: error: converting a packed 'sc16_t' pointer (alignment 1) to a 'int16_t' {aka 'const short int'} pointer (alignment 2) may result in an unaligned pointer value [-Werror=address-of-packed-member]
   89 |     const int16_t * restrict in_align = (const int16_t *) STARCH_ALIGNED(in);
      |     ^~~~~
cc1: all warnings being treated as errors
make[2]: *** [dsp/generated/makefile.arm:25: dsp/generated/flavor.armv7a_neon_vfpv4.o] Error 1
make[2]: Leaving directory '/home/pi/dump1090'
dh_auto_build: error: make -j1 RTLSDR=yes BLADERF=yes HACKRF=yes LIMESDR=yes DUMP1090_VERSION=5.0 returned exit code 2
make[1]: *** [debian/rules:48: override_dh_auto_build] Error 255
make[1]: Leaving directory '/home/pi/dump1090'
make: *** [debian/rules:57: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2

SUCCESS - BUILT FROM DEVELOPMENT BRANCH SOURCE CODE

 
image

 

pi@rpi2-20210823:~$ sudo systemctl status dump1090-fa
sudo: unable to resolve host rpi2-20210823: Name or service not known
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
     Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
     Active: active (running) since Wed 2021-08-25 09:35:19 UTC; 6min ago
       Docs: https://flightaware.com/adsb/piaware/
   Main PID: 433 (dump1090-fa)
      Tasks: 3 (limit: 2001)
     Memory: 2.1M
        CPU: 3min 9.230s
     CGroup: /system.slice/dump1090-fa.service
             └─433 /usr/bin/dump1090-fa --quiet --device-type rtlsdr --gain 60 --adaptive-range --fix --lat 43.5xxx --lon -79.6xxx --max-range 360 --net-ro-p>

Aug 25 09:35:20 rpi2-20210823 dump1090-fa[433]: Found Rafael Micro R820T tuner
Aug 25 09:35:20 rpi2-20210823 dump1090-fa[433]: rtlsdr: tuner gain set to about 58.6 dB (gain step 29) (tuner AGC enabled)
Aug 25 09:35:20 rpi2-20210823 dump1090-fa[433]: adaptive: using 50% duty cycle
Aug 25 09:35:20 rpi2-20210823 dump1090-fa[433]: adaptive: enabled adaptive gain control with gain limits 0.0dB (step 0) .. 58.6dB (step 29)
Aug 25 09:35:20 rpi2-20210823 dump1090-fa[433]: adaptive: enabled dynamic range control, target dynamic range 30.0dB
Aug 25 09:35:20 rpi2-20210823 dump1090-fa[433]: Allocating 4 zero-copy buffers
Aug 25 09:35:30 rpi2-20210823 dump1090-fa[433]: adaptive: available dynamic range (26.4dB) < required dynamic range (30.0dB), switching to downward scan
Aug 25 09:35:30 rpi2-20210823 dump1090-fa[433]: adaptive: changing gain from 58.6dB (step 29) to 49.6dB (step 28) because: probing dynamic range gain lower b>
Aug 25 09:35:31 rpi2-20210823 dump1090-fa[433]: rtlsdr: tuner gain set to 49.6 dB (gain step 28)
Aug 25 09:35:40 rpi2-20210823 dump1090-fa[433]: adaptive: available dynamic range (37.1dB) >= required dynamic range (30.0dB), stopping downwards scan here
pi@rpi2-20210823:~$

 

pi@rpi2-20210823:~$ uname -a
Linux rpi2-20210823 5.10.0-8-armmp #1 SMP Debian 5.10.46-4 (2021-08-03) armv7l GNU/Linux

git clone https://github.com/flightaware/dump1090
cd dump1090

git fetch --all
git reset --hard origin/dev

sudo sed -i 's/dh-systemd,//' debian/control

sudo dpkg-buildpackage -b --no-sign
.... .... ....
... ... ...
sudo dpkg -i dump1090-fa_6.0~dev_armhf.deb

 

EDIT:

rtl_test -t showed error 3 and recommended installation of rtl-sdr.rules. Fixed with following command:

sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/f2a9a81/rtl-sdr.rules"

1 Like

First install missing package wget to enable following bash scripts to run

sudo apt-get install wget

Next make a folder named Flightaware to hold sorce codes and build packages

sudo mkdir Flightaware

Every time you want to run any of bash-scripts, first enter the directory Flightaware

cd Flightaware

 

Run following scripts from inside folder Flightaware:

piaware ver 5.0 - Built from source-code (master branch)

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu20-amd64/master/install-piaware.sh)"

dump1090-fa ver 6.0~dev - Built from source-code (development branch)

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu20-amd64/master/install-dump1090-fa.sh)"

After above bash script completes installation of dump1090-fa, run following command:

sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/f2a9a81/rtl-sdr.rules"

 

image

 

dump978-fa ver 5.0 - Built from source-code (master branch)

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu20-amd64/master/install-dump978-fa.sh)"

Assign Dongle Serials

dump1090-fa ver 6.0~dev
sudo sed -i 's/^RECEIVER_SERIAL=.*/RECEIVER_SERIAL=00001090/' /etc/default/dump1090-fa

dump978-fa ver 5.0
sudo sed -i 's/driver=rtlsdr[^ ]* /driver=rtlsdr,serial=00000978 /' /etc/default/dump978-fa

 

piaware-web ver 5.0 - Built from source-code (master branch)

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu20-amd64/master/install-piaware-web.sh)"

 

image

 

Flightradar24 Feeder

sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"

 

Planefinder Feeder

wget  http://client.planefinder.net/pfclient_5.0.161_armhf.deb  
sudo dpkg -i pfclient_5.0.161_armhf.deb  

 

Radarbox24 Feeder

wget http://apt.rb24.com/inst_rbfeeder.sh 
sudo sed -i 's/^VERS=`lsb_release -c.*/VERS=buster/' inst_rbfeeder.sh 
sudo bash inst_rbfeeder.sh  

 

 

ADDITIONAL INFO:

Whenever I issued a command starting with sudo, I got this message:
sudo: unable to resolve host rpi2-20210823: Name or service not known

In spite of the above comment, the sudo command did execute, but the comment was quiet annoying. I finally found solution as follows:

The file /etc/hostname has the host name rpi2-20210823

pi@rpi2-20210823:~$ cat /etc/hostname 

rpi2-20210823

 

The file /etc/hosts does NOT have hostname rpi2-20210823

pi@rpi2-20210823:~$ cat /etc/hosts 

127.0.0.1       localhost 
::1             localhost ip6-localhost ip6-loopback
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters

 

I added rpi2-20210823 in the following line
127.0.0.1 localhost
so it became:
127.0.0.1 localhost rpi2-20210823

Saved the file, and rebooted.
The annoying remark disappeared :smile:

 

1 Like

I have downloaded the image and installed on sd, can’t seem to find what the default user id and password are to start the install on my rpi4.

@jlb56

After you finish imaging microSD card with Debian bullseye for RPi:

Default user name is root and it is password-less, i.e. when asked for password, simply press Enter key.

You CAN NOT login as root using SSH, but can login as root using monitor and keyboard, and create another user (say pi) and assign it password and add to group sudo. After that reboot. After reboot, you can SSH as user pi, and disconnect monitor and keyboard.

Connect monitor and keyboard to login as pasword-less user root, and do following:

(1) Create a new user, say pi and assign it a password.

root@rpi4-20210823:~# adduser pi 

Adding user `pi' ...
Adding new group `pi' (1001) ...
Adding new user `pi' (1001) with group `pi' ...
Creating home directory `/home/pi' ...
Copying files from `/etc/skel' ...
New password:
Retype new password:
passwd: password updated successfully
Changing the user information for pi
Enter the new value, or press ENTER for the default
        Full Name []:
        Room Number []:
        Work Phone []:
        Home Phone []:
        Other []:
Is the information correct? [Y/n] y

(2) Update and install sudo

root@rpi4-20210823:~# apt-get update
root@rpi4-20210823:~# apt-get install sudo 

(3) Add pi to sudoers

pi@rpi4-20210823:~#  su -
root@rpi4-20210823:~# usermod -a -G sudo pi 

root@rpi4-20210823:~# groups pi
pi : pi sudo

(4) Reboot

(5)Now you can SSH as user pi using password you have assigned.

 

Ahh I need to connect one of my PI’s to a monitor etc for the first time, always accessed via SSH lol

That is true for RPi OS (Raspbian) by raspberrypi.org

This one is RPi OS by Debian.org , so naturally there are some differences.

Anyway once you login as root using monitor & keyboard, and create user pi, you can then login as user pi using SSH.

1 Like

That was rather painless. I have a USB mouse / keyboard combo with a USB receiver that has a mini a connector, plug a mini a / usb a lead to that and into the PI4, spare hdmi input on monitor, just needed to purchase a mini hdmi adaptor. A debian lesson complete for the day. Now to wait for the store to open and wait up for the Covid click and collect process. :slight_smile:

Yay connected to a monitor… now to set up. Question though, this project, has anyone also tried this with the current Airspy R2 / mini dump FA RC1 / RC2 project that is been so keenly commented on???

Forgive me if I am doing something wrong, but from the scripts above I was starting to install piaware ver 5.0 - Built from source-code (master branch) and get the following error. I have set up a separate user and follow the instructions above, with nil errors:

“” sudo bash -c “$(wget -O - https://raw.githubusercontent.com/abcd567a/piaware-ubuntu20-amd64/master/install-piaware.sh)”
-bash: wget: command not found. realise didnt need sudo command but wget is where it is getting stuck.

I have the debian tested image on the sd card.

This distro lacks package wget. Install it first, then run the bash script.

sudo apt-get install wget

 

Thanks. As you are aware, first time with debian. I am use to the raspi-config, to set up your sd card, locations etc, what is the Debian equivalent?

sudo dpkg-reconfigure tzdata

 

1 Like

That worked. L O L whilst I am at the bottom of this post, you are at the top editing things… funny

Yes, after reading your post, I added instructions to install wget at top of bash scripts post. :slightly_smiling_face:

1 Like

Yay I am your crash test dummy L O L

One thing I notice in difference to your previous install scripts, the ““piaware web”” section as an option, is missing.