Radarcape MLAT re-occurring issue


#1

I have a Radarcape receiver and it often shows this message on my Flight Aware stats page -
This feeder is not being used for multilateration because its timing information appears to be unreliable. This can be caused by the site location being incorrect, or because your Pi is running out of free CPU.

Anyone know what could be causing this and any fixes?

It works fine for about 6 hours or so after I do a power reset on it, but after 6 hours or so it comes up with that View Anomalies message on the stats page. If I power cycle it again, it works fine again, but I dont want to have to keep power cycling it all the time.

Leigh


#2

Leigh,
I have a radarcape that has been running well for a couple of years. Are you doing MLAT with another provider? This may be causing an issue.

Jon


#3

what are the contents of your piAware Config from the radar-cape. From the status tab (flightaware). remember we dont need to see your key


#4

Hi Jon,
Thanks for the reply.
I’ve only had my Radarcape about a month.
I dont think I’m doing MLAT with another provider, as far as Im aware I’ve only set it up for working with Flight Aware. I will go through all its settings though later.

Leigh


#5

theresjam, im not at the site at present but will find out the info at next opportunity.


#6

Jon,

I had JetVision MLAT Enabled, Im guessing thats just to send info to the Jetvision Mlat. I’ve disabled it now. Maybe that could help?


#7

You can try jetvision.de for support too. They are pretty responsive.
Also there is a yahoo group https://groups.yahoo.com/neo/groups/ModeSBeast/info

FYI, de VK2TCW / K2TCW


#8

yeah no worries, was going to compare the configuration to mine.

I also feed to fr24 and jetvision mlat without a hitch so i’m thinking its just something not set right.

I think the fr24 feeder is unique to the radarcape and can use the GPS time sync, the FA client needs to know its feeding from a radarcape/beast it could be that simple.

heres the contents of mine

allow-manual-updates yes # updated by fa_piaware_config
allow-auto-updates yes # updated by fa_piaware_config
allow-mlat yes # updated by fa_piaware_config
allow-modeac no # updated by fa_piaware_config
image-type radarcape # updated by fa_piaware_config
mlat-results-format ext_basestation,listen,30106 # updated by fa_piaware_config
receiver-type radarcape-local # updated by fa_piaware_config


#9

OK yes, am still having issues with MLATs staying on even after disabling the other MLAT services so looks like something else is amiss. I can access the Radarcape remotely and thus can do system re-boots, but there still not lasting long at all before the error comes back on Flight Aware page - here if u want to look - https://flightaware.com/adsb/stats/user/VK2KRR#stats-73845

This is my piAware Config, same as yours except I dont see the allow manual updates and the allow auto updates parts.

allow-mlat yes # updated by fa_piaware_config
allow-modeac no # updated by fa_piaware_config
image-type radarcape # updated by fa_piaware_config
mlat-results-format ext_basestation,listen,30106 # updated by fa_piaware_config
receiver-type radarcape-local # updated by fa_piaware_config

In the piAware Log area, its telling me -
mlat-client (516) : Server Status : Clock unstable.


#10

Leigh,

You can ssh to the device and run
sudo apt-get update
sudo apt-get upgrade
Then reboot
This may update piaware to 3.5.3

My FA config looks the same
I feed other providers too.

Is there a chance the GPS unit doesn’t have a clear view of the sky(slightly to the North because of the orbits)? This is just a wild guess as the clock on the radarcape should be very accurate.

FYI, You have really good range(I am only 10M AMSL). I have had good results adding a filter(I use the jetvision cavity filter) and amp to my radarcape. I live near a lot of mobile phone towers (5-10 <300M away) and three major airports so noise is a big issue. You look to be pretty rural so may work well without a filter.
(edit: looking at your other equipment, you may have already done this).

I see another radarcape not too far away
https://flightaware.com/adsb/stats/user/wyehoota
It would help except I believe that most high flights >FL240 use ADS-B already. This has been upgrade to v3.5.3.

Here are some of the issues fixed in 3.5.3

FYI, I have an old Army buddy that works are your nearest airport (Wagga Hospital).

Jon


#11

if you can ssh into the radarcape, i would suggest adding the allow manual update, the command is below.

sudo piaware-config allow-manual-updates yes

then issue the following command

sudo systemctl restart piaware

this will allow you to send the update pi-aware command from your feeder page.

i would ccheck the GPS pages as hinted at above it might shed some light on the matter


#12

At the risk of sounding silly, I dont know what is meant by “ssh into the radarcape” ?
Is there any instruction on this? I am not familiar with how it all works.
I would like to try the upgrade to 3.5.3

Leigh


#13

Sorry Ive done a google search and downloaded Putty for ssh.


#14

On my network PC Ive run Putty and followed the instruction on the radarcape wiki but cant access the Radarcape via Putty, can anyone provide some directions? I cant find any specific information about it.


#15

First things first:

Do you know the IP address assigned by your router to Radarcape? The Radarcape username and password?


#16

Hi Dxista

Yes I do, I can access it and view the info on the Radarcape via the local network here no problems.


#17

I don’t have a Radarcape, but try configuring Putty the same way as needed to access the RPi: SSH using port 22. SSH must be enabled in the Radarcape.


#18

SSH should be enabled by default so need to do anything there.

i tend to put in the address like so root@ipaddress and then you should be prompted for the password.

there is a chance you will be prompted by a window to except the key used (been a while since i have connected to anything new SSH wise)


#19

Guys,

When I set up the Radarcape, I downloaded the 3.5.0 package for Pi Aware from this page http://wiki.modesbeast.com/Radarcape:Radarcape_Major_2_Feeder_Installation

Is there somewhere I can download the 3.5.3 package for Radarcape Pi Aware so I can just upload it in the same manner described on that page?

Leigh


#20

Leigh,
This should work for you
(just section 2 should update piaware for you)
https://flightaware.com/adsb/piaware/install