Radarcape Major2 update - Use the manual file upload for FA


#1

I upgraded my Radarcape to the major2 update which allows me to run the normal FA client.

However i made a bit of a balls up of the installation, which i fixed. No major issue just user error (i was tired). I added the client manually rather than use the Radarcape upload option so my bad. I had just used the manual install method on another pi so just did the same again forgetting what i was logged into.

Anyhow the issue is it registered the feeder on the 1st of January 1970 (i guess before the GPS was up after a reboot) so when i entered the unique identifier from my old PI setup (set to connect to the Radarcape) it is ignoring it and using the new site number 43860.

I’m not to fussed about the stats and stuff they will come back with time just a warning for others follow the instructions :slight_smile: i just hope the date doesn’t cause you any problems.


#2

I did mine on Sunday. The only issue I have is that my FA site,
flightaware.com/adsb/stats/user/ … tats-43617
doesn’t show up as a radarcape on
FlightAware ADS-B Coverage Map or Nearby Sites sections.

I just uploaded the V3.3 file then did an apt-get update from the cli. I think I needed to reboot once or twice.
Now showing Feeder Type: PiAware (Radarcape) 3.5.0
It is nice to be able to feed multiple providers from one device(at least 1090Mhz any way).


#3

It shows up as a piaware site on the maps because, as far as FA cares, it is a piaware site, just happens to be being fed by Radarcape hardware.


#4

I did the manual file upload of piaware v3.3. Now I’m trying to figure out how to update it to v3.5. All I see on the Flightaware site to download are the image files.
It can’t be done from the flightaware stats page because there is no command line entry like there is for the RasPi. When you say you did an apt-get update from the cli, what does cli mean?
Can I do that command just thru ssh?


#5

after a reboot try
sudo apt-get update
sudo apt-get upgrade


#6

I tried that and I’m still at v3.3. I even tried “sudo apt-get install piaware” and it says I’m already at the newest version. It’s a mystery.


#7

You can probably follow the package install instructions here: flightaware.com/adsb/piaware/install
Specifically if you install the piaware-repository package, that will make the radarcape aware of new versions via apt-get.

(But I do not have a Radarcape to test that on)


#8

Thanks, that worked fine. I’m now at v3.5.


#9

Hi I have just received my Radacape, I have managed to get it feeding to Flightaware, but I can not work out how to link it to my old FA id. I can do it real simply in my old 1090 mutability via SSH but not sure how its done with the FA that is in built with Radarcape.


#10

SSH into the box and use the following command

sudo piaware-config feeder-id “xxxxxxxxxxxxx”

replacing the x’s with your id.

then restart the fa client with

sudo piaware-config -restart


#11

Thanks theresjam, I tried the old 1090 nethod, came up with an error re the radarcape directory but then appeared to apply the new station to my old id and it worked.