FlightAware Discussions

Radarcape dual antenna system

What i described now will work with any package add on install, no matter the platform.

It’s just the previous method using piaware-config that only works on the piaware sd-card image.

The piaware sd-card image is just what it says, it’s the image you put onto an sd-card that has piaware on it. Available here https://flightaware.com/adsb/piaware/build

Package add-on means that you manually installed the packages https://flightaware.com/adsb/piaware/install

Right thanks. Just setting the card up again.

Ok XU4 set up again and feeding to flightaware etc. Now in your advice, in regards to combining 1090, I am about to start that, as mentioned earlier, your

in my set up that line appears like this:

RECEIVER_OPTIONS="--device-index 0 --gain -10 --ppm 0 --net-bo-port 30005"

not quite what you referred to?? what do I change, your instruction

[quote="wiedehopf, post:16, topic:54971"]
and change `--device-index 0 --gain -10` to `--net-only`
[/quote]

I didn’t quote the entire line, just what to replace.

It’s obvious :wink:

to look like this??

RECEIVER_OPTIONS="–device-index 0 --net-only -10 --ppm 0 --net-bo-port 30005"

If i say change A to B, that means replacing A with B.

Maybe it’s ambiguous to say change.

But seriously i expect to just read the options and think a moment.
device index refers to the dongle, you are not using a dongle so you don’t need that option.
same goes for gain, that setting doesn’t apply because you are not using a dongle.

dump1090-fa --help

There it’s explained how command line options for this program work.

I am glad you said ambiguous, in the line above there are two items with – in front of them, which one do I change.
I do not know that device index refers to the dongle, same with the gain (although I thought that might be changed) . What should that line look like completely. Is it not easy for both sides if you show now change this line

[quote="jlb56, post:23, topic:54971"]
RECEIVER_OPTIONS="--device-index 0 --gain -10 --ppm 0 --net-bo-port 30005"
[/quote]

to this …
Unfortunately I do not have the knowledge you do with scripts and find it so much easier for someone to say and show, change that line to this, not a portion that has 2 possibilites

Replace this string
--device-index 0 --gain -10
with this string
--net-only

That isn’t ambiguous.

Understanding command line options really isn’t complicated.
But i see some people don’t want to think about it, i’ll most likely still explain it but be a bit cranky that the person isn’t willing to think themselves.

Indeed not …:slight_smile:

Ok combine 1090 done. You say:

my sudo nano /etc/default/combine1090

shows me SOURCES= 127.0.0.1 127.0.0.1

I change that to read SOURCES= 10.168.0.4 10.168.0.4

That will duplicate all messages on the target receiver.

#Append all IP addresses running dump1090/piaware in the next line, 127.0.0.1 is just an example you should replace it        

This is a script for combining multiple receivers, the commend would say if the IP address would need to be there twice.
As you only have one source, there is only one ip address.

But i’ll change the default setting, it seems to confuse other people as well.

Right seem to have got that working. :slight_smile: Am about to add on the graphs. Will your improved web interface work on the combine1090 map??

The way you set up the redirection, the data will be on the main dump1090-fa a /dump1090-fa
Everything will work normally.

The interface at /combine1090 will have no data (you changed the TARGET).

Don’t forget to sudo systemctl restart dump1090-fa combine1090
But if you have it working, that’s no longer needed.

You can disable/stop the extra dump1090-fa running, but it’s not important:
sudo systemctl disable --now combine1090-dump

I’m a little confused why you didn’t want to use the RPi, it’s plenty fast for this purpose.

Ok the graphs working, but the tar1090 map is showing but no planes. Swap over to the combine1090 got the planes but not your whiz bangs

That’s what i wrote. Seems you missed that.

I did… fixed and working now

Just fiddling with a raspberry pi with the above relay. The pi is set up from a piaware sd-card, but applying the script, does not seem to be swapping over to the radarcape for data.
My piawarde-config result:

 sudo piaware-config
allow-auto-updates             yes                            # value set at /etc/piaware.conf:7
allow-manual-updates           yes                            # value set at /etc/piaware.conf:8
radarcape-host                 10.168.0.6                     # value set at /etc/piaware.conf:10
receiver-type                  radarcape                      # value set at /et

Is there something missing??

restart piaware or reboot the pi?

Yea tried that, still didn’t want to play. Worked fine last time I did it, same scenario… Only difference it was with 3.7.1 ???

Probably not a piaware sd-card image.
Otherwise the settings would be in /boot/piaware-config.txt