FlightAware Discussions

Pro Stick went missing

Hi,

After months of working well, my Pro Stick has started to not show up.

I say started because from time to time it pops up a few positions, and then it goes missing again.

When missing, it does not even appear on the USB bus as reported by lsusb. Also, rtl_test says no devices found.

It is correctly plugged and a LED blinks inside.

I am using a Raspberry Pi 3B+ powered by PoE using the official PoE HAT. This hasn’t changed. Also the PoE switch (a Cisco SG series) hasn’t changed, either.

The only messages that seem related are found on dmesg, which is full of these:
[ 2917.898060] usb 1-1.1-port2: over-current condition
[ 2917.898219] usb 1-1.1-port3: over-current change
[ 2917.988198] usb 1-1-port2: over-current change
[ 2918.147970] usb 1-1.1-port2: over-current change
[ 2918.228056] usb 1-1-port3: over-current change
[ 2918.387995] usb 1-1.1-port3: over-current change
[ 2918.767831] usb 1-1.3: new high-speed USB device number 119 using dwc_otg
[ 2918.914520] usb 1-1.1-port2: over-current change
[ 2919.148076] usb 1-1.1-port3: over-current change
[ 2919.518413] usb 1-1-port4: over-current change

These seem to happen when the probe appears and works for a little:
[ 2900.297728] usb 1-1.3: new high-speed USB device number 118 using dwc_otg
[ 2900.439554] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=2832
[ 2900.439567] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2900.439576] usb 1-1.3: Product: RTL2832U
[ 2900.439585] usb 1-1.3: Manufacturer: Realtek
[ 2900.439594] usb 1-1.3: SerialNumber: 00001000
[ 2900.447192] usb 1-1.3: dvb_usb_v2: found a ‘Realtek RTL2832U reference design’ in warm state
[ 2900.448422] dvb_usb_rtl28xxu: probe of 1-1.3:1.0 failed with error -71

I tried of course searching around, but nothing relevant popped up.

It has been mounted indoors in a wall rack, so I I don’t suspect ambient conditions.

Any ideas about which part is to blame? Anybody seen this before?

Thanks in advance.

The early version of the Poe HAT has problems supplying current to the USB somehow.
You are probably lucky that it worked at all before.

https://www.raspberrypi.org/forums/viewtopic.php?t=220984

They solved the issue by adding a small pcb to the design, that was fitted to all the boards they received back from retailers or were still stored their warehouses.

The second batch should have a different design that does not need the additional pcb, but I am not sure those are produced and on sale.

It seemed to be a pretty obscure problem, some boards worked, other did not. Id check for the pcb, and try if other usb devices also trigger the overcurrent warning, then it is probably the PoE hat.

Given the over-current warnings, it is almost certainly the PoE HAT problem; the problem was that it would falsely trigger the USB current limiter in some circumstances.

I will try an external PoE dongle and report back. Thanks a lot!