FlightAware Discussions

PiAware web interface

I’ve just set up PiAware, and I’m reporting data now. When I go to look at the web interface to my PiAware Pi, I can connect with no problems to http://<ip.ad.dr.ess>:8080, but http://hostname.example.com:8080/ attempts to redirect to https://hostname.example.com:8080/ and times out.

I have two questions / concerns:

  1. How can I connect to the interface using the hostname instead of the IP?
  2. Can I connect securely (https), making use of a LetsEncrypt certificate, or is it only http?

Thats your host/DNS redirecting - Edit your settings there.

1: Edit DNS/redirect setting with your hosting/DNS company
2: Unfortunately you need a gateway (like CloudFlare) to get HTTPS, PiAware does not support it. (Not that I know of)

This isn’t my host redirecting - this is the PiAware lighttpd software redirecting. The hostname I’m going to resolves to the local IP address (and vice-versa). Nothing is ever leaving my local network in this case.

the default name is raspberrypi so if you’ve only got one Pi and your router is working OK, using http://raspberrypi:8080 should work

Then make it clear, what you’re trying to do - You can’t redirect local without some DNS-settings on your own DNS-server.

I have no clue about lighttpd, but i have worked with network for donkeys years. PiAware never calls for https - I can’t figure out, what you are trying to do - Post some more info. (hostnames, etc.)

Well, after opening up some browser diagnostics, it turns out it’s the idiot browser doing an internal redirect to https due to the combination of unmodifiable HSTS settings and using a .dev domain. DNS is all correct, everything resolves the way it’s supposed to, then Chrome goes and tells me “I know you said http, but you really means https so I’m redirecting you to https.”

Effing Chrome. (And yes, Firefox does the same stupid stuff.)

There is a setting in Firefox to not automatically use HTTPS.
Look in about:config.

If you use the ip address then the Firefox browser ignores http/https stuff. Try your ip like this: 192.168.251.32:8080/ in the address window. (at least, that is how it seems to be working here) Good luck

I’ve managed to isolate the problem (see my earlier post re: HSTS and .dev domains) and to resolve it by enabling HTTPS on the lighttpd server with a LetsEncrypt certificate.

1 Like