PIAWARE SSH Server


#1

Hi iam new here and i have a raspberry PI 2 i want to know if on the PIAware imge the ssh server is enabled or i have to do it by my self?


#2

its enabled


#3

If you’re using a Mac open up Terminal and click on “Shell” and “New Remote Connection”.

I use


ssh -p 22 pi@10.0.0.45

to connect to the RPi. pi is the user, so change this if you use a different name and don’t forget to change to the correct IP. Windows I can’t help you with.


#4

You can omit the -p 22. The image is configured with the default port, so there is no need to specify it.


ssh pi@IP Address


#5

What is the default password? raspberry doesn’t work for me.


#6

Password “flightaware”


#7

Thank you! That worked! Now I’m trying to get my MLAT results to show up in VRS. I would like to use a single port and enable the MLAT traffic through the 30005 port instead of setting up multiple receivers in VRS. Is there a command I can send via SSH to enable this? I don’t feed to others via 30005 so I don’t mind if my MLAT is mixed with ADS-B.

I’ve tried sending this command: sudo piaware-config -mlatResultsFormat “beast,connect,localhost:30004 basestation,listen,31003”

But I cannot figure out how to configure VRS properly to show the 2 receivers. MLAT never shows up in VRS. I don’t know if I’m suppose to click the merge setting or what…

Thanks in advance to any help!


#8

This is how I have done it:

STEP 1 OF 3

STEP 2 OF 3

STEP 2 OF 3


#9

Thank you abcd567!! That helps me out quite a bit! I think I have it running correctly now! I wish there was a way just to feed both the ads-b and MLAT in through one port and have them show in VRS as a different color just as they are in the dump1090. How did you set up the flags to display in VRS? It appears that file is no longer available to download to populate those fields… Is there another place to find this? Thanks for your help!


#10

So I’m trying to ssh into my piaware and I’m having issues:

ssh pi@10.0.1.16
Connection closed by 10.0.1.16

When I try the ssh -v pi@10.0.1.16 I get:

OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: Connecting to 10.0.1.16 [10.0.1.16] port 22.
debug1: Connection established.
debug1: identity file /Users/XXX/.ssh/id_rsa type -1
debug1: identity file /Users/XXX/.ssh/id_rsa-cert type -1
debug1: identity file /Users/XXX/.ssh/id_dsa type -1
debug1: identity file /Users/XXX/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version OpenSSH_6.0p1 Debian-4+deb7u2
debug1: match: OpenSSH_6.0p1 Debian-4+deb7u2 pat OpenSSH*
debug1: SSH2_MSG_KEXINIT sent
Connection closed by 10.0.1.16

Sorry for being a Linux noob, but what do I need to do to get setup?


#11

Looks like the stock PiAware image might have some issues? I resolved this by:

sudo rm /etc/ssh/ssh_host_*
sudo dpkg-reconfigure openssh-server


#12

Just want to confirm that I used the above reset of the RPi SSH and things are working for me again; it does appear that the stock PiAware image may have some issues to be dealt with…


#13

[ Edit: I’m upgrading to 3.5.3, not 3.5.0. ]

Was this ever solved? I’m trying to upgrade an existing PiAware 2.something setup to 3.5.3, but I would be losing SSH access to the PiAware. (I was able to successfully SSH to the old installation, using “/home/pi/.ssh/authorized_keys”.)

I’ve created the “ssh” file in the root of the SD card (the directory that shows up as “/Volumes/piaware” when I mount the SD card on my Mac – “piaware-config.txt” is in the same directory), and on the Mac, I’ve renamed the “known_hosts” file in my .ssh directory.

I’m going to Google some more – this seems like a generally misconfigured SSH server problem – but it’s a bit of a bummer that there doesn’t appear to be an easily-accessible “Debugging SSH on PiAware” FAQ… :frowning: