PiAware periodic UDP error messages


#1

I only stood up PiAware for the first time a week ago on an RPi 2 model B.

Recently I started getting these messages:

Mar 19 18:09:10 rpi2 piaware[2754]: NOTICE from adept server: 12% of multilateration messages (UDP) are not reaching the server - check your network?

Then shortly after something like:

Mar 19 18:15:33 rpi2 piaware[2754]: 1740 msgs recv’d from dump1090-fa (536 in last 5m); 1626 msgs sent to FlightAware

I have a rather default FIOS Quantum Gateway router but the RPi is hooked up to a Netgear WNDR4300 running dd-wrt that is a wireless access point to the FIOS router. The RPi is hooked up via ethernet to the netgear.

Any tips on troubleshooting why not all messages are making it across?


#2

Bypass the Wifi and confirm the issue goes away. It’s often a Wifi issue. After all, it’s UDP, not TCP.


#3

Yeah I guess I should do that. The place I have it now is the easiest place to put it where the antenna is at least somewhere close to being outside. I could run it directly from the router through the basement then outside. I’ll have to try that next.


#4

Using wifi, in general, isn’t a bad thing. Many folks do so with no issue. If you confirm it goes away after removing wifi, you need to find the root cause of the wifi problems. My home system start dropping UDP packets if other systems are saturating the wifi (like during hard drive backup to a network attached drive).


#5

I’ve got 4 security cameras also communicating at one step or another over wifi. I’ll have to plug the pi back into where i originally had it and see if I still get the errors.


#6

There are so many 2.5Ghz WAPs in the area that I moved most of my stuff to 5Ghz.
Only my Nest and sense don’t work on 5Ghz.

You may benefit from a wifi USB dongle.

All of my RPIs and radarcape are powered via POE. I just ran power to the attic so I can run 4 from a POE switch.


#7

I’ve got a POE switch in the garage. Unfortunately it connects to the main router via the netgear device. I have no convenient way to hard wire down to the basement.

I do have a USB dongle lying around. I originally tried piaware on an old RPi v1, which had issues with wifi. But that didn’t seem to draw enough power to read from the receiver, so I dusted off an RPi 2.


#8

The wifi antenna on the Pi is not a great device. Changing the orientation of the antenna part can help a great deal. On the Pi 3, the antenna is a gray small box between the DISPLAY and GPIO connectors. Router antennas are generally vertical, so you want your PI wifi device to be vertically oriented also. You may have to reposition your Pi so the USB ports go vertically, and generally point in the direction of your router. Hope it helps.


#9

Is switching from wifi to Ethernet as simple as plugging the RPi into the a switch or are there commands that have to be sent to the RPi? My RPi does not have a keyboard or screen so typing in commands would be difficult.


#10

Yes, ethernet is configured by default. But you’ll get a different IP address than you had with wifi.


#11

Uhhh… What? :thinking:

I assume you’re stating that in the case of him using a USB wifi adapter? The Pi3 on-board antenna, being as small as it is, isn’t really going to be affected by vertical or horizontal orientation issues.

Best case scenario, skip the on-board wifi altogether and get a 2.4/5GHz USB wifi adapter with an external antenna from Amazon for $10-$15 and call it a day. At that point, you can aim the antenna to whichever orientation applied based on the location of the router (which could be above or below the location of the Pi for all we know).


#12

I’m using a Pi2.

I went to try the wifi adapter then realized that since the Flightaware receiver is the size of an elephant, I can’t use any of the other USB ports.

Waiting on Amazon Prime to deliver a USB extender.


#13

With the USB extender in place giving room for the wifi adapter, I’ve only seen one UDP error this afternoon. Must have been too much traffic flowing through the secondary router with two cameras also on it.