PiAware online but not in local network


#1

Hello,

I wanted to test two different setups and they both have a similar problem.

  1. Raspberry Pi 2 with Piaware and USB Wifi (3.5.3, built 15days ago)
  2. Raspberry Pi 3 with Raspbian and dump1090-fa (3.5.3, built 8 days ago)

While both continue to deliver data to FA.com and both can be controlled via the “device commands” (reboot etc.) on the website, they disappear in the local network. Neither reachable with the local IP via browser or SSH. They are not listed in my routers DHCP table anymore.

After I send a reboot command via FA.com they are reachable for a time period I am trying to determine right now.

Anyone with a similar problem and/or a solution to this?

Thank you
Alex


#2

This is really strange. This doesn’t look like a problem with the piaware since the sites are sending data and responding to the reboot command.

If you think this is the PiAware device problem you can check the logs by going to your my-ADSB page and clicking on the gear icon. Near the bottom of the site configuration it will show the status logs for the last few minutes. If everything is working fine then the logs will have every 5 minutes x messages to flightaware. https://flightaware.com/adsb/stats/user/alexseitz

I would definitely check the computer you are connecting from. Try connecting with a different web browser or computer on your network? This will rule out some networking configuration problems and specific computer problems.

If that doesn’t work than the router itself might be the problem. Maybe google the router model type with why DHCP device are not showing up on the table.


#3

I forgot to mention that I have seen some routers prevent connections to port 8080.
You can connect to your http://IP without the :8080 at the end.

You can find your current site IP on your my-ADSB stats page.


#4

Alex, this is indeed odd.

The units are reporting (as David said) which means they should appear in your DHCP lists!

A couple of questions - are they connected via Wi-Fi or cable?

And do you still know their IP addresses? Are these within the general range of your other UP addresses?weeks

Lastly, what make and model router do you have, and is the firmware up to date?

Hang in!


#5

Thank you for your help.

I tried to connect from different computer or mobile phones with different OS. All worked fine till that one moment. No previous port troubles. First I thought there is something wrong with the DHCP lease, but it has been renewed during the afternoon (was valid for at least 12h more).
And as I am typing this (22:30ish), they have disappeared from the list again. Still reachable from the tab I had still open, even when refreshing, but not from a new browser on a different computer.

Both are currently connected via wifi, I’ll test tomorrow via cable and get the exact router information.

Logs 1.
[2018-01-10 22:23 CET] 20188 msgs recv’d from dump1090-fa (93 in last 5m); 20188 msgs sent to FlightAware
[2018-01-10 22:28 CET] 20258 msgs recv’d from dump1090-fa (70 in last 5m); 20258 msgs sent to FlightAware
[2018-01-10 22:33 CET] mlat-client(767): Receiver status: connected
[2018-01-10 22:33 CET] mlat-client(767): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.0kB/s UDP to server
[2018-01-10 22:33 CET] mlat-client(767): Results: 3.3 positions/minute

Logs 2.
[2018-01-10 22:24 CET] 8852 msgs recv’d from dump1090-fa (23 in last 5m); 8852 msgs sent to FlightAware
[2018-01-10 22:29 CET] 8886 msgs recv’d from dump1090-fa (34 in last 5m); 8886 msgs sent to FlightAware
[2018-01-10 22:34 CET] 8905 msgs recv’d from dump1090-fa (19 in last 5m); 8905 msgs sent to FlightAware

(I know, not much traffic since I am testing indoor)


#6

A random thought: in some wi-fi router setups, the wi-fi network is isolated and not reachable from the “LAN” hosts. The hosts on the wi-fi network can get out to the internet but are otherwise isolated in these cases. Unfortunately I have forgotten how to check on the router for such a configuration.


#7

Thanks for the information.

Will have a think!

Have you tried using a fixed IP address for the Pi? This may be worth trying if you have not done this before.