piaware NooElect dongle RX performance


#1

Built up a Raspberry Pi B+ with the NooElect USB dongle and included antenna. Was working pretty good from home even with just the USB dongle included antenna in my home office.

Today moved the whole setup to a mountain top site - its connected to the Internet OK and it looks like maybe a couple of ADS-B reports have been received by FlightAware … but clearly there’s an issue with receive performance.

What I suspect may be happening is RF interference to the USB dongle - we’ve got TV, FM and other transmitters here. (Because of the recent snow and ice I wasn’t able to get the external antenna installed - that will have to wait for some future date). The indoor location here on the mountain top is in a wooden structure not much different than the home environment (which is why I expected much better coverage even with the indoor antenna).

As I have no previous experience with DUMP1090 or the hardware I’m looking for tips / pointers on ways to troubleshoot this. I’m a bit concerned that once setup with the external antenna I still may not see decent reception. With the location being quite a few hundred feet HAAT and in the clear I was hoping for good results. (Location N42 05 02 W72 42 15)

And a related question: is it normal for the DUMP1090 map from the built-in web server to centre on Milan Italy when there are no received / decoded ADS-B messages?

Bob W1QA


#2

How is your antenna setup now vs before? Is it in a window at least?

Yes, I’ve seen it center on Europe when it’s not picking up any traffic.


#3

At home near a window didn’t work too well - a combination of having screens and window glaze cause for a lot of attenuation. Worked best just with the magnetic base on an adjustable work lamp at my desk!

At the mountain top site near the ceiling of a room - close to an old window (no glazing).

Saw a couple of decodes that didn’t have lat/lon … and I think two for scheduled aircraft on final to KBDL likely low elevation and very close nearby.


#4

Bob,

If you want to make the map always center on a certain point, a quick file edit is possible. In the dump1090/public_html folder is a javascript file called config.sys. Within it are some constants, which include the default lat, lon for map center and a zoom level. Just change those to the point you want to center on and at what zoom level.

Marty


#5

Thanks Marty:

I also see some dump1090 startup options:

–lat
–lon

Do those have the same effect of centering the map? (I’m using the FlightAware piaware image which I believe has its startup at:

/etc/init.d/fadump1090.sh


#6

Additional info:

The piaware log shows that its getting nothing from dump1090 (and every few thousand seconds restarts dump1090).

rtl_test finds the RTL2832U R82OT tuner - no problems with the continuous read from the device.

I stopped the dump1090 (using fadump1090.sh) and manually ran dump1090 --interactive … nothing displayed (no decodes).

Guess I need to read something on the debug capabilities of dump1090? Is there anything in dump1090 that can tell you its even receiving a signal - or a utility that can give you a simple spectral display of the USB dongle?


#7

Bob, you could use SDR# or any of the SDR receive programs and a laptop to observe the whole spectrum (need to go on site). From what you describe overloading seems most likely to me. A bandpassfilter could help.
/paul


#8

Unfortunately not (though that’s a change I’ve been meaning to make for ages).

Those settings control local position decoding. The position format is ambiguous if you only have a single position message; having a local receiver location lets dump1090 disambiguate it, as the possible positions have a minimum separation of a few hundred miles. (You need two position reports - an “even” and an “odd” message - within a few seconds of each other to find an unambiguous global position).


#9

Hoi Paul:

I’ve ordered up a second USB receiver (and B+ Pi) and will use that to look into the laptop based SDR software.

Since it did decode some ADS-B packets yesterday I’m thinking it may have well been when I was handling the USB device (thereby possibly shielding it from RF ingress). We have high power emitters on 102.1 and 198 MHz albeit about 150 m above the piaware location. Of more concern are probably some of the cellular installations which are only 60 m above the piaware. Some of these are in the 900 MHz range – maybe that’s part of the problem.

I will look into possibly wrapping the USB device in foil tape, winding a choke on the import coax as well as using a bandpass filter between the antenna and the receiver.

The plan is to mount the external ADS-B antenna on a pole approximately 4 m above the roof. In total there will be about 5 m of Andrew 7/8 inch feedline to the USB receiver. When I get that mounted I will connect a spectrum analyzer to the feedline to get an idea what signals are being presented to the USB receiver.


#10

You may want to manually turn down the gain that dump1090 uses (–gain on the command line) - it defaults to the max available (probably around 49dB)


#11

We have high power emitters on 102.1 and 198 MHz albeit about 150 m above the piaware location. Of more concern are probably some of the cellular installations which are only 60 m above the piaware. Some of these are in the 900 MHz range – maybe that’s part of the problem.

Poor SDR… I posted some notes here which describe a filter that keeps away 930 Mhz GSM at 230m line of sight at my place. I can even use a preamp and SDR at full gain.


/Paul PA3DSB


#12

Thank you so much for this! I have been trying to find a 3rd party program that will do just that and it’s already built into dump1090. You made me very happy today! :smiley: (By the way, the file is /usr/share/dump1090/config.js)

Click my link to see what it looks like. Circles are 25, 50, 100 and 150 miles.
pi2dubya.ddns.net/


#13

I guess it depends on how you installed dump1090, whether standalone or via the FA image. The file path location I quoted is from a standalone dump1090 install about a year ago.

Marty


#14

[quote=“beckerm13”]

Ah, I see. I installed the Piaware image. So now people who make these changes know where to look, depending on their install method.


#15

My setup contained the file in “/usr/share/dump1090/public_html/config.js”

Thanks for the tip.


#16

Thanks all - here’s some stats from dump1090:

pi@piaware ~ $ sudo dump1090 --stats
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
Found Rafael Micro R820T tuner
Max available gain is: 49.60
Setting gain to: 49.60
Exact sample rate is: 2000000.052982 Hz
Gain reported by device: 49.60
^C

Statistics as at Mon Dec 1 01:46:44 2014
2225 sample blocks processed
0 sample blocks dropped
0 ModeA/C detected
229509 valid Mode-S preambles
0 DF-?? fields corrected for length
96 DF-?? fields corrected for type
0 demodulated with 0 errors
0 demodulated with 1 error
0 demodulated with 2 errors
0 demodulated with > 2 errors
0 with good crc
0 with bad crc
0 errors corrected
0 with 1 bit error
0 with 2 bit errors
0 total usable messages
pi@piaware ~ $


#17

Very interesting. After stopping dump1090 (using the piaware image) I then ran dump1090:

sudo dump1090 --gain 43 --interactive

And immediately I started seeing decodes … this is encouraging especially since for 30.11.2014 I think it only decoded one plane all day!

I’ll poke around and see if I can find where this is invoked in the piaware build and adjust the gain …


#18

Thanks Paul - nice looking filter. Earlier today I did order a filter off of eBay (item 151059589242) which is a K&L MICROWAVE model 4B341-1090/T109-OP/O

One question on your filter: I see it was modeled for 75 ohms - I think the NooElect dongle I have is 50 ohms?!

Side note: one of my ham interests is EME … if you have a QRZ account lookup NC1I … 4,5m RF HAMDESIGN dish for 23cm and use a 3 or 4 pole filter there as well for 1.296 GHz (we have the Boston Center regional radar nearby and it operates in the same band).

Bob W1QA (ex PA3GCQ)


#19

They’re 75 ohm - the dongles are generally designed to plug into TV antennas when used as a DVB-T receiver.


#20

to adjust the gain in the piaware image I did the following:

sudo nano /etc/init.d/fadump1090.sh

Then in the PROG-ARGS string I added at the end:
–gain 43

after saving the file I just rebooted the unit:
sudo shutdown -r now

While by no means is it optimal its decoding something - which is a lot better than nothing! Next steps will be to get external antenna setup with BPF and additional RF shielding of the SDR-RTL dongle.