PiAware 3.5.1 - sudo service piaware status - RASPBIAN 9.1 (STRETCH)


#1

Hello.

I am new in Raspbian Stretch (9.1).
I have 1 question to ask.

After I type “sudo service piaware status”, it shows all the details as per standards but at the last line, it will show lines 1-20/20 (END)

pi@raspberrypi:~ $ sudo service piaware status
● piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2017-11-03 06:15:56 +08; 28min ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 535 (piaware)
CGroup: /system.slice/piaware.service
├─535 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
├─697 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat x.xxx --lon xxx.xxx
└─710 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,301

Nov 03 06:21:32 raspberrypi piaware[535]: 101 msgs recv’d from dump1090-fa (95 in last 5m); 101 msgs sent to FlightAware
Nov 03 06:26:32 raspberrypi piaware[535]: 208 msgs recv’d from dump1090-fa (107 in last 5m); 208 msgs sent to FlightAware
Nov 03 06:31:10 raspberrypi piaware[535]: mlat-client(710): Receiver status: connected
Nov 03 06:31:10 raspberrypi piaware[535]: mlat-client(710): Server status: synchronized with 3 nearby receivers
Nov 03 06:31:10 raspberrypi piaware[535]: mlat-client(710): Receiver: 10.0 msg/s received 7.5 msg/s processed (75%)
Nov 03 06:31:10 raspberrypi piaware[535]: mlat-client(710): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.1kB/s UDP to server
Nov 03 06:31:10 raspberrypi piaware[535]: mlat-client(710): Aircraft: 3 of 3 Mode S, 1 of 1 ADS-B used
Nov 03 06:31:32 raspberrypi piaware[535]: 285 msgs recv’d from dump1090-fa (77 in last 5m); 285 msgs sent to FlightAware
Nov 03 06:36:32 raspberrypi piaware[535]: 347 msgs recv’d from dump1090-fa (62 in last 5m); 347 msgs sent to FlightAware
Nov 03 06:41:32 raspberrypi piaware[535]: 412 msgs recv’d from dump1090-fa (65 in last 5m); 412 msgs sent to FlightAware
lines 1-20/20 (END)

***To quit the "lines 1-20/20 (END), I need to key “q”. Then command window change back to pi@raspberrypi:~ $ again.

It looks strange to me as this only happen in piaware. I tried on pfclient, it doesn’t show that.

I hope to get any experts to answer and guide me how to fix this issue. Thanks in advance.


#2

This is just the pager (less) being used to show output that’s larger than a single screen. That behaviour is part of systemd, not part of piaware.


#3

Pfclient status is static, and does not show number of massages sent. Once started, it stops any update, unless restarted by systemctl/service/init.d/reboot. Hence it has a limited number of lines.

Last three static lines are:

Nov 02 19:26:10 raspberrypi systemd[1]: Starting LSB: planefinder.net ads-b deco
Nov 02 19:26:10 raspberrypi pfclient[535]: Starting pfclient: pfclient.
Nov 02 19:26:10 raspberrypi systemd[1]: Started LSB: planefinder.net ads-b decoder

On the other hand piaware status is dynamic, gets updated and entries added as the message sending progress, similar to updating of the log file:
cat /var/log/piaware.log
Hence has a large number of lines, which overflow the ssh console height.


#4

Thanks for the info. So, this is a normal and not bugs or enabled something unnecessary during installation or updating. Is it what you mean? I just simply ignored it and quit with keying “q” everytime I see this? Thank you.


#5

YES.

Yes, that is what I always do.


#6

You can set the PAGER environment variable if you’d prefer a different pager.


#7

abcd567,

Thanks for the info. Regards.


#8

obj,

Can you advise me how to set the pager environment as I am not familiar with it.

If possible step by step. Thank you. I can learn from here and remember it if you can share the details.

Regards.


#9

Here is a starting point for you: http://www.refining-linux.org/archives/3/Configuring-your-console-pager/


#10

@obj Tried following, same problem with all of these: Need to press Enter and/or Q keys

sudo systemctl status piaware -l | more

sudo systemctl status piaware -l | less

sudo systemctl status piaware -l | pg

sudo apt-get install most
sudo systemctl status piaware -l | most

sudo apt-get install lv
sudo systemctl status piaware -l | lv

.

EDIT
Removed package lv as it became default for ssh console. After removal, the ssh display became as before.

pi@ubuntu:~$ sudo dpkg --purge lv

#11

You probably want to look at “less -F”

  -F or --quit-if-one-screen
         Causes less to automatically exit if the entire file can be displayed on the first screen.

Or you can set PAGER=cat if you really don’t want a pager at all…


#12

I tried and also the same problem as what you described. Need to press Q key to quit.

Thank you for the try. Regards.


#13

obj,

Thanks for the info, I tried it but not work, anyway, just ignore it by pressing “Q” everytime I want to check the status.

Regards.