Piaware 3.3.0 + Airspy / MLAT.


#1

Hi all,
I’m trying to set up one of my two sites with airspy + PA 3.3.0.
Here are a few settings:


sudo netstat --program --protocol=inet --tcp --wide --all
Proto Recv-Q Send-Q Adresse locale          Adresse distante        Etat        PID/Program name
tcp        0      0 *:http-alt              *:*                     LISTEN      526/lighttpd    
tcp        0      0 *:http                  *:*                     LISTEN      526/lighttpd       
tcp        0      0 *:30005                 *:*                     LISTEN      1525/airspy_adsb
tcp        0      0 a.b.c.d:38379      a.b..flightaware.com:1200 ESTABLISHED 506/piaware     
tcp        0    469 a.b.c.d:30005      w.x.y.z:54342   ESTABLISHED 1525/airspy_adsb
tcp        0      0 localhost:56818         localhost:30005         ESTABLISHED 9725/fa-mlat-client
tcp        9      0 localhost:30005         localhost:56020         ESTABLISHED 1525/airspy_adsb
tcp       12      0 localhost:30005         localhost:56818         ESTABLISHED 1525/airspy_adsb
tcp      269      0 localhost:55836         localhost:30005         ESTABLISHED 32067/faup1090  
tcp       12    101 localhost:30005         localhost:55836         ESTABLISHED 1525/airspy_adsb
tcp    41030      0 localhost:54006         localhost:30104         ESTABLISHED 1525/airspy_adsb


and



ps auxww | grep dump1090
piaware   9725 10.7  1.0  13020  9784 ?        S    mars02 401:12 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,listen,30104 --udp-transport w.x.y.z:5610:3462244209


With these settings:

  1. MLAT is marked as Support/Enabled, but I’m not synchronised with any nearby sites (I used to be with over 80 sites “near” me).
  2. No aircraft, either MLAT or ADSB, shows on the dump1090 map.

The latest logs for the mlat part:

Mar 4 15:40:24 piaware piaware[506]: mlat-client(9725): Receiver status: connected
Mar 4 15:40:24 piaware piaware[506]: mlat-client(9725): Server status: not synchronized with any nearby receivers
Mar 4 15:40:24 piaware piaware[506]: mlat-client(9725): Receiver: 339.0 msg/s received 55.0 msg/s processed (16%)
Mar 4 15:40:24 piaware piaware[506]: mlat-client(9725): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.6kB/s UDP to server
Mar 4 15:40:24 piaware piaware[506]: mlat-client(9725): Aircraft: 6 of 12 Mode S, 13 of 23 ADS-B used

If one of you has a clue, you’ll be more than welcome!
Thanks.
Oliver


#2

What are you using to talk to the airspy? Multilateration is very dependent on having accurate timing information; if your decoder software doesn’t get this right, mlat won’t work.


#3

Post your airspy_adsb config (removing anything private).
There is plenty of info here to setup an airspy post201474.html?hilit=airspy_adsb#p201474

Ensure that your location is set correctly on your FA website. flightaware.com/adsb/stats/user/ … stats-5995
(OBJ probably already checked this).


#4

Hi both,

Fist, thanks for answering.

  1. My location and elevation is set properly.
  2. I upgraded from an “old” dump1090-mutability setup to PA 3.3.0. Everything was fine before.
  3. I have read the precedent post about airspy configuration. However things seem to be slightly different with this piaware setting.
  4. NTP is enabled and working OK and MLAT worked before with a simple USB RTL-SDR key on the same setup. No timing problem seen in the logs either.
  5. I don’t have any airspy_adsb config file. Just lauching it at startup with the options shown in my previous post ( ./airspy_adsb -c localhost:30104:beast -l 30005:beast -c -p -b -n -w 4 -g 21 )
  6. The setup is standalone. Just airspy_adsb, and the PA 3.3.0 tools. ADSB decoding is fine. No MLAT errors in the logs either.

So I’m more thinking about an issue relative to a missing open port or something like that.


#5

It’s almost certainly a problem with airspy_adsb as mlat-client is reporting it’s connected and seeing messages, but the timing information in those messages is never close enough to the data provided by other receivers to allow synchronization to happen.

Unfortunately airspy_adsb is closed-source so I cannot provide any support for it, you should contact the author for support.


#6

You didn’t post your airspy_adsb config/setup above.
Remove the -l part and restart and you should be fine. You can’t have dump1090 and airspy_adsb listening on the same port.


#7

try:
sudo airspy_adsb -c localhost:30104:beast -p -n -w 4 -g 21 -f 0 &

unless you need bias-tee enabled, add the -b back in.