PiAware 1.15 not found when trying to do update


#1

I used the following command at the command line after opening the LX Terminal. It said “404” “Not found”

wget flightaware.com/adsb/piaware/fil … _armhf.deb

Should I have rebooted and started from that command line? Or what else?


#2

To me, that indicates that the place where the program was being downloaded from was not ‘up’ or you mistyped the files name/command.
I would try it again. I do not think rebooting your RasPI would help.


#3

I can’t reproduce this…can you try again?


#4

Will try again in the next day.


#5

I did try this again using the command line wget flightaware.com/adsb/piaware/ffi … 1armhf.deb

The result always is a response like this:
Connecting to flightaware.com…connected
HTTP request sent, awaiting response … 404 not found

I am using a wireless adapter as mentioned in the original instructions for building of this device. Download speed at the location of the device is 10Mbps.

At this point I don’t see any course of action to update on-line so instead will remove the SD card and load the updated program image as I did originally with the Win32DiskImager software.


#6

I think you may be manually typing the URL and experiencing a typo. Your top link is correct, the one in your most recent post isn’t, which causes the 404.

The correct URL Is: flightaware.com/adsb/piaware/fil … _armhf.deb


#7

After double checking my typing, I did succeed in updating. It took a couple of attempts as I got a response wget: unable to resolve host address ‘flightaware.com