PIA Aware Stopped Working - A few dumb questions


#1

I have had my PiAware working for a couple of years. The other day I got notified it wasn’t feeding data. Usually I just unplug it and it restarts. This time it was the power supply. While I wait for that I used a generic charger and right cable to power it. It worked for a couple of days and then stopped. I plug it in and it stops. I hooked it up to a display and keyboard and everything looks ok as far as I can tell.
I made a great effort to see what was going on for ideas and have not found anything divitive on my own. I some things I found referred to “sudo systemctl”. Everytime I try I get “systemctl not found”. I tried apt-get and that didn’t work.
Obviously I really haven’t looked at it since I set up. I have very old knowledge of Unix concepts, but I really have no working knowledge of Linux other than the basics and I understand what is happening. Forgive my ignorance.
I have PiAware 3.5 installed on a Raspberry Pi B+ V1.2.
If there is some other things to look at logs that would be helpful, I just don’t if there are or how to look?
If I need to use “systemctl” how do get that installed because apt-get isn’t working?
If the solution is to upgrade is that straight forward or should I get a new SD card?

I appreciate any help.

Kevin


#2

Well, the quickest and easiest solution would be to write a new image to a sdcard. This is probably a good idea anyway, as a new image has just been released based on the current debian version, stretch.

The system stopping by itself is usuallly not a good, sign, maybe in the end some files got corrupted on the card. Also, sdcards tend to fail in the end, especially unbranded ones, so if it has been running for a couple of years, it might be a good idea to swap that, too.

If you reimage, do not forget to note your feeder id from your stats page and put in piaware-config.txt, so that your site is identified correctly.

Edit: apt-get is a way to update/upgrade the installed programs, systemctl allows you to start and stop services, so they really do different things. I guess the error you encounter means it cannot start a service, not that it itself is not installed.


#3

I would recommend reimaging on a new sd-card. That is easiest, now a few no so easy suggestions :slight_smile:

If you want root: “sudo su -l”
then you don’t need to use sudo all the time.

try “/etc/init.d/piaware restart” and see what that does.
What about apt-get does not work?
Try apt-get update followed by apt-get install vim and see if that works.
Post errors if any come up. Oh yeah either put sudo in front of the commands or become root before doing them.

You can look at /var/log/piaware.log also. Actually that is a better suggestion than the others.
Use less or vim to open the log :wink:
Press shift-g to scroll to the end.


#4

Thank you both for the input. I think I will just start with all fresh. That would probably best. I appreciate.


#5

Also sudo -i works.