FlightAware Discussions

Pi with piaware wants to connect to 'local'


#1

My pi zero has flightaware 3.6.3.installed, from the image povided by Flightaware. Nothing altered except the piaware-config.txt and the ‘ssh’ file in root.

I installed a new router and with it came some “parental control” type of access rules. And since I reckoned that the pi running piaware only need to talk to flightaware.com I let the router manage the pi.
Watching the logs I quickly discovered it also needs ntp.org, which I whitelisted. All good.

However, each time I restart the pi I get a message from router it has blocked a connection attempt to local. Is that an attempt to connect to the loopback interface and can I add that to some kind of hosts file? Or is it something else?


#2

To be honest i don’t want to even guess because you should just whitelist the pi as being grown up and be done with it.

Without a proper message from the router what exactly it blocked it’s really hard to know.

The router can’t block the pi using its loopback device because the router doesn’t even know about the pi loopback device. It’s literally an internal connection from the pi to the pi that works even when not connected to the router.


#3

Just ignore it. It’s the default behavior when multicast DNS (mDNS) is enabled. It’s advertising itself and looking for other things in the *.local domain. raspberrypi.local, appletv.local, printer.local, and so forth. Even if your router didn’t block, anything looking up a *.local outside of your LAN will fail. It’s a non-existent domain outside of a LAN.


#4

Thank you, exactly the kind of answer I was looking to get.