Out of order Timestaps

Hi, I know there are a number of threads on this issue. I’ve tried to remedy the problem with most of the solutions others came up with, to no avail. I must be overlooking something and feeding MLAT messages back into the system but I just can’t figure out how.

Looking at the amount of out of order timestamps it’s a great issue at my site. I tried to remedy the problem with a new freshly installed RPI but got the same problem.

I know timing and location are crucial in getting good MLAT results hate to be part of an ‘interference’ problem in the network.

This setup is an RPI3 that had no problems for more than a year, It’s dedicated to ADSB and feeds PF, Flightaware an FR24. Acars and S-band ACAR experiments are done on an other board, connected to my network but no active connections with the Piaware server.

This is the tail of the actual Piaware log file:

Jun 20 11:46:29 luchtvaart piaware[593]: mlat-client(1885): Aircraft: 16 of 60 Mode S, 58 of 102 ADS-B used
Jun 20 11:46:29 luchtvaart piaware[593]: mlat-client(1885): Out-of-order timestamps: 799
Jun 20 11:46:51 luchtvaart piaware[593]: mlat-client(1885): Warning: the timestamps provided by your receiver do not seem to be self-consistent. This can happen if you feed data from multiple receivers to a single mlat-client, which is not supported; use a separate mlat-client for each receiver.
Jun 20 11:48:58 luchtvaart piaware[593]: 1888639 msgs recv’d from dump1090-muta (2570 in last 5m); 1888048 msgs sent to FlightAware
Jun 20 11:53:58 luchtvaart piaware[593]: 1891418 msgs recv’d from dump1090-muta (2779 in last 5m); 1890827 msgs sent to FlightAware

There is a significatnt problem, but have no idea how to solve it cause I can’t pinpoint the cause.

Any ideas ???

You need to provide detailed information on your configuration or there’s nothing that can be diagnosed here.

Do you see any problems with an unmodified piaware 3.5 sdcard image?

Well an “out of the box” installation solved the problems… I’ll try to figure out what caused the problems on my old installation. Strange cause it was fine for over a year…

And with this month old image I’m pretty much a newbie again, you don’t seem to pick up mac-adresses anymore :smiley: