FlightAware Discussions

Optimize Gain - which would you chose


If you want to get technical that percentage of messages has an amplitude of 0.7 or greater.

A large percentage is an indicator that probably some messages have an amplitude to large to be detected it’s unknown though how large that percentage is.

Even when i set my gain so that i get 10% Messages > -3dBFS i don’t see a drop in Message numbers. But i can guess that then i’m probably losing a few percent of messages or something. Not that you can really detect that as you may decode some more weaker messages and 1% variation is really small to see compared to traffic and weather changes.

Only @retman1222 with his splitter can only really make any measurements on how many messages he loses. And even he would need to do each measurement in reverse with the dongles switched or something because the dongles are different as well.


I have a splitter between my Pi and the Flightfeeder (orange one).
Sad part is that the FF gets more planes/messages, no matter what gain I try on my Pi (with the blue FA ProStick Plus dongle).


Isn’t that just the prostick plus as well? Or is it the prostick without the SAW filter?
Anyway the dongles even of the same make are not all created equal :slight_smile:

One difference could be where the blue bandpass filter is. Before or after the splitter?
Anyway the splitter probably reduces the range of both devices.


I have both of them. I was using the blue one (with filter), I have just replaced now with the orange one (no filter). But in front of both I have a preamp with two SAW filters.

Still some 10% pos/sec less and 5% less aircrafts. Still tuning.

PS: You should submit those changes to GitHub, so they are incorporated in the ADSB project. That’s great work!


So the preamp is before the splitter?
If it’s the double LNA preamp from rtl-sdr blog then you don’t need any other filters i’d say.

I’m curious do you have a picture of that whole contraption?


Yes, preamp it’s common. See pics, sorry for the dust, it’s in an open attic/garage.

The neat feature that FF has is that you can see the “CRC passed” and “Signal Clipped”:


That’s an interesting preamp.

Is the reception better when you have the blue bandpass filter in front of the preamp?


It doesn’t change, that’s what I was trying now. I guess the preamp first stage doesn’t get overloaded by other frequencies. I’ll leave it in, since I have it.
The difference between the orange and blue FA sticks is also negligible, so I have put back the blue dongle. The orange one I am using it usually for UAT 978MHz… but I think I’ll stop that.


How do you supply power to the preamp?

Or rather what power supply do you use?


It’s an old 5V/200mA power supply that had a barrel connector that I cut and soldered. Don’t know where I got that.
I have a 3-way 120V power extension up there, one used by the Pi power, one for the preamp power.


You may try to salvage two old inductors from old electronics and solder them inline with each of the power supply leads going to the power supply so the noise / ripple from the power supply does not affect the preamp.
May not make a difference but as long as you don’t short anything it shouldn’t hurt either :slight_smile:


For anyone interested in the changes i made to the graphs, you can download the two relevant files from github instead of editing them with the commands below.
(Changes: Fix data collection of Messages >-3dB and display those messages better)

On the raspberry pi execute the following commands and be sure to copy the entire lines:

cd /home/pi/adsb-receiver/build/portal/graphs
wget https://raw.githubusercontent.com/wiedehopf/adsb-receiver/freeze/build/portal/graphs/make-collectd-graphs.sh -O make-collectd-graphs.sh
wget https://raw.githubusercontent.com/wiedehopf/adsb-receiver/freeze/build/portal/graphs/dump1090.py -O dump1090.py
sudo systemctl restart collectd

Enjoy improved graphs.

Restoring the original files:

cd /home/pi/adsb-receiver/build/portal/graphs
git checkout dump1090.py make-collectd-graphs.sh
sudo systemctl restart collectd

Edit: Changed the graph slightly to improve spacing between the number and the percent sign.

How to show gain setting
Sudden Loss of range
Another gain question

After above modification.

Pi #1, dump1090-mutability, Mag-mount on cookie-can, FA Filter, Pro Stick Plus, Gain 49.6


After above modification.

Pi #2, dump1090-fa, FA Antenna, FA Filter, Pro Stick, Gain 49.6


the same wget works for either mutability or fa?


YES, same commands worked on my two Pi’s, one with fa other with mutability.



Downloaded files were saved with extension .sh.1 and .py.1
Copied these over existing files, the graph changed from -3dBFS/15 minutes to -3dBFS/10 minutes. Please see my next post.




no doubt, i am cursed. i followed the commands but no luck. the graphs do not include the percentages as shown in your posting. i did sudo systemctl restart collectd in the adsb-receiver/build/portal/graphs directory and when that didn’t make the change i did a cd command and then tried to restart collectd from there.
i am using the fa version…any recommendations


Do the graphs still update or are they frozen in time?

Oh nvm wget does not overwrite files :slight_smile:

I’m sorry.


AS the files of same name are existing, wget command saves these with an extra .1 at the end, i.e. as:
Please see screenshot below.


I gave additional commands to copy downloaded .1 files over the existing files:

sudo cp make-collectd-graphs.sh.1  make-collectd-graphs.sh
sudo chmod +x make-collectd-graphs.sh
sudo cp dump1090.py.1  dump1090.py

At the end restarted collectd and updated graphs

sudo systemctl restart collectd

sudo ~/adsb-receiver/build/portal/graphs/make-collectd-graphs.sh 24h