No command line prompt after WiFi instructions


#1

Newbie here.

After following the FA instructions for adding WiFi, and enabling the network_monitor.sh script in /etc/rc.local, after rebooting, everything comes up fine; I’m sending Live data, WiFi is up (although I’m still feeding FA my data via my Ethernet cable plugged in)…

…except…on my attached monitor keyboard/mouse, I cannot enter any Linux command, and it never gives the Pi login prompt. Last lines shown are

My eth0 MAC address is …snip…
My wlan0 MAC address is …snip…
My IP address is 192.168.1.6 192.168.1.6

I can type stuff and it’s echoed back, but no login prompt.

I must hv a typo somewhere either in network_monitor.sh or in /etc/rc.local

But I can’t access anything on the monitor.

I’m sending live data but can’t access anything via command line.

Help.


#2

Can you still SSH into it?


#3

Never have tried SSH…don’t have it set up. I’m reading about it…but never installed Putty on the Pi. I have a Mac and a Windows PC I could try…but don’t know how to use SSH yet.


#4

I believe if you installed the Pi from the FA image, SSH is enabled by default. For clarity, PuTTY is a client that connects to an SSH server. If you’re on a Linux or Mac, you probably have the SSH client built in and don’t need PuTTY.

For Windows you can get PuTTY http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

From the Mac open a terminal window and type:

ssh pi@(ip address of PI) eg: ssh pi@192.168.0.200

You’ll probably get a message about verifying the RSA fingerprint, type yes and hit enter

The password is I think raspberry

That should get you in and able to poke around in your rc.local.

Here’s mine for comparison:


#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

if  ! -e "/etc/ssh/ssh_host_dsa_key" ]
then
    echo "generating unique ssh server host keys... (this is a one-time thing)"
    dpkg-reconfigure openssh-server
fi

# Print the IP address
_IP=$(hostname -I) || true
if  "$_IP" ]; then
  printf "My IP address is %s
" "$_IP"
fi

exit 0



#5

Thanks Rj… SSH login was successful. Found my typo in /etc/rc.local (forgot to add the ‘&’ at the end of the network_monitor.sh command just before the “exit 0” line in /etc/rc.local.

Fixed. And we are happy again! :smiley:


#6

No problem, glad you got it worked out.


#7

Syntax, killer of the unwary :wink: Been there done that, someone stole the t-shirt