FlightAware Discussions

Network flood

Hi,
thanks to the performance graphs I did a check on my syslog of my Rpi (buster version)
It’s flooded with dhcpcd messages, it mysteriously stopped but it’s back after a reboot,
anybody has an idea to correct this :
ip address of the RPi is 192.168.1.244
messages :


Jun  6 14:06:09 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244
Jun  6 14:06:09 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244
Jun  6 14:06:09 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244
Jun  6 14:06:09 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244
Jun  6 14:06:10 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244
Jun  6 14:06:10 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244
Jun  6 14:06:10 aludra dhcpcd[403]: eth0: received approval for 192.168.1.244 

graph on CPU :

Thanks for any input

Check the DHCP lease time settings in your router or DHCP server. On a router the management console is typically accessed from a browser.

For my home network I assign a DHCP reservation (by mac) for each device and set the lease time to 24 hours. That way the device IPs essentially become static.

I use a static IP address (forgot to mention that) on eth0 and WiFi is disabled in the /boot/config.txt file.
the DHCP lease time is 86400 seconds = 24h

Probably this: https://www.raspberrypi.org/forums/viewtopic.php?t=265516
(tl;dr: try removing inform from your dhcpcd.conf)

Thank you , that worked !