Mlat no longer working for me


#1

This is the message in the log file: mlat(6170): fa-mlat-client: error: argument --results: formatlist: exactly three comma-separated values are needed (see help)
Does anyone have any ideas? Running 2.1-3 and have rebooted it a couple of times.


#2

I am still using old version, so I do not have experience on my own, but is not this problem caused by changing ports in this version? See this thread: ads-b-flight-tracking-f21/piaware-2-1-3-released-t36047.html


#3

This means you provided a bad value to piaware-config -mlatResultsFormat.
Unfortunately piaware-config doesn’t check the value you give at the time you run it.

What is the command line for fa-mlat-client logged in the piaware logs? (just before the error you quoted)


#4

Here is more of the log: Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --results formatlist --udp-transport 70.42.6.197:7494:847230288
[2015-10-04 05:40 EDT] mlat(5556): usage: fa-mlat-client -h]
[2015-10-04 05:40 EDT] mlat(5556): --input-type {beast,sbs,dump1090,radarcape_gps,radarcape_12mhz}]
[2015-10-04 05:40 EDT] mlat(5556): --input-connect INPUT_CONNECT --results RESULTS]
[2015-10-04 05:40 EDT] mlat(5556): --udp-transport UDP_TRANSPORT
[2015-10-04 05:40 EDT] mlat(5556): fa-mlat-client: error: argument --results: formatlist: exactly three comma-separated values are needed (see help)
[2015-10-04 05:40 EDT]


#5

Yeah, you misconfigured the results setting somehow. (They’re set to “formatlist” which isn’t valid, maybe you cut+pasted that from somewhere and forgot to replace it with an actual list of formats)

Try:



$ sudo piaware-config -mlatResultsFormat default



#6

Did that Ojb now have this: 2015-10-04 11:05 EDT] mlat(6642): Receiver status: connected
[2015-10-04 11:05 EDT] mlat(6642): Server status: synchronized with 2 nearby receivers
[2015-10-04 11:05 EDT] mlat(6642): Receiver: 146.3 msg/s received 2.4kB/s from receiver
[2015-10-04 11:05 EDT] mlat(6642): Server: 1.7 kB/s from server 0.0kB/s TCP to server 1.4kB/s UDP to server
[2015-10-04 11:05 EDT] mlat(6642): Results: 769.4 positions/minute
[2015-10-04 11:05 EDT] mlat(6642): Aircraft: 75 of 100 Mode S, 12 of 17 ADS-B used
[2015-10-04 11:06 EDT] mlat(6642): Beast-format results connection with localhost:30004: [Errno 111] Connection refused
[2015-10-04 11:06 EDT] 32439 msgs recv’d from dump1090 (1110 in last 5m); 32439 msgs sent to FlightAware
[2015-10-04 11:06 EDT] mlat(6642): Beast-format results connection with localhost:30004: [Errno 111] Connection refused
[2015-10-04 11:07 EDT]


#7

Slightly at a loss how you got it into this state; it’s in some sort of half-installed state where you are apparently running bits of the piaware 2.1-2 core (since it’s defaulting to trying port 30004), but other bits of it are 2.1-3.

If you don’t have other customization that you want to preserve, I’d suggest just re-imaging the whole sdcard and starting afresh: flightaware.com/adsb/piaware/build (step 2). You’ll need to upgrade piaware and dump1090 via the web control panel after reinstalling as the sdcard image for 2.1-3 hasn’t been built yet.

Or try reinstalling the piaware package manually from the instructions here: flightaware.com/adsb/piaware/install (step 2)


#8

Thanks for the help Obj. Manually reinstalled everything over SSH and Mlat planes are on the map now.


#9

I just did a batch upgrade for everything and this is the same thing I get as well. I was at 2.1-2 now at 2.1-3.
Do I need t climb the tower and bring down the Pi for a manual upgrade?

Thanks.


#10

Not the same problem; if you have manually set the mlat results format configuration in the past using piaware-config, and you have updated to the newer FA dump1090 that changes its default beast input port from 30004 to 30104, then you need to update your manual configuration to match the new port.


#11

I just happened to notice today that both of my receivers were no longer forwarding MLAT data to Virtual Radar. Searched and found this thread. I guess one of the auto updates disabled MLAT because I never turned it on in the past and piaware-config showed no MLAT features enabled. I turned them on and I now appear to have the tracking working :mrgreen: