FlightAware Discussions

May 1 2020, My Dump1090 Stopped Working on My Amazon Fire

Guys, Apologies if I’ve got the wrong category…

w.e.f May 1 2020, my Amazon Fire HD 10 using their “Silk” browser stopped displaying the map and flight info. From the “PiAware Status” page using the “Go to 1090 SkyAware Map” link it starts the new page with the rotating wheel thingy and the “NightRider” effect but never completes. Was OK end of April.

Turns out I’ve always had a no-show on my Sony Smart TV browser. It does what Silk does now. Would have been good to have my TV displaying stuff but now my Amazon Fire has also failed.

I installed Chrome on my Fire and the SkyAware Map worked straight away, so not actually the Amazon Fire. Clearly something has been made a whole lot better in a way that’s totally stuffed my normal access.

There must have always been something odd about the SkyAware HTML output because my Sony TV never worked, Amazon Silk browser worked up to end April and a new install Google Chrome works along with all my other browsers on Win10/Ubuntu, The Dump1090 GitHub version date isn’t recent but I haven’t found any date yet for a Silk update.

So, what’s changed?

Not clear what software versions you’re running; you don’t appear to have an active PiAware site?

Sorry Guys. I omitted the most important bit…

I am running version 3.8.1~pbo8+1
Edit: OS = PRETTY_NAME=“Raspbian GNU/Linux 8 (jessie)”

I have since found here that this version was released 25th March 2020 although I am not certain when it got to my system. It has been set to auto-update from when this was available.

I can confirm my site is working locally, my Chrome and Firefox has connected to my PiAware and is displaying aircraft although very little is happening out there so maybe I just don’t look active. Then there is I guess a time zone difference and a war on.

Just tried the Amazon Fire’s Silk browser. After an unusual mount of time the spinning wheel resolved centered on Milan Italy. I’m in UK 100miles west and up a bit from London.

On centering the map Silk reports “Problem fetching data from dump1090. AJAX call failed (error). Maybe dump1090 is no longer running? The displayed map data will be out of date.” Which confirms getting a map centered on Milan, Italy. The URL shown is the correct one “piaware1.lan/dump1090-fa/”.

Chrome is displaying normally as is my Ubuntu Firefox.

I’m interpreting all this as Amazon Silk browser can’t do it any more suggesting something very subtle has changed. As I said above, the Sony TV browser has never worked but seems to fail in the same way.

Thank you for your attention. SteveW.

We started doing autoupdates of this recently, so the 1 May timeframe sounds about right.

This means that the ajax calls just aren’t working at all from Silk for some reason (the map centered on Italy is a giveaway - that means that the receiver position metadata file couldn’t be loadede at all)

I’m not familiar with Silk at all - does it give you a debug console (equivalent of Chrome’s F12 mode) or anything that would let you see why the ajax request is failing, but only there?

OBJ,
Have had a look at Amazon’s Silk browser and haven’t found any clever bits that could help here. Remember the Amazon Fire series of tablets are only aimed at selling Amazon’s vast amount of nonsense to the world. The thing just wants me to buy games n stuff but is useful to see what’s flying past me when I’m sat in the garden.

Don’t get me started on how easy it is to get an Amazon Prime account and how 'kin difficult it is to get rid of one.

SteveW

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.