FlightAware Discussions

Low circling over my house not tracking

I have the Stratux device shown in the link below. It has both 978 and 1090 antennas. It seems to show everything that flies over my house. I’ve replaced it’s Stratux flash card with a PIAware card. The latter does not report a large number of occurrences of small planes circling very low over my house. Any thoughts on how to get tracking to occur, presumably by modifying the configuration of one card or the other?

Thanks,
Thomas

my guess would be that the gain is too high on the PiAware card. did you run through the configuration here: Howto : Piaware SD card image 3.8.0 Quickstart Guide ?

instructions for adjusting gain are in section 10.

incidentally, -10 in the 1090 config sets the gain to auto, which is often too much gain so the starting point is often suggested as somewhere in the middle of the range (1-49)

1 Like

Have you configured piaware with the serial numbers of the two dongles so that it knows which is which, and enabled 978? (Out of the box, 978 is not enabled; and if you don’t tell it which dongle is which then both 1090 and 978 tend to compete for the same dongle)

Thanks for the info. I’ve read through it and about a thousand other sources over the past week. I’ve learned a lot, but the domain of info is so large that I’m now rather disheartened.

In short, I just need for piaware to see my 978 device. I’ve found the device via journalctl including its serial number. However, neither rtl_test nor rtl_eeprom can see the device, neither by id nor by serial number - they only see the 1080 device. I’ve tried all of this after stopping the piaware and two dump services.

The 978 device is working when I use the stratux rpi image. I’ve dug into stratux a fair amount and, long story short, I have a ton of dishes and laundry that have built up during this effort, so I have to scale back for a while.

My guess is that something is grabbing hold of the device, preventing it from being accessible to the rtl tools. Any ideas on how to know what may have a hold on it, or more importantly, how to force them to let go?

Thank you.

Nah it’s a special stratux device that’s not compatible with rtl-sdr as most dongles are.

There is an option for stratux 978.
I believe the option is:

sudo piaware-config uat-receiver-type stratux

After changing it, just reboot.

Can’t find any documentation on it right now.

Close. Should be “stratuxv3” not “stratux”. This requires a piaware image. For direct use with dump978-fa, replace the various “–sdr” options with “–stratuxv3” on the command line.

Yeah, sorry :frowning: It’s only semi-officially supported; I got as far as getting support into dump978-fa and piaware-support but it’s not particularly common (and no 978 over here to test against) so it doesn’t get much attention.

Thank you. Do I need to do something special to have my device see both the 1080 and the 978? I changed only the uat-receiver-type using the command line, but it appears that only the 978 is being seen.

Am I better off just flashing and starting new?

Well I had 1080 on the brain. 1090 does seem to be doing something. More info as I dig in.

Both feeds now work! Thank you!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.