FlightAware Discussions

Java API / NetBeans behind on versions

The Java/Netbeans Aero API instructions and examples are many versions in arrears. Java is up to about version 14, and Netbeans on version 12. The example on the Aero API are for versions 8 (both). Consequently, a number of Java Jar libraries are no longer available or applicable.

Creating a transportable/usable Jar file to work with a custom application to access flight/location/times on Linux systems is highly problematic.

Are there plans to upgrade the Java/Netbeans instructions/examples?