FlightAware Discussions

Is it wise to switch to switch to "buster"

Hi guys,
at the moment I’m running since 2018

  • Piaware (version 3.8.1 at the moment)
  • fr24-feeder
  • adsb receiver installation for perf. graphs (disk i/o and disk bandwith heve no values anymore)

on “stretch”.
Is it needed or advisable to run it on “buster”
And if so I presume a new installation from scratch is needed ?

Thanks for any advice
Patrick

I think an upgrade is possible, but maybe you give a new install a try.
The receiver graphs can be also generated by using the great script of @wiedehopf

Few days ago I revamped my 3 Pis, and these are now as follows:

- RPi 2B - Piaware sd card image 3.8.1 (Buster)
Installed FR24, Planefinder, Radarbox24, Adsbexchange, Graphs by @wiedehopf (NOT from the adsb-project)

- OrangePiPC - Armbian Buster
Installed dump1090-fa 3.8.1, piaware 3.8.1, FR24, Planefinder, Radarbox24, Adsbexchange, Graphs by @wiedehopf

- RPi 4B - 64bit Raspbian Buster
Installed dump1090-fa 3.8.1, piaware 3.8.1, FR24, Planefinder, Radarbox24, Adsbexchange, Graphs by @wiedehopf

FR24

$ sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"

## Caution: During configuration of fr24feed, never choose “Receiver DVBT”. 
## Choose Receiver: ModeS Beast(TCP), host/port: 127.0.0.1:30005

Planefinder

$ wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb  
$ sudo dpkg -i pfclient_4.1.1_armhf.deb 

## Go to page IP-of-PI:30053 to complete configuration

RadarBox24

$ sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"

$ sudo rbfeeder --setkey xxxxxxxxxx --no-start   
## Replace xxxxx by your actual key
## Press Ctrl+C to break log output.

$ sudo systemctl restart rbfeeder  

Graphs by Wiedehopf

$ sudo bash -c "$(wget -q -O - https://raw.githubusercontent.com/wiedehopf/graphs1090/master/install.sh)"  

 

For installation of 64 bit Raspbian, and 64 bit dump1090-fa + 64 bit piaware (RPi 3 & RPi 4 only)

Howto Install Piaware 3.8.1 on 64 bit Raspbian OS / Pi4

 

 

 

2 Likes

@Patrius

Before you write fresh image, from exixting install, copy-paste feeder keys in Notepad on your desktop/laptop and save notepad:

Plane finder key:
The sharecode is in the file /etc/pfclient-config.json
Scroll right to see it in full. Your Planefinder sharecode is the last item in this long line.

{"tcp_address":"127.0.0.1","tcp_port":"30005","select_timeout":"10","data_upload_interval":"10","connection_type":"1","aircraft_timeout":"30","data_format":"1","latitude":"xx.xxxx","longitude":"yy.yyyy","sharecode":"zzzzzzzzzzzz"}    

Flightradar24 key:
The fr24key is in the file /etc/fr24feed.ini

Radarbox24 key:
The key is in the file /etc/rbfeeder.ini

From my experience the RB24 key is assigned automatically. RB support told me it’s based on the MAC Adress and needs to be changed only i case the network connect changes

I installed my device several times and was never required to enter the key for RB24.
However it is always good to have a backup :slight_smile:

Not sure what you’d gain by switching unless there is an issue with your existing setup. Newer is not always better, especially based on some of the “Microsoft’ish” dev I’ve seen going on with Debian.

2 Likes

Thank you for your advice.
I didn’t install radarbox in the past , maybe a good opportunity to do it now.
@abcd567 when I understand you correctly
your RPi2B you used the http://piaware.flightcdn.com/piaware-sd-card-3.8.1.img.zip ?
My current installation started from a vanilla RPi , maybe now another challenge to do it otherwise, and version 3.81. image is then on “buster” ?
@Nitr0 : I completely understand what you say , but now it’s running there for 2 years and I want to “do” something a new small challenge

I understand that! Always fun to dig in a learn a bit if you are willing.

An upgrade shouldn’t hurt you either on the other side of the coin…bluetooth and network stacks are still a wreck, but nothing that you’d more than likely come across for ADSB functionality. OBJ has done a bang-up job keeping FA efficient and updated as needed.

2 Likes

Yes, you are right.

Installing Piaware sd card image is easier than installing Raspbian image, then doing package install of dump1090-fa & piaware.

The sd card image has dump1090-fa and piaware pre installed, and is plug-n-play.

And yes, the current image 3.8.1 is Buster.

After writing the image to microSD card, and while microSD card/Card reader is still plugged into Desktop/Laptop, open the microSD card in file explorer (it is shown as drive with name “boot”). In the opened folder, do following:

(1) Create a new file named ssh or ssh.txt

(2) Click open the file named “piaware-config.txt” and do following:

(2a) Scroll down to bottom and below last line add this line:

feeder-id xxxxxxxxxxxxxxxxx
(Replace xxxxxxxxxxxxx by your actual key).

(2b) If you are using WIFi, then locate following two lines in the file piaware-config.txt and replace wifi ssid and password by your actual values.

wireless-ssid MyWifiNetwork <-----replace MyWifiNetwork with the name of your WiFi (aka the SSID of your local network)
wireless-password s3cr3t <-----replace s3cr3t with the password to your WiFi

Save file, slip out microSD card from laptop/desktop, slip into RPi and power up.

Hi,
first of all, ty for the tips and program links.
I have everything installed : Piaware, FR24, Planefinder, Radarbox24 and the very nice graphs by Wiedehopf.
I started from a configured Raspberry Pi, because I have a RTC clock installed and I use VNC viewer (mostly I use the Bitvise SSH client).

2 questions :

  1. On the “old” installation I had a “- -gain 43.9” in the dump 1090-fa file . Now I have used the parameter “rtlsdr-gain 43.9” in the piaware.conf . Has this the same effect and thererfore this antenna gain is used by all the flight reporting programs ?

  2. I don’t know if this belongs in the forum of piaware but when trying to install the mlat client for Radarbox I got :

pi@aludra:~ $ sudo apt-get install mlat-client -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package mlat-client

I presume that I have to address this in the Radar24 forum

That’s it
Patrick

For the MLAT issu @abcd567 has built a package so you do not need to compile it.
I’m sure he can share the info shortly.

@Patrius

(1) Your previous install was on vanilla Raspbian with package install of dump1090-fa and piaware. In that case gain setting is done in fe /etc/default/dump1090-fa

Your current install is piaware sd card image. Although it also has the file /etc/default/dump1090-fa, any manual changes in it are lost at reboot, as at reboot it is overwritten using data from file /boot/piaware-config.txt (or piaware cache). That is why one has to enter the gain value by command sudo piaware-config rtlsdr-gain xx followed by sudo systemctl restart piaware . These commands save the gain value in file /boot/piaware-config.txt as well as in piaware cache.

 

(2) After release of Buster, the mlat-client (which was built for Stretch) has been removed from Radarbox repository. It is also not available in Raspbian repository. Now one need to build it from source code.

July 02, 2019:
After Buster was released, I posted the method to built mlat-client from source-code in Radarbox24 forum.

https://forum.radarbox24.com/index.php?topic=101771.msg407051#msg407051

February 26, 2020:
Later I built 2 mlat-client packages from source code, one for Stretch and other for Buster, and uploaded to Github, and posted the commands to download and install these in Radarbox forum

https://forum.radarbox24.com/index.php?topic=101771.msg433591#msg433591

 

@Patrius

Additional info:
To enable and configure Radarbox24 MLAT, please see my following post in Radarbox24 Forums:

March 27, 2019:
https://forum.radarbox24.com/index.php?topic=101771.msg389571#msg389571

 

 

Thank you very much for your reaction and the links
Small correction : I didn’t use the the piaware sd card image , I installed raspian first and adapted it for the hardware : RTC clock
Then I downloaded and installed the Piaware software.

In this case (Raspbian + package install of piaware+dump1090-fa), you have to set gain in file /etc/default/dump1090-fa . Setting gain by command sudo piaware-config rtlsdr-gain xx will not be implemented.

Please see this Howto:

For Beginners - How to Set / Change Gain

 

I have the mlat-client working
@abcd567
thank you for the mlat-client package