I seem to have 'vanilla' version of Dump1090

Hey Guys,

I have just been browsing the web and I have noticed when I see other peoples version of Dump1090 viewer, it seems to be more ‘modern’ than mine.

For example some people have color coding on planes, and generally more information being displayed.

Do I need to update my viewer somehow? Note I did just update to this: Feeder Type: PiAware (SD Card) 3.5.0
here is a screenshot of my viewer:

  1. What URL are you visiting to see that?

  2. Try holding down Shift while clicking reload.

Just did this, it appears to be the same as my screenshot still. Is there something noticeably different in the newer versions than the one in my screenshot?

Cheers for your reply.

Per this thread try

Disclaimer: I’m not very good with this ADS-B web stuff.

Isn’t that why you snagged Mr. Jowett? :smiley: :smiley: :smiley:

Thanks for the tip, unfortunately that URL doesnt resolve, webpage not found… :confused:

Your statement Feeder Type: PiAware (SD Card) 3.5.0 , and the Vanilla map screenshot contradict each other.

With Piaware SD Card image 3.5.0, it is impossible to get Vanilla map.

The Vanilla map is only possible if you have “Piaware 3.5.0 add-on package”, installed on an OS running Vanilla dump1090.


I dont want to sound like I doubt your knowledge, but that IS exactly what i have running.

This morning I logged in and noticed a notification in the orange bar of the below screenshot (its not visible now) telling me there is a new version 3.5.0. I clicked update and restart, that update seems to have worked as per the screenshot shows…

I click the PiAware Skyview button and it takes me to the screenshot in my Original Post… I dont want to sound argumentative, but everything I have posted thus far is true.

Now it is clear that you upgraded from very old version 2.x.x. This version had a Vanilla like map.

Your browser’s cache is clinging to that map. Clear cache (Alt+Shift+Delete), then hard reload (Ctrl+F5) will purge the old map and most likely you will see SkyView map.

If clearing cache does not solve the problem, try upgrading dump1090-fa.

If all above fails, then go to the SURE and TROUBLE-FREE method: Format microSD Card, download Piaware 3.5.0 image (SD Card), and write the image to your microSD card.

when you upgraded you probably only upgraded PiAware.

when you clicked on send button to upgrade the option “upgrade and restart Pi-Aware” is a drop down box . click on that phrase and you will be able to select “upgrade piaware and dump1090” then click send and it should sort you out.

I tried the clear cache and reload page, this didn’t work, I tried a different web browser, this still didn’t work, then I saw theresjam post, and that was the problem, it seems when I updated I didn’t realise there was a second option to update dump1090, so I just now selected that option, then restarted the PI and it has come up with the newer looking viewer.

Thanks heaps guys.

Just for my own knowledge, how can I tell what version of 1090 I am running? Just so I know for future to tell if its the latest version?

Thanks again.

You missed what I have written after “clearing cache” step. Later theresjam singled it out and wrote it in an eleborate way, helping you catch the point.

How to Find Version Number:

Just for my own knowledge, how can I tell what version of 1090 I am running? Just so I know for future to tell if its the latest version?


I don’t have anything running dump1090 at the minute however.

You could try this from the command prompt on the Pi

./dump1090 --help

might work, i’m not sure if the flight aware dump1090 is named the same. type in dump1090 at the command prompt and hit tab if it isn’t just dump1090 that should autocomplete.

You can find the version number of any installed software by “dpkg -s” command

pi@piaware:~$ dpkg -s dump1090-fa | grep Version
Version: 3.5.0

pi@piaware:~$ dpkg -s piaware | grep Version
Version: 3.5.0

pi@piaware:~$ dpkg -s pfclient | grep Version
Version: 3.7.20

pi@piaware:~$ dpkg -s fr24feed | grep Version
Version: 1.0.18-9

pi@piaware:~$ dpkg -s mlat-client | grep Version
Version: 0.2.9

pi@piaware:~$ dpkg -s rbfeeder | grep Version
Version: 0.2.3-20170527202345


pi@piaware:~$ ./dump1090 --help
-bash: ./dump1090: No such file or directory


pi@piaware:~$ dpkg -l


pi@piaware:~$ dpkg -l |grep dump1090
ii  dump1090-fa                          3.5.0                            armhf        ADS-B Ground Station System for RTL-SDR

pi@raspberrypi:~ $  dpkg -l |grep dump1090
ii  dump1090-mutability              1.15~dev                         armhf        ADS-B Ground Station System for RTL-SDR

abc did you try pressing tab after typing in dump1090?

No, not earlier. I missed " hit tab" in your post.

Now after I see your new post, I tried it.
It did auto-complete.
Thanks theresjam for the very easy, and very useful tip.

double tap tab and it show you all the commands that begin with what you started typing.

I didn’t know about this for too long a time and now its hard to work without it saves so much time.