FlightAware Discussions

HOWTO: Airspy mini and Airspy R2: Piaware / dump1090-fa configuration


#81

On the FA stats page, which one is which?
I assumed the v3 is 83471 https://flightaware.com/adsb/stats/user/retman1222#stats-83471

and the mini is 89124 https://flightaware.com/adsb/stats/user/retman1222#stats-89124


#82

i have not measured. the spec is 0.6dB insertion loss and of course 3dB per side for the split. i should have measured but took the spec for granted (silly me!). my best results (in terms of aircraft and positions) for the V3 side have come with the addition of a 1dB attenuator between the splitter and the V3 and gain of -10. with the gain at -10 i run about 14%> -3dB but lowering the gain to 49.6 (at 49.6 i was at 5%>-3dB), or lower, always reduced both aircraft counts and positions.


#83

you are correct, the v3 is 83471 and the mini is 89124. the mini is showing fewer positions at 250+ miles at the moment but slightly more aircraft (less then 1%) and 1.8% more positions.


#84

Interesting, i looked just at the ADS-B positions and in that category the v3 is actually leading by 2000 positions.
Maybe the signal is just a little weak to use the full potential of the airspy mini.


#85

Could well be - as I said earlier in one of my posts I had to use a 2nd LNA with the splitter combo to achieve same results with mini - dropped gain to -18 when using 2nd LNA vice -21 when on it’s own with no splitter.


#86

well, the splitter will be gone soon and it will be fun to see what happens…also re wiedehopf post and higher ADS-B positions on the v3, it’s interesting that the total count on the mini is higher but ADS-B is lower???


#87

That’s how the stats look to me.
142 000 vs 140 000 that’s what the stats pages are telling me for the 22nd and ADS-B positions reported.

Btw did you see the fix i posted quite a few posts up to get the message rate graph working again?
Did that work for you? (HOWTO: Airspy mini and Airspy R2: Piaware / dump1090-fa configuration)


#88

when i attempt to change the sample rate i change from 12 to 20 and hit Ctrl-O and then it asks "file name to write: /etc/default/airspy_adsb…then what command to i use (see attached screen shot)


#89

You can just press enter / return.

Didn’t know nano did that, will have to add an “enter” into the guide :stuck_out_tongue_winking_eye:


#90

yes, i just found that too…when i hit enter all was well…thanks


#91

Interesting that the number of MLAT positions seems to be much better for the mini but the number of ADS-B positions is almost the same, maybe a little less.


#92

yes, i noticed this…but don’t understand. by the way, i have changed the sample rate to 20 now and will start comparing again at 3pm (so will get data from the 2pm to 3pm window for positions and aircraft


#93

I get the impression the v3 right now has a little more range. Positions on FA are only counted every 5 seconds or so for each aircraft.

So if the mini is receiving more position messages from most aircraft that does not necessarily help with ADS-B position.
But it increases the likelihood your receiver is selected for MLAT (the server somewhat randomly selects a message to do MLAT calculations on, and if you basically get every message from an MLAT aircraft then you have a better chance of being selected)

The range should improve once the splitter is gone, the airspy just needs more signal strength compared to the rtl dongles.


#94

so much for 20MHz sample rate. i have an RPI 3B (not the + version). piaware quit using MLAT because “pi running out of free CPU”). i went back to 12MHz and all is well


#95

message in log file was “clock unstable”


#96

I guess burgdorfer has less traffic than you, so it’s less problematic for him.

If the cpu is the problem:

Could also be that the graphs being generated are a problem as they load down the cpu for short times when they are calculated.
Also i guess you have the pi in a plastic case without too much ventilation which can also be a problem regarding heat.
From the photo i gather you have connected a monitor to the pi as well. That creates some extra heat and uses some system resources as well.

USB could also be the bottle neck which is harder to solve. (Reducing network usage reduces USB load, but i’m pretty sure there isn’t too much network usage on you pi.)

If you want to prod at this some more i would suggest trying some cooling with a small fan. But maybe it’s better to just use -m 12

Even with -m12 the reception seems good and i’m sure without the splitter it will be even better :slight_smile:


#97

hi wiedehopf, both RPI’s are in plastic cases but no tops and standoffs underneath. also a fan is blowing on both RPI’s and both dongles. so no heat issues. i am going to remove the splitter in about 1 hour…


#98

You can disable drawing the graphs with:
sudo mv /etc/cron.d/adsb-receiver-performance-graphs /root
And reenable them with:
sudo mv /root/adsb-receiver-performance-graphs /etc/cron.d/

You could also unplug the keyboard and the monitor and instead access the pi via putty.

Both might help with the issue. Hard to tell though.

Do you run other feeders? adsb_exchange has a cpu intensive MLAT client as well i believe.

Just for completeness: If you want to run the bandwith test using airspy_rx you would need to compile the following repository (https://github.com/airspy/airspyone_host)


#99

i feed fr24 but only on the ref side, so no extra bandwidth used on the mini side. after i get the mini up and stable with the splitter removed i’ll play some more by removing the graphs and turning off the monitor after i try changing the sample rate
again


#100

No hurry :slight_smile:
Just wanted to provide some ideas because you asked in the other thread.