FlightAware Discussions

How-to Get VRS-Like Coverage Map on RPi


#42

on a whim Im doing an update/upgrade and there is a lot of changes from the basline PIAware. so lets see with all the new jessie ARHMF files, new libraries etc, it will make a change enough to work.


#43

Nope, same o same o

must be something missing in the B+ that its looking for.


#44

@w7psk
@AhrBee

I tried on C.H.I.P / Jessie >>> FAILED

chip@chip:~$  lscpu
Architecture:          armv7l

chip@chip:~$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 8 (jessie)"

chip@chip:~$ sudo mkdir mm2

chip@chip:~$ sudo wget -O mm2/modesmixer2_rpi2-3_20170924.tgz "https://www.dropbox.com/s/fm8zclxxq0kg8u4/modesmixer2_rpi2-3_20170924.tgz?dl=1"    

chip@chip:~$ cd mm2
chip@chip:~/mm2$ sudo tar xvzf modesmixer2_rpi2-3_20170924.tgz
modesmixer2
modesmixer2.readme
LICENSE.MIT

chip@chip:~/mm2$ sudo ./modesmixer2 inConnect 127.0.0.1:30005 --web 8787 & disown
[1] 939

.
CHECKS:
1, chip@chip:~/mm2$ top >> modesmixer2 is NOT running
2. http://192.168.0.24:8787 >> Problem loding this page - Unable to connect

chip@chip:~$ sudo killall modesmixer2
modesmixer2: no process found

#45

Tried on Pi B+ / Piaware SD card img (Jessie) >>> FAILED

pi@piaware:~$ lscpu
Architecture:          armv6l

pi@piaware:~$ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"

pi@piaware:~$ sudo mkdir mm2

pi@piaware:~$ sudo wget -O mm2/modesmixer2_rpi2-3_20170924.tgz "https://www.dropbox.com/s/fm8zclxxq0kg8u4/modesmixer2_rpi2-3_20170924.tgz?dl=1"

pi@piaware:~$ cd mm2
pi@piaware:~/mm2$ sudo tar xvzf modesmixer2_rpi2-3_20170924.tgz
modesmixer2
modesmixer2.readme
LICENSE.MIT

pi@piaware:~/mm2$ sudo ./modesmixer2 inConnect 127.0.0.1:30005 --web 8787 & disown
[1] 935

CHECKS

1. top >> modesmixer2 is NOT running
2. http://192.168.0.20:8787 >> Problem loding this page - Unable to connect
3. pi@piaware:~/mm2$ sudo killall modesmixer2 >>> modesmixer2: no process found


#46

My 2 cents on the compatiiblity of the modesmixer2 image and Raspberry Pi models: the author states the build is

Raspberry Pi 2/3 (Broadcom SoC BCM2836/37, quad-core): modesmixer2_rpi2-3_20170506.tgz (Raspbian GNU/Linux 8.0 (jessie))

which tells me that it won’t work on the older Raspberry Pi boards that are single-core and/or not based on chipset listed. That, combined with a Java library issue (meaning: it generates the same ‘illegal instruction’ message) on armv6 CPUs, “limits” this app to run on the newest Raspberry Pi multi-cpu models, is how I read it. I would guess it might fail the same way on a Pi Zero…

The author also has 32-bit and 64-bit pre-built images for Intel-based CPUs. It is a stand-along image than can (SHOULD) be run from a non-root account, and seems to be light on resource consumption, especially for the work it is doing.

If all one has is a Windows computer around, then Virtual Radar Server is a good tool for doing similar work, as mentioned in several places.


#47

You are right, but the whole idea of this thread is to AVOID running Windows PC 24/7, and to generate the VRS-Like coverage plot within the Pi itself, which is already running 24/7.

.

.

Thanks for the information. That clarifies the cause of failure on Pi B / B+.

I have now checked the modesmixer download page, and found that there is a (deprecated) version available for Pi B+, but it also says for Wheezy. May be it can work on Jessie also. I will give it a try on my Pi B+ With Piaware SD card image.

.

I have uploaded it to my dropbox if someone wants to use wget command

sudo mkdir mm2

sudo wget -O mm2/modesmixer2_rpi1_20170506.tgz "https://www.dropbox.com/s/hpt66mrk81w9fjo/modesmixer2_rpi1_20170506.tgz?dl=1"

cd mm2

sudo tar vxzf modesmixer2_rpi1_20170506.tgz
.


#48

Am I missing something here? Why not run VRS on an RPI?

I set one up last week and it seems to run fine. It is pulling data from a radarcape and three Piawares running different Antennas and receivers (ProSitck Plus, Mode S Beast,RTL-SDR v3 and an airspy). I can see how limited my range is for UAT 978.

I know the local database is going to reduce the life of my SD card. I would probably be better off setting up a database on my NAS server.


#49

Thanks for the info.
How to do this? Any guide/tutorial?


#50

Success Pi B+, Piaware SD card img (Jessie)

using modesmixer2_rpi1_20170506.tgz

sudo mkdir mm2

sudo wget -O mm2/modesmixer2_rpi1_20170506.tgz "https://www.dropbox.com/s/hpt66mrk81w9fjo/modesmixer2_rpi1_20170506.tgz?dl=1"

cd mm2

sudo tar vxzf modesmixer2_rpi1_20170506.tgz
modesmixer2_rpi1
modesmixer2.readme

sudo nano mm2.sh

#Copy-pasted following code
/home/pi/mm2/./modesmixer2_rpi1 --inConnectId 127.0.0.1:30005:ADSB  --inConnectId 127.0.0.1:30106:MLAT --web 8787 --location xx.xxxx:yy.yyyy   

#Saved file

#Made file executeable
sudo chmod +x mm2.sh

#Run file
sudo ./mm2.sh

#51

DING DING DING

we have a winner … now to play with it.

only thing I do not get right now is MAP and bandwidth. Not sure why not
On the map my planes are all piled up on each other in the top left corner.

also Disown doesn’t seem to work, Id like to use my terminal to play with Gain to see if message count changes. I can always get another terminal up but … just so you know.

Any ideas why I have no map display?


#52

Just add --db ~/mm2/basestation.sqb to the command line. Adjust for the location of your sqb file. And make sure there are two - before the db - not always easy to see those in scripts.

And there has been much discussion of these programs over the last 4.5 years here:
https://radarspotting.com/forum/index.php?board=56.0

This thread in particular where the author pops in from time to time may answer your questions:
https://radarspotting.com/forum/index.php/topic,2978.0.html


#53

.

Try another browser. I think this is browser specific.

I faced same problem with Firefox.
I was in hurry to go, so did not try another browser. Will try when back home.


#54

@idh
Thanks for info about basestation.sqb, and thanks for the link to radarspotting forum


#55

I had this problem using Firefox but just refreshed the screen and it was fine - it happens sometimes but not all the time


#56

VRS on Linux: http://www.virtualradarserver.co.uk/Mono.aspx
It has the option to be setup from another computer so you don’t need a screen on the RPi.

And the forum includes a section for Linux: https://forum.virtualradarserver.co.uk/viewforum.php?f=7&sid=d41bcf82c0202597cf39399d0918479f

I’ve only ever installed on Linux on a PC but it clearly works on a Rpi as well.


#57

“Clear the cache” is the usual answer given for this. Specific instructions depend on your browser.


#58

@jonhawkes2030

Ah, running through mono!

I never tried mono, but heard running Windows software through it is heavy for Pi.

Using Windows software through mono on Linux on desktop/laptop is OK.


#59

Can I suggest that you use port 30105 data for MLAT? That is Beast format which is recommended for ModesMixer2.

And ModesMixer2 can also do conversions between data formats.

For info this is my command line:
./modesmixer2 --web 8086 --location 52.xx:-0.yy --inConnect 192.168.0.177:30105 --inConnect 192.168.0.177:30005 --outServer beast:30009 --outServer msg:30003 --globes 31008:table2:EGNX --outServer sbs10001:10001 --db /home/BaseStation.sqb

Sending out combined ADSB and MLAT as Beast data on port 30009, Kinetic SBS format on port 10001 which can be read by BaseStation software, message data on port 30003 (I think I used this for FlightAirMap but maybe it accepts other formats now) and finally data on port 31008 for Globe-S display software (which seems to have vanished from the internet :frowning: )

This number of options may cause a RPi to crawl so be selective - I’m running it on a server and feed to a PC during the day so it’s not an issue.


#60

Im on my laptop and it works fine. Both browswers are Chrome. Ill reload and clear
the other next time Im in the room.


#61

It seems to run OK on and RPI3 also running xastir.
I am using it to monitor 5 devices so I think it has enough grunt.

My response was delayed because I was trying to work out how to run it at startup on the desktop. I just had to add a start script to /etc/rc.local with a 5 second delay and the display variable had to be set.