FlightAware Discussions

How-to Get VRS-Like Coverage Map on RPi

Simply get a key from google. It’s still available as “developer”. I assume as long as you’re not generating too much calls on it, they will not contact you.

I have mine since years without giving any payment details to them.
And my map is not watermarked

Many thanks to @abcd567 for providing tips how to run mm2 and where to get extra files. One more question - after getting BaseStation.sqb from https://data.flightairmap.com/ and running mm2 for about 24hrs, the database has now 308MB - and it’s growing.
How do you handle the growth? What’s your file size? Should I switch to RO mode, given that pi sd card has somewhat limited life - especially with writes?

1 Like

Recent sd-cards don’t really have that problem.

2 Likes

Unfortunately it doesn’t work that way anymore. I tried to find developer links and it wants to to fill out all information including credit card. Be happy you got one before, and I wouldn’t be surprised if they come to you soon and want one.

1 Like

I have one from before they started asking credit card and other personal info, and it worked for some period, but ultimately it has stopped working.

1 Like

I hope that the developer of MM2 (serge) will update to other than Google maps. I figured Google maps have become so popular, Google wants their fair share of the money.

It is OK if Google wants to earn profit, and dont want to offer free map like before. However Google do not force anybody not to use map of other providers which are still doing it free.

I dont understand why author of modesmixer/modesdeco2 is clinging to Google map. Look what others have done:

  • VRS has option of Google or Leaflet
  • Planefinder local web page has option of Google or OpenStreet.
  • dump1090-fa/dump1090-mutab have totally switched to OpenStreet.
1 Like

I have sent the programs author’s a PM and posted on Radarspotting.com in their forums but no answers. This was over a month ago.

For me it is still working. Of course they are now asking for payment methods to be given on account/key creation

Not sure if it was a coincidence, but as long as Google does not see your setup on the public internet, you are fine.

Mine worked long after the API key was required, until I opened the port for some testing, and acessed my RPi from the public internet. That was it, it never worked again without the watermarks.

ModeSMixer2 installation script for RPi 2/3, Raspbian Stretch and Raspbian Buster

Copy-paste following command in SSH console and press Enter key. The script will install and configure modesmixer2.

sudo bash -c "$(wget -O - https://raw.githubusercontent.com/abcd567a/mm2/master/install-mm2.sh)"

For details, visit this page:

https://github.com/abcd567a/mm2/blob/master/README.md

1 Like

Changelog

The latest update to automated installation script at github has following changes:

(1) Startup at boot is no more by rc.local. it is by systemd service.

Now following commands are available

sudo systemctl status mm2
sudo systemctl restart mm2
sudo systemctl stop mm2

(2) Location of install folder changed from /home/pi/mm2 to /usr/share/mm2

(3) The startup command and config are split in two files.
The startup file mm2.sh reads all "--argument value" pairs from config file mm2.conf, combines (concates) these, and starts modesmixer2 with this combined (concated) string.

1 Like

such genius, ran it and fired right up first time. Google map is annoying as hell, but we shall see if it locks up.

Hopefully someday they change it.

1 Like

Question: How does the installation script installs the ModeSMixer2?

Answer: The installation script does following

(1) Creates a folder /usr/share/mm2.

(2) Downloads file modesmixer2_rpi2-3_deb9_20190223.tgz from Google Drive, and saves it in folder /usr/share/mm2. (Tested, this distro works both on Stretch and Buster)

(3) Unzips downloaded file in folder /usr/share/mm2.

(4) Creates config file /usr/share/mm2/mm2.conf .
(It can be edited by user at any time to add, remove, or change arguments).

The config file mm2.conf:

--inConnectId 127.0.0.1:30005:ADSB
--inConnectId 127.0.0.1:30105:MLAT
--web 8787
--location xx.xxxx:yy.yyyy

.
(5) Creates a startup script file /usr/share/mm2/mm2.sh, and makes it executable.
The startup file is started by systemd mm2.service. The startup file mm2.sh does two things:
(a) Reads arguments from config file mm2.conf.
(b) issues a command to start modesmixer2 using " --arguments values" pairs read from file mm2.conf.

The startup file mm2.sh:

#!/bin/sh 
CONFIG="" 
while read -r line; do CONFIG="${CONFIG} $line"; done < /usr/share/mm2/mm2.conf 
/usr/share/mm2/modesmixer2 ${CONFIG}

.
(6) Creates a service file /lib/systemd/system/mm2.service. The service file starts modesmixer2 at boot. It can also used by user to restart, stop, and check status during normal running.

The service file mm2.service:

# modesmixer2 service for systemd 

[Unit] 
Description=ModeSMixer2 
Wants=network.target 
After=network.target 

[Service] 
RuntimeDirectory=modesmixer2 
RuntimeDirectoryMode=0755 
ExecStart=/bin/bash /usr/share/mm2/mm2.sh 
SyslogIdentifier=modesmixer2 
Type=simple 
Restart=on-failure 
RestartSec=30 
RestartPreventExitStatus=64 
Nice=-5 

[Install] 
WantedBy=default.target

.
(7) Enables mm2.service by following command
sudo systemctl enable mm2

(8 ) Starts modesmixer2 by systemd start command
sudo systemctl start mm2

(9) Announces completion, and advises to add latitude & longitude to file /usr/share/mm2/mm2.conf

.

Is anyone having problems with ModeSMixer2? I have it installed on two RPis and it has been working fine, however, I have just checked it and although I can open the web page, there is no data being displayed (Tables/Map etc), although I do know FA-1090 is working fine.

Thanks

@NigelRichardson

Yes, I have same problem. In Firefox, the Map shows a blank page, but charts tab and flights tab work ok.

I am not sure but vaguely remember map shows on Google Chrome.

Thanks for the reply. I’m getting nothing and using the same browser as I was last week when it was all working fine. Very puzzling.

I’ve now resolved this issue. A browser update had changed some of the privacy settings. I’ve edited these and I’m now seeing full data again.

Thanks

1 Like

Can you please give more details so that I can also fix my browser.

I’m using UR as a browser. Under Settings you can control the privacy levels (i.e. blocking cookies, ads etc.). The default is medium which stops MM2. I have reset the privacy levels for MM2 to low and this has cured the display problem.

I hope this helps.

1 Like