FlightAware Discussions

How to get access to 192.168.8.108:8080

Hello,

I have started uploading ADSB data lately. I see that I should be able to visit http://192.168.8.108:8080/

Unfortunately, the website is not responding. Which of the files should I edit? Or maybe what configuration should I share, so you could advise me something?

I’m a beginner, so I see that I have installed dump978 which wasn’t needed. I can see it here: http://192.168.8.108/skyaware978/ The map is empty, because I live in Europe. Is there a way of configuration so that dump1090 would be available in this position instead of dump978. I use raspberry pi with Flightradar image. The IP given above is static. If I forgot to write about something, please answer and I will send it.

Best regards

Instead of going directly to port 8080, try http://192.168.8.108/dump1090-fa. Sometimes it doesn’t seem to make up the port 8080 link. I don’t know why, but I am sure that others here can explain.

1 Like

Thanks for the answer. The link works, indeed: http://192.168.8.108/dump1090/gmap.html

I have noticed that the websites like: Flightradar, Planefinder offer their graphic interfaces. I thought that it would be possible to run GUI here as well. I would be grateful, if anyone told me how to make it happen.

That has an obsolete dump1090. I’d suggest upgrading to something more recent.

3 Likes

That’s outdated indeed, i’d recommend either going to a piaware image or starting from Raspbian Buster:
https://github.com/wiedehopf/adsb-wiki/wiki/Raspbian-Lite:-ADS-B-receiver

If that’s not an option in the short term, the automatic install scripts on the above page for both readsb and dump1090-fa should work fine if the image isn’t super old.

1 Like

Indeed, but FR24 programmers seem to be happy with it.

  1. Their Pi24 image has dump1090-mutability (D EB_VER) pre-installed.

  2. If user has Raspbian image, and performs a package install of fr24feed, the fr24feed on first run installs dump1090-mutability (D EB_VER), if the user is not careful to change default setting from receiver=dvbt to reciever=beast-tcp.

  3. In both the above cases, the dump1090-mutability runs in a walled garden. During dump1090-mutability’s installation, the install script changes dump1090-mutability’s default configuration to start at boot from YES to NO. Now it is started, stopped, restarted by fr24feed, which starts it passing following argumets read from fr24feed’s configuration file /etc/fr24feed.ini:

--net --net-http-port xxxx --gain -10 --lat xx.xxx --lon yy.yyy

  1. If you run command lsb_release -sc on Pi24 image, instead of getting stretch or buster, one gets fr24-stretch and fr24-buster

 

1 Like

Chemitox,
In your piaware-config.txt file, did you remove the # from the 978 UAT lines at the bottom?
I did that after mine was working with 1090, and it killed the 1090 sigs and only showed the 978 returns.

What files have you changed?
Perhaps if you pulled down a new fresh image of https://flightaware.com/adsb/piaware/build and changed ONLY the IP addy to suit your needs and try it, perhaps it will work.

I’d suggest doing it to a diff SD card so as to preserve your info as it stands now, just to see if things will work with minimum config changes, then if it DOES work, you can change a line or two in the new config setup to have your feeder ID reflected in it that you currently have.

What hardware are you using?
My setup is a Rpi that was laying in my desk, a USB power supply, an RTL-SDR dongle laying in my desk, and an old trucker cellphone antenna that I modded the antenna connector to fit the SDR, and I changed the IP addy’s and the password and it’s running top shelf (also added the ssh file {from the advanced config page] so I could remotely access my system) straight off the web.

Once my feeder was live, I came on here and set up my acct and entered my location coords and things are working as they should (far as I can tell with over 3 million position reports in the last month)

I’d be curious what your piaware-config.txt file looks like (it’s in the BOOT folder)

Gary
K4GHL

1 Like

I am a beginner. Running Flightradar, ADSBExchange, Planefinder, Radarbox, has taken a while, so I would not like to start from the scratch. Everything else work fine, and I would only like to get into flightaware GUI. I’m sending the configs below, about which other users are usually asked.

pi@raspberrypi:~ $ apt-cache policy dump1090-mutability

dump1090-mutability:
Installed: 1.15~20180310.4a16df3+dfsg-6
Candidate: 1.15~20180310.4a16df3+dfsg-6
Version table:
*** 1.15~20180310.4a16df3+dfsg-6 500
500 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages
100 /var/lib/dpkg/status
pi@raspberrypi:~ $ apt-cache policy dump1090-fa

dump1090-fa:
Installed: (none)
Candidate: 4.0
Version table:
4.0 500
500 http://flightaware.com/adsb/piaware/files/packages buster/piaware armhf Packages

pi@raspberrypi:~ $ sudo systemctl status dump1090-mutability

dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
Loaded: loaded (/etc/init.d/dump1090-mutability; generated)
Active: active (exited) since Fri 2020-11-27 09:49:03 GMT; 3 days ago
Docs: man:systemd-sysv-generator(8)
Process: 27886 ExecStart=/etc/init.d/dump1090-mutability start (code=exited, s

Warning: Journal has been rotated since unit was started. Log output is incomple
lines 1-7/7 (END)

sudo apt-get purge dump978-fa  
sudo apt-get purge skyaware978   
sudo apt-get purge skyview978
sudo reboot
1 Like

The SkyAware map is part of dump1090-fa. You will need to replace dump1090-mutability with dump1090-fa. You can continue to feed the other feeders with this, the data format it produces is the same.

dump1090-mutability is no longer maintained upstream (I know this because I was the maintainer). If you need help with the version that flightradar is apparently using, you’d need to contact them directly for support.

1 Like

1 - Open file /etc/fr24feed.ini for editing

sudo nano /etc/fr24feed.ini   

You will see this:

receiver="dvbt"
fr24key="xxxxxxxxxxxxxxxx"
path="/usr/lib/fr24/dump1090"
bs="yes"
raw="yes"
logmode="1"
logpath="/var/log/fr24feed"
mlat="yes"
mlat-without-gps="yes"

2- Make following changes:
Change receiver="dvbt" to receiver="beast-tcp"
Change path="/usr/lib/fr24/dump1090" to host="127.0.0.1:30005"
Change bs=“yes” to bs=“no”
Change raw=“yes” to raw=“no”

The file will become like this:

receiver="beast-tcp"
fr24key="xxxxxxxxxxxxxxxx"
host="127.0.0.1:30005"
bs="no"
raw="no"
logmode="1"
logpath="/var/log/fr24feed"
mlat="yes"
mlat-without-gps="yes"

 

3 - Save file (Ctrl+O) and Close file (Ctrl+x)

 

4 - Restart fr24feed

sudo systemctl restart fr24feed  

 

5 - Purge dump1090-mutability

sudo apt-get purge dump1090-mutability

 

6 - Install dump1090-fa

wget https://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_4.0_all.deb
sudo dpkg -i piaware-repository_4.0_all.deb
sudo apt-get update
sudo apt-get install dump1090-fa

 

7 - REBOOT Pi

sudo reboot 

 

8 - Go to following address in your browser to see the SkyView Map for 1090 :slight_smile:

http://192.168.8.108/dump1090-fa/

 

3 Likes

It all seems so easy, but are you sure that after the update all of the current services that I have (ADSBExchange, Radarbox, Flightradar, Planefinder, etc.) will still work?

If you don’t mess it up they will continue to work.
Well and if abcd567 hadn’t messed up with the instructions, leaving bs/raw enabled on fr24feed will create a TCP port conflict for port 30003 i believe.

Because people often make mistakes … i’ve scripted the whole deal … it works quite reliably:
dump1090-fa plus some extra stuff: https://github.com/wiedehopf/adsb-scripts/wiki/Bundle-install-for-dump1090fa
just dump1090-fa: https://github.com/wiedehopf/adsb-scripts/wiki/Automatic-installation-for-dump1090-fa

1 Like

No, it does not. Also all other feeders (planefinder, Adsbx, Radarbox, Flightradar24 etc) use port 30005, and there is no conflict on that port.

Yes, everything will still work as before.

1 Like

Default for dump1090-fa:

--net-sbs-port 30003

fr24feed.ini:

bs="yes"

Both of those will use port 30003 leading to a conflict.

Dec 04 11:29:53 pi readsb[17046]: Error opening the listening port 30003 (Basestation TCP output): bind: Address already in use

It’s still a conflict that should be avoided by disabling the fr24feed basestation output … as you don’t need it anyhow.
That conflict is a bit elusive as it requires fr24feed to start before dump1090-fa/readsb. (fr24feed doesn’t even give an error when it can’t use the port that’s why most of the time people get away with it as it usually starts after dump1090-fa but that doesn’t change the fact that it’s a misconfiguration)

The fr24feed raw output on 30334 is just useless when you have a properly programmed application providing you with data outputs. (fr24feed will crash if more than 2 clients or so connect to that port … or it did at some point)

1 Like

@wiedehopf:

When dump1090-mutability works ok with these settings, why dump1090-fa cant work and cause conflict? The default ports for both versions are identical.

I have posted the method after testing dump1090-fa with fr24feed having settings bs=yes and raw=yes and it works ok. Please see screenshots below.

You can try these settings yourself to confirm

1 Like

Please read again that it will only be apparent when you start dump1090-fa after fr24feed and that usually doesn’t happen.

Port 30003 and 30334 (and maybe 30002 … not sure) aren’t provided by dump1090-mutability but rather by fr24feed itself.

Also i just tried and showed you the error that can occur if fr24feed is started before dump1090-fa.
So … as i already tried … no need to do it again rather i’d recommend that you try stopping both services, start fr24feed then start dump1090-fa.

1 Like

If what you say is correct, then following simple addition in modifications to file fr24feed.ini will solve it

Change bs=yes to bs=no
Change raw=yes to raw=no

I will now add these two lines to the manual method I have posted

1 Like

Mine settings look slightly different, should I change them to exactly how you showed it? If not, then which setting should I leave as they are now?

bs=yes
raw=yes
mlat=“yes”
mlat-without-gps=“yes”
logmode=“2”
receiver=“dvbt”
procargs="–net --net-beast --net-bo-port 30005 --gain -10"
fr24key=xxxxxxxxxxx
receiver=dvbt