FlightAware Discussions

How to check bias tee activation

After upgrading to version 5 I am having problems with my reception. I checked my gain, it has not changed.
I have an uptronic filter and powered it with my RTL-SDR dingle.
I know there is a command to check if my filter is powered my my dongle, but i cannot find it in my notes.

Would someone be so kind and help me our so I can check if it is working correctly , co I can go to a next step in optimising ( again) my setup?

Thanks

1 Like

I’d suspect for some reason your biastee isn’t being activated.
Use this:
RTL Bias Tee · wiedehopf/adsb-wiki Wiki · GitHub

1 Like

Thank you for thew link.
I used your script but there are many red lines. A lot od warnings is that “normal”?
It is probably to much to copy and paste it in here.

Not sure about that specific filter, but my RTL-SDR Blog ADSB Filter has a Green Power LED on the Circuit Board. I had to drill a hole in the case directly above it so that I can see it easily but now I can tell at a glance whether it is powered or not. Same deal with the RTL-SDR Wideband LNA that I run on my Airband setup. Now I just need to pop my head up the loft hatch and if I see 2 green lights I’m good :slight_smile:

@NeoDuder The Uptronic doesn’t have green lights

Can you borrow a DVM? (Digital Volt Meter)

Unfortunately not.
If I remember well there is a command that shows at the end of the text something like bias tee on

pastebin.com

Thank you, as always:)

https://pastebin.com/embed_js/eTApQXC5

That looks pretty normal.
Let’s check the logs then.

sudo systemctl restart dump1090-fa
sudo journalctl -u dump1090-fa | tail -n30

Ok,
here the journal:
https://pastebin.com/embed_js/CMg7w972

cat /etc/systemd/system/dump1090-fa.service.d/bias-t.conf

Did you run both scripts on that page?
Seems it isn’t working for some reason.

This should manually enable the bias-tee if dump1090-fa is stopped.

sudo systemctl stop dump1090-fa
sudo /usr/local/share/adsb-wiki/biastee/rtl_biast/build/src/rtl_biast -b 1
sudo systemctl restart dump1090-fa

Similar output is what i would expect in the system log.

Here the outcome

I ran the install script., so only the first one you mentioned, so the enable script

Yeah run the thing again but with stopping dump1090-fa first.

sudo systemctl stop dump1090-fa
sudo /usr/local/share/adsb-wiki/biastee/rtl_biast/build/src/rtl_biast -b 1
sudo systemctl restart dump1090-fa

I have no clue what is wrong with your setup.

cat /etc/os-release 
ls /etc/systemd/system/dump1090-fa.service.d
ls /etc/systemd/system/dump1090-fa.service

You have a minor error:

Mar 15 18:06:04 raspberrypi dump1090-fa[22901]: /usr/share/dump1090-fa/start-dump1090-fa: 1: /etc/default/dump1090-fa: «#: not found

So you have some extra character in /etc/default/dump1090-fa … but i don’t think that is the issue. Wouldn’t hurt to fix it.

As you see in the log it’s using a gain of 37.

Did re run it

pi@raspberrypi:~ $ sudo systemctl stop dump1090-fa

pi@raspberrypi:~ $ sudo /usr/local/share/adsb-wiki/biastee/rtl_biast/build/src/rtl_biast -b 1
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
Found Rafael Micro R820T tuner
pi@raspberrypi:~ $ sudo systemctl restart dump1090-fa

Here the outcome of the other three commands

For the last command there is an error

    pi@raspberrypi:~ $ cat /etc/os-release 

PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL=“http://www.raspbian.org/
SUPPORT_URL=“RaspbianForums - Raspbian
BUG_REPORT_URL=“RaspbianBugs - Raspbian
pi@raspberrypi:~ ls /etc/systemd/system/dump1090-fa.service.d bias-t.conf pi@raspberrypi:~ ls /etc/systemd/system/dump1090-fa.service
ls: cannot access ‘/etc/systemd/system/dump1090-fa.service’: No such file or directory
pi@raspberrypi:~ $

Changed the gain back to 49.6 as it was before the update

Huh?
The 5.0 update certainly didn’t reduce the gain to 37 …

No you are right, but checked if a change in gain would make a difference.
In an other post the fa staff said the messages could be different because of the update

Can you show the graphs to illustrate … i get the impression people just imagine it …

thank you. Will port them tomorrow.

Good night

I have re-imaged, so no past history left to compare with and worry about… peace of mind :wink:

1 Like