FlightAware Discussions

GUI Login Screen fails repeatedly and consistently


#1

Hi, all

I seem to be cursed with a problem that has been addressed a number of times on these discussion boards. My GUI login window accepts the default pi/flightaware login/password combination, then goes dark for a few seconds and repaints the same login screen, but without the login/password entries that I have just made. I have seen numerous solutions suggested and tried on these boards, and many of them have worked, but for only others and never for me. :frowning:

I know that I’m entering the correct login information, because whenever I vary the input (as a test), the system informs me “Incorrect password, please try again”.

I can log into the console using that same default login/password conversation, and can move about in console mode quite freely. I have examined both the presence and content of various files (as suggested by this and other boards) and find nothing amiss. Permissions all seem to be in order.

My system is about as vanilla as it can be. I started out with everything bright and shiny and right out of the box about a month ago. I was very happy when everything downloaded correctly, and installed properly…until I could not log into the the GUI. (And I need to do this, in part because I need to use VNC, and the FlightAware apparatus will be installed near my friend’s antenna tower. BTW, I get the same login blues when accessing via VNC. Both my friend and I need the GUI.)

In my search for answers, I have even gone beyond the flightaware community to the generic Raspbian and Raspberry Pi boards. I have even found very similar problems and advices the Ubuntu sources. I have found a lot of advice and tried everything that looked even remotely promising, but nothing helps. Because I’ve seen this exact same complaint and proposed answers on both FlightAware and Ubuntu boards, I’m fairly sure it’s a Linux problem and not a FlightAware problem.

I am running FlightAware 3.6.3 on a Raspberry Pi III+, with Raspbian OS downloaded from FlightAware about a month ago. The memory card has a capacity of 32 Gb (!), of which 27 Gb is still available. I did set up an option, very early on, to start the GUI upon boot. It worked right away. I don’t remember what I did to enable that behavior or where I saw the tutorial about how to do it, or I already would have tried turning it off and rebooting/starting it manually.

I’m not a Unix/Linux/Raspbian guru, by any means. But I’ve made my living writing C on MS-DOS, then Windows machines for forty+ years, so I do know my way around. I did some limited work in the mid-80’s on Xenix (Unix from Microsoft, of all things!), so I’m not entirely flummoxed by the OS.

I’ve tried the following, to no avail:

  • chown .Xauthority file
  • reconfigure lightdb system
  • reinstall the lightdb system.
  • numerous other attempts, followed by
  • dozens and dozens of reboots

My point in posting this generic complaint, containing the proviso that I’ve tried everything I could find, is that this complaint appears to widely in the literature that it must be commonplace. And it has been happening for years. So it seems to me that there has to be a great deal of community experience in dealing with this problem, even to the extent of someone having put together a checklist/cheatsheet of everything to try when the “I can’t log in via the GUI” problem arises.

Is that magic bullet floating around the interwebs somewhere, and I’ve just not recognized it?


#2

Have you checked the logs?

There should be at least something there.
Also try changing the default password there may be a policy in place that you need to change the default password.


#3

Thanks for responding, wiedehopf.

I’m not at all sure how to do either one of those. (I’m sure that I could if I knew where to look and what tools to use.)

Which log(s) would you recommend looking at first; and what should I be looking for.

With respect to changing the password, I guess I do know how (there is a pwd command, right?). But again, I am able to log in (using the default password) in the console. It’s only in the GUI that it’s being ignored in.

Hope that makes sense.


#4

…just guessing here… have you got the memory split set large enough… on the command line, raspi-config and it might be in advanced options. Most of us use SSH, not VNC, to use command line, so I don’t have a lot of experience here. Graphics memory default for raspian is something like 64mb, but I set it down to 16 because I don’t use GUI.

I offer this as a joke… “real men use the command line”! :slight_smile:


#5

Nevertheless use passwd to change the password just to check if it’s the problem.

The logs you may want to look at:

cat /var/log/lightdm/lightdm.log
cat /home/pi/.xsessionerrors

#6

I need to use the GUI because I’m giving FA access to the guy whose tower access is being given to me gratis. Pretty cheap rent, I’d say.

Back in the old days, we never even had GUIs. The saying then was “Real men program right down to the metal”, and we did…using Assembler and Machine Code.

For your enjoyment, here is a set of images, with a bonus xkcd! https://www.google.com/search?q=real+men+use+the+command+line&client=firefox-b-1-ab&tbm=isch&tbo=u&source=univ&sa=X&ved=2ahUKEwjlrcXw3qTeAhWD2YMKHaasDroQsAR6BAgFEAE&biw=1320&bih=728


#7

Haha, love it. …but bare metal and assembler… you must be older than I!

What do you mean by “giving FA access” to your friend with the tower? If you simply want him to be able to see the Skyview screen, then you don’t need GUI access to the Pi. Giving someone access to your Pi also gives them access to whatever files are shared by other computers on the same LAN potentially. A better approach would be to make just the Skyview screen accessible from the internet. There are a couple of ways to do that. The simplest is to port forward a random port on your router to whatever port skyview is using, typically 80. This allows anyone who knows your external IP address to access skyview, but that isn’t any more of an exposure than allowing internet access to a GUI login screen. Some might say it is safer. Externally, one would access your skyview with http://your-ip-address:random-port-you-picked-above.


#8

The whole shebang is going onto his tower (he’s a ham) and my antenna will be approximately 150 feet in elevation higher than the top of my chimney. Also, line of sight from my antenna will be to the horizon in every direction. The PIAware and PI have been mounted in a weatherproof container and tested. The only holes in the bulkhead that it needs are ports for the antenna and 5V power source. We WiFi into his router/network and get to the interwebs that way. We have it set up headless, but we also have a logitech keyboard/mouse dongle, as well. I will need to get (remote, non-physical) access to the Pi once it’s semi-permanently attached to his tower.

We might use your suggestions. (But if we do, we might knock on your door for more advice…)

Yes, I am older than everybody on this board, I’m sure. I have been hacking around with computers since 1968, and even then I was so old you couldn’t trust me (at least if you believed Abby Hoffman!)


#9

pwd is Print Working Directory. Executing it tells you which directory you’re currently in.

passwd is the command that changes a password.

As with most commands/executables, appending --help to the command will display
a brief version of help. e.g. passwd --help

man passwd gets you detailed help.

That was the year I got my first ham ticket. Things have sure changed since then, eh?


#10

I’ll say they have. As an old ham once told me (I didn’t get my ticket until early 90’s, and a tech plus at that): “Real radios glow in the dark”. (Before xistors, or course.)

The guy with the tower is my Elmer. This project is sorta my payback to him.

He just showed me his new SDR station. It is like a supercomputer that happens to also be able to send and receive. The features are astounding, even to me (a supposed computer nerd, but ham noob.)


#11

xlr99:

Didn’t mean to ignore you, and a sincere ‘my bad’ about passwd and pwd. I really did know the difference, but somehow fat-fingered it. (Somehow? Actually, I should have paid more attention.)


#12

Not meaning to pry but could you just post the two logfiles :slight_smile:
And maybe report if changing the password helped?

You just login on the console and then type

passwd

It will ask the old password and then ask for a new one twice.

You can just paste the commands from my previous post and it will show the logs. But as cat just outputs the file onto the console you will need to scroll with SHIFT-PAGEUP and PAGEDOWN.
With less you can actually scroll natively but it will start to show the file at the beginning and often the interesting things are at the end.

less /var/log/lightdm/lightdm.log
less /home/pi/.xsessionerrors

The gui won’t help you much anyways in updating the device and checking stuff but i’m happy to help you get it up and running.

You might want to check out FileZilla and make it work via SCP so you can transfer files to a computer you are more comfortable to work on.
This way you could for example get to those logfiles too.
I won’t explain that part i’m sure you can google “Raspberry Pi Filezilla” :slight_smile:

Be aware though that creating text files on a windows computer and transferring them to linux is a bad idea as windows uses other carriage returns and the files won’t work.
But just for checking log files it might be more comfortable to view them.


#13

I’m pretty familiar with File Zilla, having used it widely on several projects in recent years.

the password change operated exactly as advertised. That is, the new password iis in effect, and it words as a password, just like the previous one did. But it does not modify the deficient gui behavior at sighnin. No jon.

Similarly, texts to cat the two suggested fires reported in “No such file or directory”

Wow, this can sure get exhausting, cant it?


#14

Which image did you put on the sd-card if i may ask and how did you activate the gui or was it already on?

You ain’t seen nothing yet.

Get putty running then you can just copy paste the console that will be easier.
(for example you could copy the command complete with the error that came up and i would easily see any potential mistakes. not saying you made any but you know how it is :wink: )

You are not using VNC to look at the planes are you? (Just making sure. I still don’t really know what you intend to do with the gui)


#15

Stand by. I’ll get putty running so that you can see exactly what I tried and what the response was/is. I know that I fat-fingered at least three words in this most recent reply, and that can get annoying to readers.

How do I get it running, BTW?


#16

Right now I’m not even running VNC. Our intention is to use it to look at the maps of the pretty airplanes moving around over our heads. Beyond that I really have no idea what to use it for. I simply thought at the outset that it would be a nice tool to have running that could give my friend and I a holistic view of the local air traffic. I assumed that it would allow me to drill down to look at anything I needed to look at after installation.

Currently, the pi/flightaware dongle has been removed from the tower and is sitting on my desk within arm’s reach. I am doing all interactions with it via logitech keyboard/mouse dongle and hardwired HDMI cable from pi to a spare, dedicated monitor.

(I am beginning to think that there might be better means available for remote viewing/control of the pi/FA module, but I’m not so sure of the selection and configuration. What seems to be fixed right now is that we mount the weatherproof module (containing all the electronics) on his tower and that it communicates with the larger world (including myself) by the pi joining his WiFi/router. Perhaps I’m designing too much complexity into this system and there is a simpler (i.e. ‘better’) way to skin this cat. We are not at all married to the idea of a VNC/GUI interface; it just seemed like the simplest proposition, and thus the simplest to install and maintain. If there is a ‘better’ way, I’m all ears.


#17

The map is reachable via http so directly in the browser. You don’t need VNC for that. As someone mentioned for you to access that map over the internet your friend will need to forward a port to the pi. (Such a port forward would have otherwise be needed vor VNC anyway)

Anything you will want to control will be shell commands anyway. (updates mostly, tweaking the gain)

For activating ssh you can do:

sudo systemctl enable ssh
sudo systemctl start ssh

Then you just put the IP-address in putty and connect.


#18

If there is a way for you to remote into my pi to look around, and poke/prod it, I’d certainly be willing to open any cybernetic doors that might be needed for proper access and control.

Yes, IIRC, Windows insists on using CRLF (0x0D 0x0A) and the Unixes all use LF (0x0A or /n). I think that there are little utilities that will properly strip out these bad boys before shipping the files off to the ux world. If not, I’d write one(!)


#19

I mean you could forward a port and i could ssh in, but i wouldn’t want to encourage it, even if many people run shell scripts that they don’t understand on their machines at least they are public.

Anyway you’ll learn to maintain it along the way and probably notice you don’t need any gui :slight_smile:


#20

Oh i read your first post again.
If you want to run a GUI i would go with a raspbian sd card image and then install piaware instead of getting the piaware sd-card image.