FlightAware Discussions

Graphs1090 Connection Port

I need to port forward graphs1090. I couldn’t find the port in the graphs1090 docs.

I was able to port forward tar1090 using port 8080

CORRECTION
I was able to port forward SkyAware using port 8080.

The website is on whatever port lighttpd is set to.
That’s normally the default http port 80.

It’s not reachable at / but only at /graphs1090 or /perf.
It’s not too hard to configure lighttpd to put it somewhere else …

I’ve tried to change the port from 80 to 8085 in lighttpd.conf but still get 403-Forbidden. How can I get around this error so I can use graphs1090 remotely?

Did you restart it …?

Why don’t you forward port 80?

Yes I restarted lighttpd. That didn’t work so I rebooted. No joy.
I forwarded port 80 and still get 403-Forbidden.
I believe the forwarding works, but the 403 error is due to a security setting in lighttpd or a permission setting in Buster. I’m not techie enough to know how to fix it.

You checked /graphs1090/ ?

Try accessing the page locally:

wget -S http://localhost/graphs1090/index.html
--2020-03-02 17:52:54--  http://localhost/graphs1090/index.html
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:80... connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 200 OK
  Server: nginx/1.16.1
  Date: Mon, 02 Mar 2020 16:52:54 GMT
  Content-Type: text/html
  Content-Length: 7703
  Last-Modified: Mon, 02 Mar 2020 11:29:44 GMT
  Connection: keep-alive
  ETag: "5e5cee28-1e17"
  Accept-Ranges: bytes
Length: 7703 (7.5K) [text/html]
Saving to: ‘index.html’
wget -S http://localhost:99/graphs1090/index.html
--2020-03-02 17:53:19--  http://localhost:99/graphs1090/index.html
Resolving localhost (localhost)... ::1, 127.0.0.1
Connecting to localhost (localhost)|::1|:99... connected.
HTTP request sent, awaiting response... 
  HTTP/1.1 200 OK
  Vary: Accept-Encoding
  Content-Type: text/html
  Accept-Ranges: bytes
  ETag: "1923325813"
  Last-Modified: Mon, 02 Mar 2020 11:29:44 GMT
  Content-Length: 7703
  Date: Mon, 02 Mar 2020 16:53:19 GMT
  Server: lighttpd/1.4.54
Length: 7703 (7.5K) [text/html]
Saving to: ‘index.html.1’

Really, if you have a default Raspbian Buster setup with lighttpd, i see no reason for 403
Maybe you screwed up the configuration?
Undo all your changes :wink:

I’ve had the default Buster configuration (not lite) installed since it was first released. The only changes I’ve made were to enable ssh, configure wifi and install apps. In addition to your enhancements I’ve installed CUPS, RPi Monitor and RDP/VNC. The systems update and upgrade automatically using apt.

I have no problem accessing graphs1090 from the local lan at 192.168.xx.xx/graphs1090. I get 403-forbidden with 192.168.xx.xx:80. This is on 3 identical RPi 4 B and 1 RPi 3 B+ systems.

I need to forward the port because there are other ports that are forwarded to the same IP address.

Could adding a port to /etc/lighttpd/conf-available/88-graphs1090.conf fix port forwarding?

$SERVER[“socket”] == “:8085” { # Add this line to 88-graphs1090.conf
alias.url += (
“/graphs1090/graphs/” => “/run/graphs1090/”,
“/graphs1090/” => “/usr/share/graphs1090/html/”,
)

I hesitate trying it because I’m not lighttpd knowledgeable and it might brick the system.

/graphs1090 is the exact same as :80/graphs1090

So you just forward port 80 and then add /graphs1090 to the IP that is being forwarded …
I really don’t understand the issue.

You forward port 80 and then add /tar1090 or /graphs1090 like you would when regularly accessing it.
If you locally can’t access /, the forward won’t change that.

1 Like

OK, that work around functioned. Still, it would be better if one could access the page by port number the way FlightAware and RPi Monitor work. Just connecting to port 80 does not work. Evidently there is no default page defined.

Thanks for your help.

That’s basically the correct approach.

To have it at / you need to modify it a bit.

“/graphs/” => “/run/graphs1090/”,
“/” => “/usr/share/graphs1090/html/”,

Just give it a try … you can always just reinstall graphs1090 and it will overwrite that configuration file.

I am forwarding the tar1090 to Port 80 and that my router can serve to the Internet.