FlightAware Discussions

Graphs for dump1090 -- my version with install script

Maybe the hits were accounted for differently with the older amd64 fr24feed client.
Let’s see if it changes now that you are using the arm client.

Also i stopped collectd on accident -.-, now i have to wait 7 days for my graphs to get pretty again! :stuck_out_tongue_winking_eye:

Oh well, my graphs always look like crap when i’m working on the code.

1 Like

I ran fr24feed on a RPi3 to get MLAT (that will change tonight). I ran the airspy on the same Pi before, with no difference. But we’ll se…

Don’t know how many times services has been stopped and you try to figure out why things fail :crazy_face:

Is it possible for the graphs to display local time, rather than GMT? I always forget whether the US Pacific time zone is GMT -7 or -8 for a given time of year.

They display the timezone set on the computer it’s installed on.

This should help you out:

sudo raspi-config

Thank you, sorry I missed that.

The graph y-axis is adjusted automatically based on the values received.
Is there a way to limit this behavior or making the steps smaller?

My number of aircraft is going to values between 120 and 135
But for this the chart goes up to 200 from 120 to show them.

I would now limit this graph to e.g. 150 ny myself or giving a smaller step from 120 upwards.

Possible? If yes, how?

Check the lower half of /etc/default/graphs1090

There i can adjust the graph size itself, but not the scaling, of the y-axis, or?

 40 # set custom y-axis upper limits for the individual graphs
 41 # for automatic upper limits leave them blank
 42 ul_message_rate=2200
 43 ul_aircraft=200
 44 ul_tracks=1000
 45 ul_range=250
 46 ul_maxima=2200
 47 ul_rate_per_aircraft=30
 48 ul_adsb_cpu=100 

These lines are not in the file i have.
Do i have to add the lines at the end?

# after saving this file, run
# sudo /usr/share/graphs1090/boot.sh
# to update the graphs and web interface

# set to 1 to enable farenheit instead of celsius
farenheit=0

# set range graph to either nautical, statute, or metric
range=nautical
# set the right axis unit: (leftaxis, nautical, statute, metric)
range2=metric

# set graph size, possible values: small, default, large, huge, custom
graph_size=large

# make the small graphs as large as the big ones
# run "sudo /usr/share/graphs1090/boot.sh" to adjust the web interface
all_large=yes

# font size, default 10.0 (relative to graph size)
font_size=11.0

# set to 1 to draw a reference line at the maximum message rate
max_messages_line=0

# if graph_size is set to custom, the following sizes are used:

# large graph dimensions are the actual graph area
# define the width of the larger graph, default is 1096, 960 also looks good in my opinion
lwidth=1400
# define the height of the larger graph, default is 235
lheight=450

# small graph dimensions are the actual total size
# width, default 619
swidth=850
# height, default 324
sheight=300

Just reset the configuration as described below:

https://github.com/wiedehopf/graphs1090#configuration-optional

Do whatever, i don’t care. You should be able to figure it out :wink:

I am, thanks :wink:

Working…