Gotta kick my pi 3 in the pants every few hours

I am running a 2.5 amp power supply with a pi 3 16 gig microsd card and a fa pro sick with a fa filter and a fa antenna

it all boots up and works good
then i get nothing after a while
so I manually reboot it from the fa website and all goes well foe a couple of hours
i have high speed internet and I am using the built in wifi on the pi 3

i am running 2.15 jessie latest one

[2016-04-23 23:41 PDT] mlat(1003): Reconnecting in 30.0 seconds
[2016-04-23 23:41 PDT] mlat(1003): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
[2016-04-23 23:41 PDT] no ADS-B data program seen listening on port 30005 for 180 seconds, next check in 60s
[2016-04-23 23:41 PDT] mlat(1003): Connection to localhost:30005 lost: [Errno 111] Connection refused
[2016-04-23 23:41 PDT] mlat(1003): Reconnecting in 30.0 seconds
[2016-04-23 23:41 PDT] mlat(1003): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
[2016-04-23 23:42 PDT] 13181 msgs recv’d from dump1090 (31 in last 5m); 13165 msgs sent to FlightAware
[2016-04-23 23:42 PDT] mlat(1003): Connection to localhost:30005 lost: [Errno 111] Connection refused
[2016-04-23 23:42 PDT] mlat(1003): Reconnecting in 30.0 seconds
[2016-04-23 23:42 PDT] mlat(1003): Beast-format results connection with localhost:30104: [Errno 111] Connection refused

tech supp0rt is busy

I just want to get back to normal rock solid operations


If you are able to reboot the pi via command from the FA website, that tells me the network side of things is working.

The simplest thing I can think of next would be to move the dongle to a different USB port and reboot the pi. See if that helps.

tried that
tried going direct stick to pi using the usb ports
and using a 3 foot high quality usb extender cable to get the stick away from my monitors and stuff
still happens.
even tried a rtl.sdr stick with tcxo and still happens.

Have you tried using a different power supply yet? Many RPi issues are caused by bad, poor quality, or dying power supplies.

I had a issue where my RPi 2 model B would boot normally but not feed FA due to a dying power supply. The power supply was less then 30 days old. Since that issue I got a good quality RPi power supply and also added a powered USB hub for my dongle. I’ve had no issues for over a year now.

FYI, my dongle is mounted on my antenna mast just below the antenna and is connected to my RPi in my house using a 32 foot USB extension cable.

Suggestion 1

use wifi check script (link and instructions below)

Suggestion 2.

you could also ping your router with a job in cron to run every minute to keep connection alive

crontab -e

add the line

* * * * * /ping ­c2 > /dev/nul

Ctrl x and y to save

the code above works if your router has the ip of,if its different, substitute the address for yours.

Yep - second that - power supply issues will be big with the Pi 3 :open_mouth: Use a good 2.4 Amp supply at least.

A majority of Raspberry Pi issues are related to power supplies and USB cables running from the power supply to the Pi.

Use a good, calibrated digital voltmeter and measure the voltage at the Raspberry Pi, such as GPIO pins 2 (+5) and 6 (ground) while the Pi and anything hooked up to it is running.

You should read at least 4.8 Volts. If you read below 4.8 Volts, you have a not-so-good power supply, or USB cables that introduce too much voltage drop.

bob k6rtm

I am using a new canakit 2.5 amp supply ( have 2 new ones )

I am always able to reboot the unit from the website and it works for 12 hours or so then blammo down it goes
then I reboot from the website and I am good for another 12 hours or so
It does not have any problems where there is a ton of air traffic only when there is none to very minimal traffic ( 4 to 6 am usually )

also the window where it shows the aircraft being heard on the right side sometimes fills up with data slowly ( false data ) for 5 or 10 seconds then it slowly boils down to what is actually out there.

I think that this might be a software issue ( i don’t know )

i also have connected the pro stick directly to the pi 3 with no usb cable and still have the same problems.

funny thing is you try to stay current and have something better where the older pi 2 unit with the older pi aware version was rock solid !!!

I also changed the mlat over to 30104 seems to have helped

no I just get what is happening above

thanks for your guidance guys !!!

Symptoms of 2 things I think,

  1. Wifi system of the pi is going into power save/sleep mode.

You can put this right by opening

sudo nano /etc/network/interfaces

add this line below the settings for wlan0

wireless-power off

then restart networking to the pi

sudo /etc/init.d/networking restart

then check power saving is set to off on wlan0 by viewing the output of


  1. Low traffic causing a break in wifi comms from pi-router / router-pi

Follow steps in my previous post further up this thread to keep wifi connection active during low station demand.

Re: rebooting PI
I have changed Power supply, HUB, PI, SD, SDR and my PI is still rebooting.
Its rebooting because it was hanging which required me to do something, so
I added the internal watchdog. So instead of a hang I get a clean reboot.
The watchdog is doing a ping of its router every 3 seconds so if network
is broken I loose 4 pings an it reboots.
I’m not using wlan0, and I have 2 ethernets (1 internal, and 1 via USB)
The network gets wedged If I have internal, or external, or both running.

It reboots about once or twice a week unless I turn MLAT on. Then it
reboots a few times per day :frowning:

Check /var/log/syslog for the reason why it reboots

for me, its the USB Dongle broken, so it keeps rebooting until I RMA

Looking at the syslog I see that the PI did not
get any reply from pings. TCPDUMP on
another host shows no PING REQUEST.

Whats on the USB bus…

  1. the SDR dongle
  2. a USB->ethernet (second ethernet dongle)

I can remove the second ethernet (so i’m left
with just the onboard ethernet) and still get
the same problem (ie hang without watchdog,
and reboot if watchdog start).

PS I have run TCPDUMP (apt-get install tcpdump)
and when the problem occurs I no longer see
any ICMP ECHO REQUEST packets leaving the

PPS once the PI is hung (no watchdog) all I
see of a new incoming ssh is the first SEQ
packet. I don’t see the SEQ/ACK packet
sent from PI.