FlightAware Discussions

Feed cuts out on a regular basis

I don’t think you need spectrum testing.
Well actually, install the most recent version of graphs1090, a couple months back i re-added the noise floor graph.
If it goes to -0 that means it’s interference.
Well or the LNA only producing noise i suppose.

I wouldn’t expect the rtl-sdr LNA to be overwhelmed by interference, it’s very unlikely.

I think you’re on to something:

Last 48 hours:

ADS-B Signal Level noise 48 uur

Last 24 hours:

ADS-B Signal Level noise 24 uur

I’m trying to pinpoint when it al started. First the same graph for the last 3 months:

ADS-B Signal Level noise 3 maanden

So once or twice in May. But it really starts going in the middle of July:
(Graph is the last 30 days)

ADS-B Signal Level noise 30 dagen

I haven’t changed anything to the setup in since I installed it this way on December 11, 2020.
The only thing changed is that I installed the case fan on June 26 which lowered the maximum core temp with about 10-15 degrees.

So, anyone a clue what causes the interference, interference is something I really don’t know much about…

Might well be the LNA being defect.

What’s the exact models you use again?

Did it start when you turned on the fan?

If that is the only thing that has changed it is possibly the noise source.

S.

All the hardware I use:

  • RPi 3B+ (connected to network via Wifi)
  • Transparant case with fan
  • FlightAware Pro Stick (orange)
  • Bias tee injector
  • RTL-SDR LNA
  • FA antenna

Indoor setup: Raspberry 3 with ADS-B | Iemand91 | Flickr
Outdoor setup: FlightAware antenne with LNA | Iemand91 | Flickr
(LNA is in a waterproof box)

You can see in the above graphs the problems started sometime around middle of July, whereas I installed the fan on June 26.

Perhaps try and run without fan for a few days?

1 Like

How did you connect the fan. On the product page of the case it is connected to two gpio-fans, which cannot be right.

There are power pins in the GPIO header.
Those can be used for a 5 V fan without issue.

But yes, i’d try disconnecting it as well to exclude it as a noise source.

Yes, but in the picture of the manufacturer it is connected to 6 and 7 on the row closer to the CPU, that cannot be right. :thinking:

Yes, I have the fan connected to 5V and ground. And I have disconnected the fan but still no good.
Here is the last 8 hours:

ADS-B Signal Level avond

So with the fan unplugged, still no good. Still going up and down.
Any idea what else can cause the noise?

Has someone changed their lighting?

1 Like

It might getting worse: Iemand91 ADS-B Feeder Statistics - FlightAware

I haven’t got a clue what causes the noise. (that goes up when the feed goes down; so I’m assuming that’s what causes the problemes)
It shouldn’t be a physical issue with the setup right, since when the system is working; I get good results.

But the feed dropping is so annoying, I don’t want a system that isn’t functioning right, I get emails from the several sites I feed that the feed has dropped and (first world problem) my current streak might get to 0 at some point.

Anyone got a clue?

Just a suggestion, did you try to see the result with a wired ethernet connection versus the wireless connection ?

I sometimes see issues with the wireless connections.

That can’t be it since the graphs don’t rely on a network connection.

EDIT: a reboot through FA site information didn’t change a thing, but I just did a manual reboot (I wanted the change the RPi3 with the old RPi but I can’t right now (no build-in Wifi and cable to short to power the bias tee) and plugged the power back in the RPi3 and now feeding again.
Sometimes that fixes the problem, sometimes not…

I just don’t know what the cause is for my problem…

And down again. I removed the FA stick and plugged in my old DVB-T dongle with antenna and still nothing, even after a reboot.

So the problem is not the power supply (I replaced it with official RPi power supply), nothing after the USB-port (FA dongle + bias tee + coax + (outside) LNA + antenna; since the problem persists when I replace all that with and old DVB-T dongle + antenna).

So maybe either the RPi (I might be able to swap it with an old RPi if I can run some ethernet to it since it has no build-in Wifi), the SD-card, some firmware/software-issue or external influence.

For the last few days I’ve disconnected the FA stick/outside antenna and used the old DVB-T stick with antenna.
I get VERY poor results of course, but looking at the graphs, it might have to look at the FA stick/bias tee/coax/LNA/antenna situation?

Last 7 days:
image

Last 24 hours:
image

I’m seriously no idea what to do anymore…

I would.start to eleminate one item at a time. So start with removing the LNA in the chain and see what it does in 24 hrs. Since you need to feed it, you can also exclude the power feed as a source of creatieve noise. If the problem persists move to the next item in the chain. It will take some time but in the end you will find the item that is causing the issue.

Have you been able to make any progress on this issue ?
Just wondering

No not really, haven’t really looked at it either. Currently disconnected the FA stick (and bias tee - LNA - FA antenna) and using a cheap DVB-T stick with cut antenna.
Really poor reception but at least it’s not crapping out for hours on end.

So the problem is likely somewhere between (and including) the FA stick and FA antenna, or issue with powering the bias tee (that gets it’s power from the GPIO pins so probably not).
Solving it likely requires me to climb up the roof which I’m not looking forward to, so that’s probably why I haven’t done anything about it yet :roll_eyes: